Signaler

Filtre sur 2 colonne dans excel [Résolu/Fermé]

Posez votre question laetitia - Dernière réponse le 4 mai 2009 à 23:05 par tochapjacques
bonjour a tous,
j'aimerais savoir si c possible de faire ceci sur excel sur mac.....
je voudrais mettre un filtre sur une meme ligne mais dans 2 colonnes differente.
en fait je dois associer des prix a des objets,donc quand je choisirais un objet dans le filtre,ba j'aurais le prix automatiquement qui s'afficherais dans la colonne d'a cote.
en gros,il faudrais que je creer une sorte de base de donnee.
j'espere que mon explication est comprehensible car c la galere au boulot,ca fait 3 jours que je planche dessus lol.
merci de votre aide!
Utile
+3
plus moins
Bonsoir,

Une solution serait d’utiliser la fonction "recherchev" .

Exemple simple:

Supposons que, après sélection à partir du menu déroulant, le nom de l’article s’affiche dans la case C21, et que tu veux voir le prix s’afficher dans D21

Et supposons que ce nom a été pris dans une plage A2 à A16
Idéalement les prix correspondant seront placés juste à coté, donc entre B2 et B16
La plage contenant à la fois le nom et son prix est donc A2:B16 = colonne A pour les noms et colonne B pour les prix.

Il faut donc que le fonction recherchev trouve le nom affiché en C21, dans la plage A2:A16 et que Excel affiche en D21 le chiffre trouvé en face du nom dans la plage B2:B16

Donc, tu insères dans la cellule D21 la formule suivante : =RECHERCHEV(C21;A2:B16;2)

Recherchev veut dire : fais une recherche verticale
C21 veut dire trouve la même valeur, (le même nom), que celle qui se trouve dans C21
A2:B16, veut dire trouve cette valeur, (ce nom), dans la plage A2 à B16
2, veut dire affiche le contenu se trouvant dans la deuxième colonne de la plage.

En supposant par exemple que la 1ère colonne contienne le nom et la deuxième colonne contienne le prix.
Si le prix est contenu dans une colonne plus éloignée, il faudra changer le chiffre 2 pour qu’il corresponde à la colonne exacte. Note que cette colonne devra toujours se trouver à droite de la colonne contenant les noms.

Cordialement
Cette réponse vous a-t-elle aidé ?  
Utile
+1
plus moins
Bonjour,
Je pense que nous sommes d'accord. Le signe dollar verrouille au choix , soit les rangs, soit les colonnes, soit les 2.
Mais dans le cas d'un devis à plusieurs articles , nous aurons plusieurs lignes possibles, faisant dans cet exemple, toutes références à une même plage, c'est à dire A2:B16. Que cette plage soit verrouillée, très bien, ça ne mange pas de pain. Mais c'est l' adresse C21 qui en fait va être changée.
Explications, si la première ligne du devis doit se référer au contenu, le nom de l'article, se trouvant dans C21, la deuxième ligne fera probablement référence à la cellule C22, et la ligne suivante , à la cellule C23 etc...
et donc pour C21, seule la colonne devra être verrouillée.

Nous aurons une formule
en D21: =RECHERCHEV(C21;A2:B16;2)
en D22: =RECHERCHEV(C22;A2:B16;2)
en D23: =RECHERCHEV(C22;A2:B16;2)

ou encore :
en D21: =RECHERCHEV($C21;$A$2:$B$16;2)
en D22: =RECHERCHEV($C22;$A$2:$B$16;2)
en D23: =RECHERCHEV($C23;$A$2:$B$16;2)

L'avantage de cette dernière façon de procéder, est de permettre de copier , une fois écrite, la cellule D21, et de la recoller sur autant de lignes que souhaité, vers le bas, sans risque puisque toutes les adresses qui doivent l'être sont verrouillées.

Voilà, je crois que maintenant Fashi0nata sait tout ce qu'il faut. Pour ce cas précis ...en tous cas.



Cordialement
Utile
+0
plus moins
j'ai aussi oublie de preciser que c t pour un devis,donc il me faudrais ce filtre sur chaque ligne de la colonne descrition des objet,comme ca j'ai juste a choisir mon objet et il s'affiche directement avec le prix correspondant.
voila!
laetitia- 5 mars 2007 à 11:57
ok c gentil!
merci beaucoup.
broeckenar 18Messages postés mardi 7 janvier 2003Date d'inscription 8 mars 2007 Dernière intervention - 5 mars 2007 à 16:09
Es-tu membre enregistré sur le forum?
Parce que dans ce cas, je te passerais mon mail pour te passer le modèle.

@+
laetitia- 6 mars 2007 à 13:28
ah non je ne me suis pas enregistre car c t juste occasionnel...... je vais le faire.
ratoulafripouille 1Messages postés mardi 6 mars 2007Date d'inscription 6 mars 2007 Dernière intervention broeckenar - 6 mars 2007 à 13:35
voila!me suis inscrite mais sous un autre pseudo car celui d'avant ete deja pris.donc maintenant tu peux me passer le mail pour l'exemple!
c super simpa de m'aider :)
broeckenar 18Messages postés mardi 7 janvier 2003Date d'inscription 8 mars 2007 Dernière intervention broeckenar - 6 mars 2007 à 16:49
Salut laetitia,

Je viens de t'envoyer le mail.

Bonne fin de journée.
J'attends ton feedback.
Utile
+0
plus moins
Merci à tous ceux qui pourront m'aider je vous explique mon soucis:
J'ai un fichier excel qui me sert de devis j'ai une colonne avec les articles(et un menu déroulant qui pioche dans une feuille de calcul) et une autre colonne avec les prix que je rentre manuellementt
J'aimerais selectionner dans le menu déroulant un article et que automatique dans l'autre colonne de prix s'affiche le prix.

mon mail: peaches.n.cream@hotmail.fr

J'ai vraiment besoin d'aide
Utile
+0
plus moins
Salut Fashi0nata et Sanspseudo - Francis,

J'ai répondu en mars à la question de laetitia, et je crois que je l'ai expliqué au-dessus.
La réponse de Sanspseudo - Francis est valable également, simplement, si tu veux que la formule se répéte en verticale, c-a-d, si ton devis contient plus d'un article, il faudra penser à vérouiller la plage de sélection pour la recherche verticale, afin de copier et coller cette formule verticalement.

Dans ce cas, il faut penser à changer la formule comme suit:

=RECHERCHEV(C21;$A$2:$B$16;2)

Le symbole $ bloque consécutivement la colonne et la ligne, c'est tout.

J'espère être clair, sinon, vous pouvez revenir vers moi et je tâcherai de vous envoyer un exemple.
Cordialement,
Utile
+0
plus moins
j'ai des données, chiffres dans deux colonnes, colonne A ce sont les
donnes d'une base de données, c'est les données de base. Dans la
colonne B j'ai également des chiffres qui viennent d'une autre base de
données.
j'aimerais mettre sur la même ligne les mêmes chiffres, c'est à dire,
au départ les données sont présentées ainsi :
colonne A : 132981 - colonne B : 432981
colonne A : 332981 - colonne B : 532981
colonne A : 932981 - colonne B : 732981
colonne A : 432981 - colonne B : 932981
colonne A : 732981 - colonne B : 132981
colonne A : 532981 - colonne B : 332981
etc...
je veux les présenter de cette manière :
colonne A : 432981 - colonne B : 432981
colonne A : 532981 - colonne B : 532981
colonne A : 732981 - colonne B : 732981
colonne A : 932981 - colonne B : 932981
colonne A : 132981 - colonne B : 132981
colonne A : 332981 - colonne B : 332981
Pouverz-vous m'aider j'ai des données, chiffres dans deux colonnes, colonne A ce sont les
donnes d'une base de données, c'est les données de base. Dans la
colonne B j'ai également des chiffres qui viennent d'une autre base de
données.
j'aimerais mettre sur la même ligne les mêmes chiffres, c'est à dire,
au départ les données sont présentées ainsi :
colonne A : 132981 - colonne B : 432981
colonne A : 332981 - colonne B : 532981
colonne A : 932981 - colonne B : 732981
colonne A : 432981 - colonne B : 932981
colonne A : 732981 - colonne B : 132981
colonne A : 532981 - colonne B : 332981
etc...
je veux les présenter de cette manière :
colonne A : 432981 - colonne B : 432981
colonne A : 532981 - colonne B : 532981
colonne A : 732981 - colonne B : 732981
colonne A : 932981 - colonne B : 932981
colonne A : 132981 - colonne B : 132981
colonne A : 332981 - colonne B : 332981
Pouvez-vous m'aider S V P Merci
broeckenar- 1 sept. 2008 à 00:30
Bonsoir,

Merci de bien vouloir m'envoyer un exemple du fichier au format Excel et je vous le renverrai avec des commentaires.
Je mettrai ensuite tous les commentaires sur ce forum.

À bientôt.
Merci

B.
Utile
+0
plus moins
Bonjour tous le monde je voudrais savoir si c'est possible de faire un filtre horizontal je dis bien horizontal et non vertical
exemple si mes donnes sont sur les cellules A3, B3, C3, D3, j'aimerais savoir si c'est possible de faire filtre pour afficher les donnes d'une seul colonne par exemple

merci d'avance mesdames messieurs
Utile
+0
plus moins
A B C D E F
1 03/14/2009 19:20:40 208 X
2 03/14/2009 11:50:40 133 X
3 03/14/2009 07:29:08 161 X
4 03/13/2009 19:40:16 131 X
5 03/13/2009 12:09:48 103 X
6 03/13/2009 06:52:32 269 X
7 03/12/2009 20:10:00 104 X
8 03/12/2009 11:57:24 86 X
9 03/12/2009 05:41:24 187 X
Ci il a une personne qui pourrait ne donner une formule pour délasser les cellules c1 à c9 dans les cellules D E F
Couleur Bleu de 18 h 00 mn 00 s à 21 h 00 mn 00 s heure dans les cellules D 1-4-7.
Couleur Jaune de 11 h 00 mn 00 s à 14 h 00 mn 00 s heure dans les cellules E 2-5-8.
Couleur Rouge de 05 h 00 mn 00 s à 08 h 00 mn 00 s heure dans les cellules F 3-6-9.
Je vous remercie d’avance pour résoudre mon problème

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !