CommentCaMarche
Recherche
Posez votre question Signaler

Les arrondis sous Excel [Résolu]

SweetRom 152Messages postés lundi 6 juin 2005Date d'inscription 20 décembre 2006Dernière intervention - Dernière réponse le 7 janv. 2015 à 18:35
Salut à toutes et à tous,
je travaille sur Excel, et je suis incapable de gérer les arrondis, et je voulais donc savoir s il existe un manip pour qu il n arrondisse plus au dessus, mais au dessous.
exemple : 12.3625 = 12.36

Par avance merci beaucoup.
Lire la suite 
Réponse
+65
moins plus
Salut,

tu as deux possibilitées :

=TRONQUE($cellule;nb_après_la_virgule) »
=TRONQUE(A1;2)


=ARRONDI.INF($cellule;nb_après_la_virgule) »
=ARRONDI.INF(A1;2)


On peux jouer avec le nombre après la virgule :
Pour le nombre 123,568
;2 » affiche 123,56
;1 » affiche 123,5
;0 » affiche 123
;-1 » affiche 120
;-2 » affiche 100
...

et =ARRONDI.SUP(a1;2) fonctionne pareil dans l'autre sens :)
HLW- 6 juil. 2011 à 18:22
Euhm, faut-il taper la fonction pour chaque cellule ? Car j'ai tout un tableau de chiffres à arrondir ><
Répondre
romainlabe 9Messages postés mercredi 17 novembre 2010Date d'inscription 7 septembre 2011Dernière intervention - 7 sept. 2011 à 15:30
Dans le coin en bas à droite, tu as une petite croix noire. Tu peux à l'aide de celle-ci sélectionner les cellules pour lesquelles tu veux mettre la même fonction.
Répondre
tunibel- 14 févr. 2014 à 09:06
autre cas plus complexe, pour arrondir un nombre qui est un résultat d'une formule ex : a1/b1.
comment intégrer la fonction arrondir tantôt vers 0 tantôt vers +0?? merci
Répondre
Eulogezone- 7 janv. 2015 à 18:35
On peu aussi utiliser les fonction plafond et plancher pour faire des arrondi
Répondre
Ajouter un commentaire
Réponse
+32
moins plus
Bonjour,

Excel n'arrondi pas les nombres par défaut. Il conserve la valeur complète, l'arrondi apparent est généré par le format d'affichage de la cellule. EX:

3,2345678 est AFFICHE 3,24 si le format donne 2 décimales
3,2345678 est AFFICHE 3,2346 si le format est de 4 decimales.
TOUT LES CALCULS SE FONT SUR LA VALEURS GLOBALE 3,2345678.


Pour ARRONDIR REELLEMENT UNE VALEUR il faut utiliser la fonction:

ARRONDI(nombre;no_chiffres)

nombre représente le nombre à arrondir.

no_chiffres spécifie le nombre de chiffres auquel vous voulez arrondir nombre.


Si no_chiffres est supérieur à 0 (zéro), nombre est arrondi au nombre de décimales indiqué.
Si no_chiffres est égal à 0, nombre est arrondi au nombre entier le plus proche.
Si no_chiffres est inférieur à 0, nombre est arrondi à gauche de la virgule.
Exemple

L'exemple sera plus compréhensible si vous le copiez dans une feuille de calcul vide.


FORMULE (résultat)
=ARRONDI(2,15;1) Arrondit 2,15 à une décimale (2,2)
=ARRONDI(2,149;1) Arrondit 2,149 à une décimale (2,1)
=ARRONDI(-1,475;2) Arrondit -1,475 à deux décimales (-1,48)
=ARRONDI(21,5;-1) Arrondit 21,5 à une décimale à gauche du
séparateur décimal (20)


Arrondit un nombre en tendant vers 0 (zéro).


ARRONDI.INF(nombre;no_chiffres)

nombre représente un nombre réel quelconque à arrondir en tendant vers zéro.

no_chiffres représente le nombre de chiffres à prendre en compte pour arrondir l'argument nombre.

Notes

La fonction ARRONDI.INF est similaire à la fonction ARRONDI, excepté qu'elle arrondit toujours le nombre en tendant vers zéro.
Si l'argument no_chiffres est supérieur à 0 (zéro), le nombre est arrondi à la valeur entière immédiatement inférieure (ou supérieure pour les nombres négatifs) et comporte le nombre de décimales spécifié.
Si l'argument no_chiffres est égal à 0, le nombre est arrondi au nombre entier immédiatement inférieur.
Si l'argument no_chiffres est inférieur à 0, le nombre est arrondi à la valeur immédiatement inférieure (ou supérieure si négative) par incrémentations de 10, 100, etc., en fonction de la valeur de no_chiffres.


L'exemple sera plus compréhensible si vous le copiez dans une feuille de calcul vide.


Formule (résultat)
=ARRONDI.INF(3,2;0) Arrondit 3,2 à la valeur entière
immédiatement inférieure (3)
=ARRONDI.INF(76,9;0) Arrondit 76,9 à la valeur entière
immédiatement inférieure (76)

=ARRONDI.INF(3,14159;3) Arrondit 3,14159 à la valeur inférieure
comportant trois décimales (3,141)




---------------That's all Folk...---------------
Valendil- 19 déc. 2011 à 11:38
Ceci est la réponse ! Un "vrai" arrondi. Merci JPM!.
Répondre
Ajouter un commentaire
Réponse
+4
moins plus
Merci pour la formule, je comprends l utilisation, mais du coup survient un autre probleme :
Je veux arrondir le résultat d un calcul , et si je tape ARONDI(Nombre;no_nombre)b4*b5*b6, j ai en fait mon resultat qui est multiplié par l arrondi...

puis je utiliser le AND pour faire cohabiter mes deux formules?
Merci
Kat- 26 sept. 2013 à 11:04
La formule marche également avec des calculs, pas simplement des cellules.
Il suffit de taper =arrondi(b4*b5*b6;no_nombre) et tu auras ton résultat.
Répondre
Ajouter un commentaire
Réponse
+3
moins plus
Bonjour
petit exemple:
de A1 à A12 la liste des chiffres de votre exemple
en B1 la formule:
=INDEX($A$1:$A$12;EQUIV(C1;$A$1:$A$12)+1;)
devrait vous donner la correction cherchée quand vous entrez une valeur en C1
A appliquer bien sur sur la hauteur du champ utile.
Crdlmnt
Bergamott- 5 mars 2010 à 15:28
Merci beaucoup pour cette aide Vaucluse.
Afin d'arrondir à la valeur supérieure, j'ai utilisé le -1 (paramètre de la fonction EQUIV) qui me permet de faire exactement ce que je voulais!
Encore Merci!

=INDEX($A$1:$A$12;EQUIV(C1;$A$1:$A$12;-1))
Répondre
Ajouter un commentaire
Réponse
+2
moins plus
salut
Utilise la fonction "ARRONDI.INF" dans la cellule qui reçoit ton résultat(cherche cette fonction pour le paramétrage)
Joel
Ajouter un commentaire
Réponse
+1
moins plus
Merci à tous pour votre aide. Ca fait des années que je cherche à faire des arrondis à la 10ène supérieur ou inférieur.

ca va grandement me facilité la vie

voici la formule que j'ai utilisée

=SI(((N-ARRONDI(N;-1))<=5);ARRONDI(N;-1);ARRONDI(N;-1)-5)
N étant la cellule de référence

résultat
181 = 180
182 = 180
183 = 180
184 = 180
185 = 180
186 = 190
187 = 190
188 = 190
189 = 190

cordialement
Bergamott- 5 mars 2010 à 15:37
Ptite souris...

Pour faire ce que tu souhaites faire, tu peux utiliser les fonctions PLAFOND et PLANCHER

Exemple: PLAFOND(Chiffre, 10) arrondi à la dizaine au dessus
PLANCHER(Chiffre, 10) arrondi à la dizaine en dessous

On peut bien sur changer le "10" par "100" pour arrondir à la centaine ou même le changer par "37" pour arrondir à un multiple de 37!!
Répondre
Gaetan- 15 févr. 2011 à 16:00
la fonction arrondi fonctionne aussi pour les dizaines et centaines. par exemple :
=ARRONDI(184;-1) vaut 180
=ARRONDI(184;-2) vaut 200
=ARRONDI(149;-2) vaut 100
Répondre
Ajouter un commentaire
Réponse
+1
moins plus
Bonjour à tous,

des vrais génies sur ce site !!!!

mais je n'ai pas trouvé ce que je cherche...

Mon problème:

Je voudrais arrondir un nombre mais avec une condition qu'il soit divisible par 1.5 !!

Par exemple:

100/(2.3-1) = 76.92...
si j'arrondis avec la formule =ARRONDI(H12/(J12-1);0), cela me donne un résultat de 77.00 mais 77 n'est pas divisible par 1.5 car j'obtiens 51.333333333333 !!

En fait, je voudrais obtenir 75 ou même 76.5, ou encore 78 qui est divisible par 1.5, enfin vous comprenez quoi !

Merci beaucoup pour votre réponse collective.
JLO
Maya2012- 17 déc. 2012 à 15:51
@JLO :
la règle est tjrs la même :
si tu veux arrondir à 1.5 près, divise d'abord par 1.5, fait l'arrondi, et remultiplies par 1.5...
=arrondi(A1/1.5;0)*1.5
Répondre
Ajouter un commentaire
Réponse
+0
moins plus
Un Immense merci à tous pour votre disponiblité et votre aide précieuse.

J ai trouvé mon bonheur et je peux poursuivre mon travail.
Encore un grand merci à vous tous

Acharge de revanche... ; )
Ajouter un commentaire
Réponse
+0
moins plus
Bonjour
mon probleme sous excel tient aussi des arrondis mais moi je souhaiterai arrondir107406910 à un multiple de 5000 le plus proche soit 107405000
Merci
OBLOIS- 11 avril 2008 à 10:28
Bonjour Cyril,

as-tu essayé la formule =MROUND(Ton_chiffre;5000) ?

cordialement,
Répondre
Ajouter un commentaire
Réponse
+0
moins plus
Bonjour,

Personnellement, je cherche à arrondir de cette manière :

Si 14 835,43 € --> Arrondir à 14 800 €
Si 12 587,20 € --> Arrondir à 12 600 €

Comment faire?
Bergamott- 5 mars 2010 à 10:59
ARRONDI(14 835,43; -2) devrait donner 14 800
et ARRONDI(Si 12 587,20 €; -2) donnera 12 600

J'espère que ca répond à ta question...

Pour ma part je souhaiterais arrondir à la valeur supérieure dans une liste de valeurs.
Par exemple si la liste est la suivante: 10;16;20;25;32;40;50;63;80;100;125;160
Je souhaiterais que la formule associe 16 à une valeur comprise entre 10 et 16, 20 à une valeur comprise entre 16 et 20, etc.

Merci de vos réponses.
Répondre
Ajouter un commentaire
Réponse
+0
moins plus
Vous avez raison,Bergamott, mais pour appliquer celle ci, il faut , du moins je crois que les valeurs soient placées en ordre décroissant.
Mais il est vrai que cette solution est conforme, par rapport à la mienne qui renvoyait la valeur supérieure lors d'égalité avec une valeur du tableau.
Crdlmnt.
Ajouter un commentaire
Réponse
-1
moins plus
Merci de ton aide mon poulet.
Tu me sauves la vie...LOL
Ajouter un commentaire
Réponse
-1
moins plus
=ARRONDI.INF(G12/5;0)*5

MOi je suis une americain stupid avec beaucoup les I.D. 10 T problèmes informatiique.

Alors -- je boss en fanglaise avec MS/excel 2007 -- tout la vie est plus simple en anglaise- merde
Skooter- 27 oct. 2010 à 07:07
diviser par 10 plutot que 5 pour avoir le inf/sup
Répondre
Ajouter un commentaire
Réponse
-3
moins plus
je voudrais savoir s'il est possible d'arrondir un chiffre en 3 positions : inférieur, millieu , supérieur.

exemple : 12.124 donnerai 12
12.366 donnerai 12.5
12.665 donnerai 12.5
12.832 donnerai 13
Hadidman- 15 avril 2008 à 11:15
Voilà mancou je viens de faire cela, je sais pas si c'est la meilleure méthode mais j'ai rien trouvé d'autre :

Vous avez par exemple des nombres allant de 1840 à 1850 et vous voulez tous les arrondir soit à 1840, soit à 1845, soit à 1850, voilà ce qu'il vous faut :

Code:
=SI(((N-ARRONDI(N;-1))<=5)*ET((N-ARRONDI(N;-1))>=0);ARRONDI(N;-1);ARRONDI(N;-1)-5)
avec N le nom de votre cellule

Ce qui donne

1840 == 1840
1841 == 1840
1842 == 1840
1843 == 1840
1844 == 1840
1845 == 1845
1846 == 1845
1847 == 1845
1848 == 1845
1849 == 1845
1850 == 1840

Voilà Razz
Y a peut-être un moyen plus simple de le faire, où une formule Excel mais je ne l'ai point trouvée...
Répondre
Maya2012- 17 déc. 2012 à 15:33
pour répondre à Hadidman - 15 avril 2008 à 11:15
oui, il existe la formule suivante : =ENT(A1/5)*5
mais juste pour régler ton soucis de 1840....
car ça ne règle pas du tout le pb de Mancou :D

l'avantage, c'est que si tu changes 5 par 2, ou 3 ou ce que tu veux, ça te permet de choisir
:)

2
1840 1840
1841 1840
1842 1842
1843 1842
1844 1844
1845 1844
1846 1846
1847 1846
1848 1848
1849 1848
1850 1850
1851 1850
1852 1852
1853 1852
1854 1854

3
1840 1839
1841 1839
1842 1842
1843 1842
1844 1842
1845 1845
1846 1845
1847 1845
1848 1848
1849 1848
1850 1848
1851 1851
1852 1851
1853 1851
1854 1854

Pour Mancou, il faut en effet utiliser la formule =Arrondi(A1/5;1)*5
pour faire des arrondis à 0.5 près...
Répondre
Ajouter un commentaire
Ce document intitulé «  les arrondis sous Excel  » issu de CommentCaMarche (www.commentcamarche.net) est mis à disposition sous les termes de la licence Creative Commons. Vous pouvez copier, modifier des copies de cette page, dans les conditions fixées par la licence, tant que cette note apparaît clairement.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.