Signaler

Transformé ds excel mois chiffre en lettre [Résolu/Fermé]

Posez votre question castelc - Dernière réponse le 21 févr. 2017 à 11:06 par Phénix Lwanzo
Bonjour,
J'ai crée un tableau ds EXCEL , ds la première collonne j'ais mis la date et dans la deuxième j'ai mis "mois" avec la formule: =SI(A4="";"";MOIS(A4))
Le résultat me donne le mois en chiffres, mais ce qui m'interresserais c'est de l'avoir en lettre.
Est ce possible ?
Merci de votre réponse
Afficher la suite 
Utile
+51
plus moins
je croie qu'il faut maitre tout simplement cette fonction
=TEXTE(30*MOIS(A4);"mmmm")
Cette réponse vous a-t-elle aidé ?  
Ppow- 22 août 2014 à 16:03
ou plus simplement TEXTE(A4;"mmmm")
Raymond PENTIER 42945Messages postés lundi 13 août 2007Date d'inscription ContributeurStatut 21 juillet 2017 Dernière intervention - 22 août 2014 à 16:11
Voir, juste en-dessous, la deuxième solution de passaisparla du 18 août 2010 (4 ans déjà !), lien #4 .
Amazigh- 4 févr. 2015 à 17:22
Bonjour
Moi j'ai la formule =DATE(ANNEE(AX3)+950;MOIS(AX3);JOUR(AX3)-11)

12 Janvier de chaque année correspond au 1er Yennayer
2015 correspond à 2965

je souhaiterai remplacer comme suit

Janvier Yennayer
Février Fu?ar
Mars Me??es
Avril Yebrir
Mai Maggu
Juin Yunyu
Juillet Yulyu
Août ?uct
Septembre C?embe?
Octobre ?ube?
Novembre Wambe?
Décembre Dujambe?

J'ai essayé plein de formule mais aucune ne marche. Y aura t-il une âme charitable ? mdr
Raymond PENTIER 42945Messages postés lundi 13 août 2007Date d'inscription ContributeurStatut 21 juillet 2017 Dernière intervention - 16 oct. 2015 à 00:31
Tu n'as pas essayé celle de Mytå
http://www.commentcamarche.net/forum/affich-12818778-transforme-ds-excel-mois-chiffre-en-lettre#5
artttt- 3 déc. 2015 à 20:37
pour avoir une date avec le mois qui s'actualise : =TEXTE(AUJOURDHUI();"mmmm")
Utile
+13
plus moins
plus simple qu'une fonction personnalisée :

Première solution : modifier le format de cellule
Entrer un format personnalisé "mmmm" qui affichera un champ date
sous forme de mois en lettres.
Clic droit sur la cellule > Format de cellule > Personnalisé > Taper "mmmm" dans le champ Type.
NB: La cellule conserve la même valeur, seul l'affichage a changé.

Deuxième solution: convertir le champ date en champ texte
La fonction TEXTE permet de convertir un champ chiffre en un champ texte en respectant un format indiqué.
On peut aussi convertir un champ date en un champ texte.
Dans ton cas tu peux écrire dans B4 par exemple:
=TEXTE(A4;"mmmm")
Cette fois-ci B4 contient bien un texte et plus une date.
Allynn- 28 févr. 2012 à 22:51
J'ai essayé votre fonction =TEXTE(A4;"mmmm") mais le seul mois qui s'affiche est janvier.
J'ai modifié les formats de cellule, etc., etc. mais rien ne fonctionne.
Savez-vous ce que je peux faire pour résoudre mon problème ?
Mytå 2997Messages postés mardi 20 janvier 2009Date d'inscription ContributeurStatut 20 décembre 2016 Dernière intervention - 29 févr. 2012 à 01:30
Re le forum

Ta cellule A4 doit contenir une date valide.

Sinon utilise la fonction du Permalink (#5)

Mytå
Thi2046- 11 avril 2012 à 12:16
@ cultissime : il faut paramétrer le premier jour de la semaine. Tu as 2 options, soit tu définis le 1er jour de la semaine comme étant le dimanche, auquel cas, ton 7ème jour est bien un samedi, soit tu définis le lundi comme étant le premier jour. L'option se trouve à la fin de ta formule.
Raymond PENTIER 42945Messages postés lundi 13 août 2007Date d'inscription ContributeurStatut 21 juillet 2017 Dernière intervention - 11 avril 2012 à 19:09
Pourquoi tant de complications ?
Tu saisis la date 05/04/12 en A2 ; tu mets le format personnalisé jj : 5 s'affiche.
Tu saisis en B2 la formule =A2 ; tu mets le format personnalisé mmmm : avril s'affiche.
C'est tout, et il ne peut pas y avoir d'erreur.
fred- 10 oct. 2012 à 19:17
Bonjour,
j'avais la même question... l'addage se vérifie: les problèmes les "plus" compliqués ont souvent les solutions les plus simples...Raymond...tout simplement génial, fallait y penser!!! Cela fonctionne parfaitement. Un tout grand merci à tous, vous m'avez fait gagner un temps dingue.
Merci
Utile
+10
plus moins
Salut le forum

Avec la fonction CHOISIR

=SI(A4="";"";CHOISIR(MOIS(A4);"Janvier";"Février";"Mars";"Avril";"Mai";"Juin";"Juillet";"Août";"Septembre";"Octobre";"Novembre";"Décembre"))

Mytå
Utile
+0
plus moins
=TEXTE(B9;"jj mmmm aaaa")
Raymond PENTIER 42945Messages postés lundi 13 août 2007Date d'inscription ContributeurStatut 21 juillet 2017 Dernière intervention - 16 oct. 2015 à 00:25
FAUX : on a demandé seulement le mois en toutes lettres ; pas la date complète !
Utile
-1
plus moins
salut
je crois que la fonction ne ramène que le mois en chiffre!
Tu pourrais peut être écrire un petit programme qui convertirais le chiffre donné en un mois pour toi!
donnes moi 05 minutes je t'écris la formule ok?
Utile
-1
plus moins
j'ai essayé de faire quelque chose, le problème est qu'à partir d'un moment donné m'indique un erreur dans la formule.Donc je te post au moins ce sui marche.La section marqué à compléter est celle qui pose problème!utilises la formule que je te donne et achève ton travail

=SI(A4="";"";SI(MOIS(A4)=12;"Décembre";SI(MOIS(A4)=11;"NOVEMBRE";SI(MOIS(A4)=10;"OCTOBRE";SI(MOIS(A4)=9;"SEPTEMBRE";SI(MOIS(A4)=8;"AOUT";SI(MOIS(A4)=7;"JUILLET";"à compléter")))))))
salout- 12 nov. 2009 à 18:19
il n'est pas possible d'imbrique plus de 6 si dans excel
Glaglagla- 15 juil. 2014 à 10:13
Bonjour à tous,
J'ai utilisé la fonction =TEXTE(30*MOIS(A4);"mmmm"), qui fonctionne très bien, à l'exception qu'elle calcule janvier sur les cellules vides. Comment faire pour qu'elle ignore les cellules vides?
Merci de votre iade,
Gladys
Raymond PENTIER 42945Messages postés lundi 13 août 2007Date d'inscription ContributeurStatut 21 juillet 2017 Dernière intervention - 15 juil. 2014 à 14:44
Comment faire ? Comme d'habitude :
=SI(A4="";"";TEXTE(30*MOIS(A4);"mmmm"))
Phénix Lwanzo- 21 févr. 2017 à 11:06
chez moi ça a marché avec =TEXTE(AUJOURDHUI();"mmmm").
Merci beaucoup Forumistes!
Phénix Lwanzo
Répondre

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !