Tri données en fonction d'un texte [Résolu]

Signaler
Messages postés
6
Date d'inscription
vendredi 31 janvier 2020
Statut
Membre
Dernière intervention
26 mars 2020
-
CCF42490
Messages postés
6
Date d'inscription
vendredi 31 janvier 2020
Statut
Membre
Dernière intervention
26 mars 2020
-
Bonjour,

Étant maintenant chauve car je ne suis que débutant dans les fonctionnalités Excel, je me tourne vers vos lumières pour m'aider à trouver une solution.

J'ai un tableau contenant deux colonnes (Clients et Retards).
Dans la colonne clients, deux clients recensés, CL01 et CL02, les deux étant mélangés (cf exemple ci après.).

J'aimerais pouvoir sur des cellules autres, afficher le nombres de livraisons à jour et en retard en fonction des clients, sachant que "A jour" signifie une livraison <= 3 ; et que en retard du coup >= 4.





J'avais tenté ceci : =SI(A2:A800="CL01";NB.SI(B2:B500;"<=3")-NB.SI(B2:B500;"=0");"")

Mais ceci ne me renvoie que vide (donc si faux ;"") et j'ai trouvé pourquoi (enfin je pense) : car il n'y a pas que CL01 dans la colonne A.

J'utilise Office pro plus 2019 si cela peut aider.

Merci d'avance pour votre aide.



Configuration: Windows / Firefox 74.0

4 réponses

Messages postés
28097
Date d'inscription
mercredi 22 octobre 2003
Statut
Modérateur
Dernière intervention
7 avril 2020
2 246
Bonjour,

Si tu veux les faire un par un...(comme ta tentative de formule le suggère ) penche toi sur la formule NB.SI.ENS


Sinon, tu peux aussi générer un tableau croisé dynamique
Messages postés
6
Date d'inscription
vendredi 31 janvier 2020
Statut
Membre
Dernière intervention
26 mars 2020

Bonjour,

merci pour ce conseil.

Je vais essayer de creuser de ce côté, et si je m'arrache le peux de cheveux qu'il me reste, j'étudierais les croisés dynamiques.
Messages postés
5469
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
4 avril 2020
416
Bonjour CCF42490

Essayer cette formule

=SOMME.SI($A$2:$A$500;C3;$B$2:$B$500)

C3 =CL01 par exemple

jordane45
Messages postés
28097
Date d'inscription
mercredi 22 octobre 2003
Statut
Modérateur
Dernière intervention
7 avril 2020
2 246
Bonjour,
Je ne vois pas en quoi un SOMME.SI va l'aider à traiter sa demande

J'aimerais pouvoir sur des cellules autres, afficher le nombres de livraisons à jour et en retard en fonction des clients, sachant que "A jour" signifie une livraison <= 3 ; et que en retard du coup >= 4.
PHILOU10120
Messages postés
5469
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
4 avril 2020
416 > jordane45
Messages postés
28097
Date d'inscription
mercredi 22 octobre 2003
Statut
Modérateur
Dernière intervention
7 avril 2020

Il cherche le nombre de retard pour un client (CL01 par exemple) alors je n'avais pas compris ?
Voici la formule à adapter

=NB.SI.ENS($A$2:$A$500;C3;$B$2:$B$500;">3")
CCF42490
Messages postés
6
Date d'inscription
vendredi 31 janvier 2020
Statut
Membre
Dernière intervention
26 mars 2020

J'ai essayé cette formule avec ma nouvelle colonne (décompte retard, expliquée ci dessous, qui affiche "1" si la colonne retard est ">3". Mais cela m'affiche 0 alors que dans mon tableau il y en aurait 2 :/
PHILOU10120
Messages postés
5469
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
4 avril 2020
416 > CCF42490
Messages postés
6
Date d'inscription
vendredi 31 janvier 2020
Statut
Membre
Dernière intervention
26 mars 2020

"1" c'est du texte il faur mettre 1 uniquement
Messages postés
6
Date d'inscription
vendredi 31 janvier 2020
Statut
Membre
Dernière intervention
26 mars 2020

Re bonjour,

je me suis donc lancé dans un tableau croisé dynamique.

J'ai créé une nouvelle colonne pour recenser les cellules >3 jour de retard ou non.

=SI(B2:B800>3;"1";"")

Ce qui me permet dans mon TCD de sélectionner la colonne "clients" et "Décompte retards".
Malheureusement, il ne prend pas en compte la formule ci dessus. En effet, après les avoir rentré manuellement, cela fonctionne...

Une solution svp ?

Merci encore pour votre aide.
CCF42490
Messages postés
6
Date d'inscription
vendredi 31 janvier 2020
Statut
Membre
Dernière intervention
26 mars 2020

Solution trouvée.

Ma formule correcte pour la colonne Décompte retard : =SI(B2:B500>3;1;"")
Ma formule incorrecte : =SI(B2:B500>3;"1";"")

Les " " autour du 1 faisant en sorte de le mettre au format texte ne permettait pas le calcul. Maintenant que c'est un chiffre, le TCD fait le calcul correctement.

je vous remercie pour votre aide !