Attribué ville à un code postale à partir de 2 listes [Résolu]

Signaler
-
eriiic
Messages postés
23125
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
15 décembre 2019
-
Bonjour,

J'ai un fichier excel qui indique sur 2 cellules (exemple cellule A2=J6E et la cellule B2=3E6) tous les codes postaux pour une même ville qui se retrouve en A1 sur l'onglet .

Sur l'onglet 2 du fichier, j'ai une liste de code postaux séparée en 2 cellules aussi mais qui contient plusieurs code postaux qui ne seront pas nécessairement dans ma liste de l'onglet 1.

Je veux savoir, à l'aide d'une formule, quels codes postaux de mon onglet 2 correspondent avec la ville de l'onglet 1.

En gros, il faudrait qu'à l'onglet 2, à la cellule C2, le nom de ville apparaisse en fonction du code postal qui est écrit dans la cellule A2 et B2. (exemple A2=J6E, B2=3E6, C2=Joliette)

Merci

18 réponses

Messages postés
9119
Date d'inscription
lundi 9 juin 2008
Statut
Contributeur
Dernière intervention
16 décembre 2019
468
si j'ai compris:
- onglet2, liste de code postaux en colonne A
- onglet1, ne peux-tu pas obtenir, sur chaque ligne, en colonne A le nom de la ville et en colonne B le code postal?
C'est ce que je tente de faire. À partir des codes postaux définis pour chaque ville sur l'onglet 1, je dois trouver une formule qui va faire en sorte que lors que j'inscrit un code postal, celui-ci sera capable de me dire automatiquement à quelle ville appartient ce code postal.
yg_be
Messages postés
9119
Date d'inscription
lundi 9 juin 2008
Statut
Contributeur
Dernière intervention
16 décembre 2019
468 > Starocean
tu as changé d'avis sur l'utilisation de onglet1 et onglet2. tu as choisi des noms peu clair, et tu t'y perds.
appelons-les plutôt reference et visiteurs.
le plus simple est de modifier le contenu de l'onglet reference, et d'y mettre, sur chaque ligne, en colonne A le code postal et en colonne B le nom de la ville.
ensuite, tu mets en B2 de l'onglet visiteur:
=recherchev(A2;reference!A:B;2;FALSE)

et ensuite tu recopies cette formule vers le bas
Messages postés
23125
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
15 décembre 2019
5799
Pas de fichier...Alors :
=RECHERCHEV(A2&B2;Feuil1!$A$1:$B$11;2;FAUX) 

eric
Oups je n'avais pas vue la mention du fichier joint. Voici le lien https://www.cjoint.com/c/IKnpOCMQDYo

Merci
eriiic
Messages postés
23125
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
15 décembre 2019
5799
Il faut mettre ta liste des CP sur 2 colonnes pour pouvoir faire un Recherchev() dessus.
https://www.cjoint.com/c/IKnqJVpBd67
eric
Messages postés
334
Date d'inscription
jeudi 18 juillet 2019
Statut
Membre
Dernière intervention
16 décembre 2019
12
Bonjour,

Si j'ai bien compris en B2 (onglet 1)
=SI(ESTNA(RECHERCHEV(A2;'Onglet 2'!A:A;1;FAUX));"";'Onglet 2'!$A$1)

et tu recopies jusqu'en bas

Cordialement
ALS35
Messages postés
334
Date d'inscription
jeudi 18 juillet 2019
Statut
Membre
Dernière intervention
16 décembre 2019
12
Bonsoir,

C'est un peu plus compliqué !
Ci-joint divers essais avec trois colonnes, toujours si j'ai bien compris, sinon donne un exemple.
https://www.cjoint.com/c/IKnr2oIDyhh

Cordialement
Ah bien oui avec la colonne ensemble je vais pouvoir regrouper tout dans la même colonne.

Merci beaucoup, ça règle mon problème.
eriiic
Messages postés
23125
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
15 décembre 2019
5799
J'avais testé avec ton fichier mais ça inscrit le nom de la ville même si le code postale ne correspondait pas à un code postal de la liste. Merci quand même pour ton soutien.
eriiic
Messages postés
23125
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
15 décembre 2019
5799
Ca , ça m'étonnerait fort, impossible...
#N/A veut dire non trouvé.
eric
Messages postés
9119
Date d'inscription
lundi 9 juin 2008
Statut
Contributeur
Dernière intervention
16 décembre 2019
468
bonjour,
1)tu écris "tous les codes postaux pour une même ville":chaque ville a toujours 2 code postaux, ni plus, ni moins?
2) ces codes postaux sont toujours dans le même ordre?
3) dans l'onglet 1, les codes postaux sont toujours sur la ligne en dessous de la ligne de la ville?
4) pourquoi veux-tu utiliser des formules?
5) veux-tu faire cela une seule fois, ou plusieurs fois?
1) Une ville peut avoir au dessus de 200 code postaux différents
2) La liste des codes postaux oui puisque c'est la feuille de référence
3) Entre temps, j'ai fusionné les cellules A et B ensemble avec la formule =A1&B1 donc mes codes postaux sont maintenant dans une seule cellule pour facilité le tout donc code postal dans colonne de gaucher et ville dans colonne de droite
4) Pour des fins de statistique. Quand un visiteurs passe, on prend son code postal. À la fin du mois, on me demande de sortir tous les visiteurs provenant de la même ville en fonction de leur code postale.
5) Je dois faire cela pour chaque ville (J'ai plusieurs autres colonnes avec d'autres codes postaux par ville)

Merci.
eriiic
Messages postés
23125
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
15 décembre 2019
5799
Bonjour,

Des 2 cotés, tes code postaux sont sur 6 caractères sans espace entre les 2 groupes ?
Tu devrais déposer un fichier exemple sur cjoint.com et coller ici le lien fourni.
eric
> eriiic
Messages postés
23125
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
15 décembre 2019

Oui avec la fonction =A1&B1, ça donne 6 caractères sans espaces. J'ai fait un copier/coller valeur uniquement pour ne pas avoir la formule.