Je n'arrive pas à faire mon RechercheV [Résolu]

Messages postés
75
Date d'inscription
mercredi 1 novembre 2017
Statut
Membre
Dernière intervention
12 novembre 2019
- - Dernière réponse : diablo13800
Messages postés
2058
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
5 décembre 2019
- 12 nov. 2019 à 17:59
Bonjour,

J'essaie de faire ma formule RECHERCHEV dans ma feuille 2 avec ma table matrice feuille 1
et je n'arrive pas à comprendre pourquoi ça marche pas, pourtant je fais beaucoup de recherchev
quelqu'un peux m'expliquer mon erreur svp
merci

voici mon fichier
https://mon-partage.fr/f/lqknWxTu/
Afficher la suite 

4 réponses

Messages postés
2058
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
5 décembre 2019
831
0
Merci
Bonjour,

Pour ma part, il s'agirait pas d'un rechercheV mais plutôt d'un SOMME.SI

Car si je comprend bien vous voulez savoir la dépense pour chaque "Payable Où"

=SOMME.SI(Feuil1!A:A;Feuil2!A1;Feuil1!D:D)

PS:Votre rechercheV était bonne sinon
ange-lyna
Messages postés
75
Date d'inscription
mercredi 1 novembre 2017
Statut
Membre
Dernière intervention
12 novembre 2019
-
ahh cool il me semblait aussi
mais comment puis comprendre la SOMME.SI avec le payable Ou? je veux l'expliquer a mon patron mais je ne sais pas quoi y dire car ça fonctionne super
diablo13800
Messages postés
2058
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
5 décembre 2019
831 -
La fonction Somme.si fait , comme son nom l'indique, une somme suivant une condition.

A:A est la plage de condition( Dans Feuil1),
A1 est la condition ( dans Feuil2)
Et D:D est la plage a additionner

Donc il additionne toutes les cases "D:D" pour lesquels la A:A correspondante = A1 :)
Commenter la réponse de diablo13800
Messages postés
16992
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
3 décembre 2019
3710
0
Merci
Bonsoir,

Si je comprends ta problématique, il existe plusieurs références FG sur ta Feuil1 alors que veux tu faire à partir de cette référence, afficher tous les résultats de cette référence ou veux tu le total des sommes de cette référence !

A+
Mike-31

Je suis responsable de ce que je dis, pas de ce que tu comprends...
ange-lyna
Messages postés
75
Date d'inscription
mercredi 1 novembre 2017
Statut
Membre
Dernière intervention
12 novembre 2019
-
au fond ce que je cherche c'est la somme qui se trouve dans la colonne 4 de tous le FG et ainsi de suite pour les autres aussi
Commenter la réponse de Mike-31
Messages postés
1743
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
6 décembre 2019
462
0
Merci
Bonjour
comme il ya plusieurs fois FG dans la feuille 1 il faudrait passer par la fonction SOMMEPROD

=SOMMEPROD(Feuil1!$A$7:$A$42=A1*Feuil1!$D$7:$D$42)
ange-lyna
Messages postés
75
Date d'inscription
mercredi 1 novembre 2017
Statut
Membre
Dernière intervention
12 novembre 2019
-
MERCI
Commenter la réponse de yclik
Messages postés
16992
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
3 décembre 2019
3710
0
Merci
Re,

tu as ce genre de formule

=SOMME.SI.ENS(Feuil1!D7:D42;Feuil1!A7:A42;A1)
ou
=SOMMEPROD((Feuil1!A7:D42=A1)*(Feuil1!D7:D42))

tu peux également simplifier ces formules en nommant tes plages exemple Feuil1!D7:D42 nommée Prix
et Feuil1!A7:A42 nommée Réf

les formules deviennent
=SOMME.SI.ENS(Prix;Réf;A1)
ou
=SOMMEPROD((Réf=A1)*(Prix))
ange-lyna
Messages postés
75
Date d'inscription
mercredi 1 novembre 2017
Statut
Membre
Dernière intervention
12 novembre 2019
-
MERCI A TOUS
Commenter la réponse de Mike-31