Correction formule [Résolu]

Messages postés
577
Date d'inscription
lundi 29 décembre 2014
Statut
Membre
Dernière intervention
2 août 2019
- - Dernière réponse : nonossov
Messages postés
577
Date d'inscription
lundi 29 décembre 2014
Statut
Membre
Dernière intervention
2 août 2019
- 2 août 2019 à 11:46
Bonjour mes amis,

cette formule consiste à trouver les 3 premiers chiffres de la cellule J8, et les chercher dans la colonne A et faire la somme de ses correspondants, exemple:

Col A / Col C
441 / 100
100/ 20
200 / 30
441/ 100
210/ 500
441/ 120

le resultat sera: 320

ma question : est ce qu'il est possible d'avoir une formule qui travaille sur n'importe quel nombre de caractère dans la cellule J8 et n'est pas les 3 premiers chiffres???

Merci infiniment
Afficher la suite 

1 réponse

Meilleure réponse
Messages postés
1851
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
21 août 2019
695
1
Merci
Bonjour,

Quel est votre formule actuelle? ( vous parlez de correction ce serait bien de savoir quelle formule corrigée)

Que voulez-vous dire par "n'importe quel nombre de caractère dans la cellule J8 et n'est pas les 3 premiers chiffres??? "

X Chiffres, peu importe leur placement, ou X chiffres au début?

Comment vous allez déterminer le nombre x.

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 58732 internautes nous ont dit merci ce mois-ci

nonossov
Messages postés
577
Date d'inscription
lundi 29 décembre 2014
Statut
Membre
Dernière intervention
2 août 2019
-
Nn juste les nombres,

il doit ajouter le chiffre, mais je n'ai pas de probleme avec 3 caracteres en J8, le probleme c'est dans 4 caracteres et plus.

Merci
diablo13800
Messages postés
1851
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
21 août 2019
695 -
Pourquoi ne pas faire simplement avec un somme.SI ?

=SOMME.SI(A:A;J8;C:C)

Ca permet de chercher J8 en A, Si ya correspondance une somme se fait des valeurs en C
nonossov
Messages postés
577
Date d'inscription
lundi 29 décembre 2014
Statut
Membre
Dernière intervention
2 août 2019
-
Parce que si je cherche 4411 et j'ai 4411000000 dans colonne A:A je ne recois pas la somme.
diablo13800
Messages postés
1851
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
21 août 2019
695 -
C'est ce que j'ai demandé plus haut... et vous m'avez dit non ....

Pouvez-vous essayé avec cette formule:
=SOMMEPROD(EXACT(GAUCHE(A1:A29;NBCAR(J8));J8)*C1:C29)
nonossov
Messages postés
577
Date d'inscription
lundi 29 décembre 2014
Statut
Membre
Dernière intervention
2 août 2019
-
Merci infiniment
Commenter la réponse de diablo13800