[Google sheet] Mise en forme conditionnelle selon une moyenne mobile [Résolu]

Signaler
-
Vaucluse
Messages postés
24783
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 janvier 2020
-
Bonjour,

Dans google sheets, j'ai dans ma colonne B plusieurs données correspondant à chaque date présente dans ma colonne A.

Je souhaiterais appliquer à ma colonne B la MFC suivante:
si la valeur de ma cellule est inférieur à la moyenne des 7 lignes précédentes alors la cellule est verte.
Si B8 = 30 et que Moyenne(B1:B7) = 40 alors B8 est verte
Si B9 = 32 et que Moyenne(B2:B8) = 38 alors B8 est verte ...

Il y a bien la solution de rajouter une colonne moyenne mobile en colonne C et d'utiliser la MFC B lesser than C mais je souhaiterais avoir une solution sans rajout de colonne.

Merci d'avance pour votre aide,
Romain

Configuration: Windows / Chrome 74.0.3729.169

2 réponses

Messages postés
24783
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 janvier 2020
4983
Bonjour
je en connais pas google sheet, je peux juste vous proposer la solution par formule dans MFC Excel
soit donc, à appliquer à partir de B8
=B8<MOYENNE(DECALER(B1;;;7))
crdlmnt

Bonjour Vaucluse,

J'ai essayé votre formule et cela marche parfaitement. Il faut vraiment que j'apprenne à utiliser la fonction Decaler car c'est elle qui me manque à chaque fois pour avancer.
Vaucluse
Messages postés
24783
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 janvier 2020
4983
Pas de quoi
je passe le sujet en résolu
pour utiliser DECALER, passez par l'onglet formule et l'aide Excel qui y est installée, vous aurez toutes les informations
Bonne route
crdlmnt
Messages postés
1787
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
21 janvier 2020
508
Bonjour
Comme Vaucluse donc une autre proposition

MOYENNE(INDIRECT("B"&LIGNE()-7):INDIRECT("B"&LIGNE()-1))<40
Vaucluse
Messages postés
24783
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 janvier 2020
4983
Salut yclick
l'idée est bonne dans le principe, mais sauf erreur il faut écrire:
=MOYENNE(INDIRECT("B"&LIGNE()-7&":B"&LIGNE()-1))<40
de façon à ce que le texte représente l'adresse du champ
crdlmnt
Merci Yclik,
je ne comprend par contre la fin de la formule "-40".