Faire une priorité sur Excel [Résolu]

Messages postés
2
Date d'inscription
mardi 4 juin 2019
Statut
Membre
Dernière intervention
4 juin 2019
- - Dernière réponse : hiper-tofu
Messages postés
2
Date d'inscription
mardi 4 juin 2019
Statut
Membre
Dernière intervention
4 juin 2019
- 4 juin 2019 à 21:01
Bonjour,

je souhaiterai sur Excel effectuer un retour d'etat, je m'explique :

J'ai une plage avec des "O", des "X" et des "U".

"O" pour Ok
"X" pour A faire
"U" pour Urgent

Si présence d'un U ou plus alors afficher en priorité U, si il n'y a pas de U mais la présence de X alors X, sinon afficher O dans la colone A

Voici le lien d'exemple du tableau https://docs.google.com/spreadsheets/d/1uxfgB3HasowzkTCGxahpd5Qo7zT5OuC7PEhT-iz1uOU/edit?usp=sharing

J'ai essayé avec SI, mais cela ne fonctionne pas sur une plage, j'ai essayé avec des NB.SI et SI.MULTIPLE, j'ai peut-être loupé des choses

Merci d'avance.
Afficher la suite 

1 réponse

Meilleure réponse
Messages postés
24615
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 octobre 2019
4842
1
Merci
Bonjour
On ne sait pas dans quelle cellule ou quel champ il faut détecter le U , le X ou le O?
est ce de L à AC? dans ce cas, en A4
=SI(NB.SI(L4:AA4;"U");"urgent";SI(NB.SI(L4:AA4;"X");"en cours";"Ok"))
sinon complètez vos explications
à vous lire
crdlmnt


Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 65172 internautes nous ont dit merci ce mois-ci

hiper-tofu
Messages postés
2
Date d'inscription
mardi 4 juin 2019
Statut
Membre
Dernière intervention
4 juin 2019
-
Bonjour,

Oui, la plage ou il y aura les O, X et U est de K4 à AL4.

J'ai mis à jour le Google Sheets avec ta formule, cela fonctionne parfaitement ! C'est impressionnent. J'ai déjà réalisé ce genre de formule, mais à chaque fois je rajouté des "supérieurs ou égale à" un peu partout.


Merci !
Commenter la réponse de Vaucluse