Menu

Firefox sans Adobe FlashPlayer [Résolu]

Messages postés
142
Date d'inscription
mercredi 9 décembre 2009
Statut
Membre
Dernière intervention
3 mai 2019
- - Dernière réponse :  jns55 - 5 mai 2019 à 10:19
Bonjour,
depuis deux jours je galère pour installer Adobe FlashPlayer sans résultats.
J'ai fait le tour des forums, doc Ubuntu, WikiHow, etc,... et ça ne passe pas.
J'en ai besoin pour travailler sur des sites d'archives départementales qui me refusent l'accés à leur pages.
Je n'applique peut-être pas les bonnes manips.
Je vois que Adobe n'est pas dans une grande forme.
Donc existe-t-il un autre flash pour le remplacer pour Firefox ?
Afficher la suite 

Votre réponse

7 réponses

Meilleure réponse
Messages postés
142
Date d'inscription
mercredi 9 décembre 2009
Statut
Membre
Dernière intervention
3 mai 2019
2
1
Merci
VICTOIRE !!!

J'ai déterré un vieux post de 2009 et appliqué la cde

sudo apt-get install flashplugin-nonfree

après avoir fermé Firefox.
Je l'ai rouvert et fait un essai sur le site en question et ça marche.

Il faut répandre la bonne parole pour tous les Ubuntu-istes qui galèrent avec la 18.04.

MERCI à tous les amis qui m'ont conseillé.

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 39483 internautes nous ont dit merci ce mois-ci

Curieux : flashplugin-nonfree contient le même programme d'installation que flashplugin-installer. C'est ce programme qui télécharge le plugin sur le site d'Adobe et l'installe automatiquement.
Canonical a changé le nom du paquet pour qu'il évoque mieux son rôle. L'ancien paquet a été conservé pour des questions de compatibilité avec les versions plus anciennes.
D'ailleurs sous Debian, le paquet porte toujours ce nom.

Adobe arrête le développement de flash fin 2020, et conseille de se tourner dès à présent vers html5.
Commenter la réponse de jeanlucbo
Messages postés
14258
Date d'inscription
dimanche 16 décembre 2007
Statut
Membre
Dernière intervention
7 mai 2019
2290
0
Merci
bonjour
en tout cas, c'est pas la faute à FFX ni AFP

déjà, télécharger la bonne version 32/64bits pour TON système 7,8,10 d'exploitation sur LE bon site
https://get.adobe.com/fr/flashplayer/

pour installer; setup.exe en "tant qu'admin." en faisant attention à ne pas installer des logiciels tiers à l'insu de ton plein gré
zipe31
Messages postés
36490
Date d'inscription
dimanche 7 novembre 2010
Statut
Contributeur
Dernière intervention
7 mai 2019
6134 -
Salut,
pour TON système 7,8,10
[…]
setup.exe
Il sait lire le Simpson rouge ???
Redbart
Messages postés
14258
Date d'inscription
dimanche 16 décembre 2007
Statut
Membre
Dernière intervention
7 mai 2019
2290 -
désolé pour ma pensée monolithique (linux ne m'a pas convaincu), c'était plus une une aide à repenser ton approche qu'une solution sur un plateau

le pseudo ne vient pas d'une admiration des simpson, mais de barbe rousse = red beard

il y a suffisamment de forums dédiés à linux
zipe31
Messages postés
36490
Date d'inscription
dimanche 7 novembre 2010
Statut
Contributeur
Dernière intervention
7 mai 2019
6134 > Redbart
Messages postés
14258
Date d'inscription
dimanche 16 décembre 2007
Statut
Membre
Dernière intervention
7 mai 2019
-
il y a suffisamment de forums dédiés à linux
Et celui de CCM en fait partie à ce que je sache…
Commenter la réponse de Redbart
0
Merci
Bonjour,
Tu as essayé la commande
sudo apt install flashplugin-installer
?

https://doc.ubuntu-fr.org/flashplayer#installation
Commenter la réponse de jns55
Messages postés
142
Date d'inscription
mercredi 9 décembre 2009
Statut
Membre
Dernière intervention
3 mai 2019
2
0
Merci
Bonjour à tous,
Oui, j'ai essayé ça + tout ce que j'ai trouvé sur le web et aussi la méthode de redbart par le site d'Adobe.
j'ai bien téléchargé FlashPlayer en .rpm et en .tar.gz
En .tar.gz j'ai extrait le fichier "libflashplayer.so"
et j'ai suivi les Cdes indiquées.
En me trompant plusieurs fois comme vous pouvez voir sur la photo.




Je suis nul et ne fais que copier. si les Cdes ne sont pas adaptées à mon système, c'est sûr que ça plante.

Qu'est-ce qui se passe lorsque tu tapes la commande
sudo apt install flashplugin-installer
?

Ce paquet fait automatiquement ce que tu essaies de faire en vain.

Les fichiers .rpm, c'est pas pour Ubuntu.
Commenter la réponse de jeanlucbo
Messages postés
142
Date d'inscription
mercredi 9 décembre 2009
Statut
Membre
Dernière intervention
3 mai 2019
2
0
Merci
C'est le seul libellé de cde que je n'avais pas essayé
Mais réponse : impossible de trouver le paquet flashplugin-installer

un des essais précédents "sudo apt-get install flashplugin-installer" sans plus de résultat.
zipe31
Messages postés
36490
Date d'inscription
dimanche 7 novembre 2010
Statut
Contributeur
Dernière intervention
7 mai 2019
6134 -
C'est bizarre ça ;-\

Quelle version d'Ubuntu ?

Chez moi, sur une machine virtuelle avec Xubuntu, voilà le résultat (la 1ère commande c'est pour la version du système) :
jp@VB-XFCE-18:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 18.04.1 LTS
Release: 18.04
Codename: bionic

jp@VB-XFCE-18:~$ sudo apt search flashplugin-installer
[sudo] Mot de passe de jp :
En train de trier... Fait
Recherche en texte intégral... Fait
flashplugin-downloader/bionic-updates,bionic-security 32.0.0.171ubuntu0.18.04.1 i386
Installation du plugin Adobe Flash Player (paquet de transition)

flashplugin-installer/bionic-updates,bionic-security 32.0.0.171ubuntu0.18.04.1 amd64
Installeur du greffon Adobe « Flash Player »
impossible de trouver le paquet flashplugin-installer
Il faut que le dépôt multiverse soit activé.
Donc activer le dépôt multiverse
puis
sudo apt update
et seulement
sudo apt install flashplugin-installer.

Ou alors, tu installes le paquet apturl
sudo apt install apturl
puis tu cliques sur le lien en rouge
ici :
https://doc.ubuntu-fr.org/flashplayer#depuis_les_depots_officiels
paragraphe 2.1.2 Méthode 2.

A toi de choisir ta méthode.
Commenter la réponse de jeanlucbo
Messages postés
142
Date d'inscription
mercredi 9 décembre 2009
Statut
Membre
Dernière intervention
3 mai 2019
2
0
Merci
Bonjour zipe31

Installé Ubuntu 18.04.1 LTS, les mises à jour l'ont poussé à 18.04.2 LTS
Commenter la réponse de jeanlucbo
Messages postés
142
Date d'inscription
mercredi 9 décembre 2009
Statut
Membre
Dernière intervention
3 mai 2019
2
0
Merci
jns55, merci.
J'ai déjà utilisé les deux méthodes sans succès.
Le geek du site d'archives qui utilise adobe m'a fait faire un nouveau chargement de flashplayer en me guidant par téléphone mais sans plus de succès. Il a abandonné après 25 minutes de cdes diverses....!
Les dépôts ne donnent rien par Synaptic non plus.
Il y a certainement une action que je ne sais pas faire puisque je bloque après les téléchargements.
Je continue d'éplucher le web.
Commenter la réponse de jeanlucbo