Menu

2 formules différentes dans une même cellule [Résolu]

Messages postés
31
Date d'inscription
mercredi 6 décembre 2017
Statut
Membre
Dernière intervention
22 mai 2019
- - Dernière réponse : sylmarco
Messages postés
31
Date d'inscription
mercredi 6 décembre 2017
Statut
Membre
Dernière intervention
22 mai 2019
- 6 mai 2019 à 18:26
Bonjour,

J'ai un fichier dont je veux calculer un % et que je veux dire que si le résultat du % est de 0%, je voudrais que ça indique --- au lieu de 0%
Afficher la suite 

Votre réponse

3 réponses

Messages postés
8957
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
23 mai 2019
1562
0
Merci
Bonjour

Essaies ceci
=SI((B2-A2)/B2=0;"_";(B2-A2)/B2)

Cdlmnt
Commenter la réponse de ccm81
Messages postés
1945
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
23 mai 2019
354
0
Merci
Bonjour,

Comme ceci

=SI((B2-A2)/B2>0;(B2-A2)/B2;"---")

et si tu veux que la cellule reste vide

=SI((B2-A2)/B2>0;(B2-A2)/B2;"")

Cordialement
sylmarco
Messages postés
31
Date d'inscription
mercredi 6 décembre 2017
Statut
Membre
Dernière intervention
22 mai 2019
-
OK super et ça fonctionne très bien et comment pourrais-je ajouter une autre condition en disant que mes cellules a4 (ou a5) si elles ont rien d'entrées ou si elles sont à zéro de mettre une case vide dans la colonne C en plus de mes formules qui sont déjà là au lieu d'afficher #DIV/0! (Voir la photo de mon document ci-joint)

Merci beaucoup à l'avance :-)
PapyLuc51
Messages postés
1945
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
23 mai 2019
354 > sylmarco
Messages postés
31
Date d'inscription
mercredi 6 décembre 2017
Statut
Membre
Dernière intervention
22 mai 2019
-
Bonjour,
Il suffit d'ajouter une condition à la formule

=SI(OU(A2="";B2="");"";SI((B2-A2)/B2=0;"---";(B2-A2)/B2))

Cordialement
sylmarco
Messages postés
31
Date d'inscription
mercredi 6 décembre 2017
Statut
Membre
Dernière intervention
22 mai 2019
-
Merci énormément, ça fonctionne super bien :-)
Commenter la réponse de PapyLuc51
Messages postés
31
Date d'inscription
mercredi 6 décembre 2017
Statut
Membre
Dernière intervention
22 mai 2019
0
Merci
Merci beaucoup de votre aide :-)
Commenter la réponse de sylmarco