Menu

Recherche v et Si imbriqué

- - Dernière réponse : PHILOU10120
Messages postés
5329
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
24 juin 2019
- 27 mars 2019 à 10:47
Bonjour à vous,

Je dispose de deux classeurs Excel
Dans l'un une base de données espèces avec leur statuts
https://drive.google.com/open?id=1IEj_TsMK-eVV_36FLM0r0NvaGvV__MM9

Dans l'autre je souhaiterai lorsque que j'affiche le code d'une espèce que son code statut apparaissent.
https://drive.google.com/open?id=1_RWj7yy0l5F4wybh1D-YY-0DH7ux7vRQ

Ça c'est fait ça fonctionne ^^
=RECHERCHEV(A2;'BDC_STATUTS_11 - Copie.xlsx'!$1:$1048576;7;FAUX)

Les difficultés commencent maintenant

je souhaiterai obtenir les résultat de ma recherche uniquement si dans la colonne Code statut (BDC_statuts 11) on obtiens "CR" "DD" "EN" "EW" "EX" "LC" "NT" et "VU"

j'ai essayé la formule si dessous pour le 1er SI

=SI('BDC_STATUTS_11 - Copie.xlsx'!$G:$G="CR";RECHERCHEV(A3;'BDC_STATUTS_11 - Copie.xlsx'!$1:$1048576;7;FAUX))

Cependant je me rend compte que dans mon deuxième classeur la formule fonctionne uniquement lorsque je met les chiffre (CD_NOM) dans le même ordre que le classeur BDC_STATUTS_11 - Copie.xlsx. Si je lui donne un autre chiffre bien présent dans le classeur BDC_STATUTS_11 - Copie.xlsx mais qui ce trouve ligne 15 ligne plus bas, il m'affichera automatiquement FAUX même si le il est inscrit "CR" dans la cellule CODE Statut.

J'espère que mes explication sont claires.... et que vous pourrez m'aider car je galère vraiment la ........
( Le pire c'est que la réponse doit être toute simple)
Afficher la suite 

1 réponse

Messages postés
5329
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
24 juin 2019
318
0
Merci
Bonjour

Sur la feuille avifaune colonne D1 à D9
D1 = liste
D2 = CR
D3 = DD
D4 = EN
D5 = EW
D6 = EX
D7 = LC
D8 = NT
D9 = VU

Puis mettre cette formule en B2

=SI(NB.SI($D$2:$D$9;RECHERCHEV($A2;'BDC_STATUTS_11 - Copie.xlsx'!$A1:G$1048576;7;FAUX))>0;RECHERCHEV($A2;'BDC_STATUTS_11 - Copie.xlsx'!$A1:G$1048576;7;FAUX);"")

Commenter la réponse de PHILOU10120