Menu

Formule SI optimisée [Résolu]

Messages postés
56
Date d'inscription
lundi 27 février 2017
Dernière intervention
12 mars 2019
-
Bonjour à tous,

J'ai une cellule (en D3) dans laquelle j'entre une référence manuellement. La cellule juste à côté me renvoie la valeur entrée manuellement en D3. J'aimerais que lorsque la cellule en D3 est égale à l'une des références inscrites dans la colonne B de mon petit tableau, la cellule E3 me renvoie la valeur associée dans la colonne A.
Exemple :
- Si je rentre "ACD0" en D3, je souhaiterais avoir "ABD0" en E3.

Je pourrais le faire avec la fonction SI pour chaque référence, mais le souci est qu'en réalité j'ai une cinquantaine de référence dans mon tableau et qu'il est susceptible d'être modifié (ajout ou retrait de référence).

Existe-t-il une fonction me permettant d'obtenir ce que je souhaite ? Merci de votre aide
Afficher la suite 

Votre réponse

4 réponses

Meilleure réponse
Messages postés
268
Date d'inscription
samedi 16 février 2019
Dernière intervention
12 mars 2019
10
1
Merci
Bonjour,

Vous pouvez utiliser la fonction RECHERCHEV:

=RECHERCHEV(D3;A1:B50;2;FAUX)


Edit: Je n'avais pas vu que c'était dans l'autre sens, du-coup voir autre réponses.

Cdlt,

T3ch'

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 50808 internautes nous ont dit merci ce mois-ci

Commenter la réponse de T3chN0g3n
Messages postés
5248
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
12 mars 2019
785
1
Merci
Bonjour

Essayer cette formule

=SI(D3="";"";RECHERCHEV($D$3;$A$1:$B$61;2;0))

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 50808 internautes nous ont dit merci ce mois-ci

Commenter la réponse de PHILOU10120
Messages postés
23609
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
12 mars 2019
5672
1
Merci
Bonjour
à partir d'Excel 2013

=SIERREUR(INDEX(A:A;EQUIV(D3;B:B;0));D3)

qui renverra la valeur de B sur la ligne qui contient D3 en A, sinon, renverra la valeur de D3

et avant 2013:

=SI(NB.SI(B:B;D3);INDEX(A:A;EQUIV(D3;B:B;0));D3)

crdlmnt
(ps: formules corrigées après 1° édition du message pour inversion des colonnes B et A)

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 50808 internautes nous ont dit merci ce mois-ci

Commenter la réponse de Vaucluse
Messages postés
56
Date d'inscription
lundi 27 février 2017
Dernière intervention
12 mars 2019
1
0
Merci
Merci pour vos réponses. J'ai essayé chacune d'entre elle et le problème est que cela fonctionne que si j’intervertis ma colonne A avec la colonne B, c'est à dire si je mets les Références bonnes en B et pas bonne en A (parce que je veux que la fonction renvoie la valeur en colonne A). Si je change seulement dans les formules le numéro de colonne renvoyé (1 (A) à la place de 2 (B)), elles ne fonctionnent pas.
Mais merci pour vos réponses, je peux me débrouiller avec elles.
Coco-8
Messages postés
56
Date d'inscription
lundi 27 février 2017
Dernière intervention
12 mars 2019
1 -
Sur mon fichier de base elles fonctionnent parfaitement, merci :)
Commenter la réponse de Coco-8