Menu

Mon imprimante refuse de répondre

- - Dernière réponse :  jns55 - 2 mars 2019 à 10:09
Bonjour,

J'ai récemment installé Debian (malgré de nombreuses galères).

J'ai donc voulu installer les drivers de mon imprimante, mais voilà...
Tout se passe correctement, l'imprimante semble être correctement connectée, mais ne fonctionne pas.
dans le localhost:631, elle apparrait, mais est marquée "ne répond pas"
J'ai essayé de l'installer manuellement depuis localhost:631 en ajoutant le modèle mais rien n'y fait.

Mon imprimante est une Brother DCP-9020CDW, si jamais.
Elle apparait bien dans la liste des modèles compatibles avec le driver

Merci d'avance...


Configuration: Windows / Firefox 65.0
Afficher la suite 

Votre réponse

2 réponses

0
Merci
Salut,
Tu as résolu ton pb d'install de Debian ?

https://doc.ubuntu-fr.org/brother_driver_install_tool
Non, j'ai tout essayé rien ne fonctionnait...
J'ai laissé tombé, j'ai formaté tout mon disque et j'ai réinstallé Windows et Debian proprement !

Mais maintenant j'ai toujours le même problème avec l'imprimante :/
C'est bien la procédure que j'ai utilisé, le "driver install tool", cela semble fonctionner, l'imprimante apparaît bien dans le gestionnaire mais elle ne répond pas...
Je crois que Debian ne veut vraiment pas de moi :(
Commenter la réponse de jns55
0
Merci
J'ai essayé d'installer "manuellement" les drivers, et je me rends compte que j'ai un message d'erreur:
mkdir: impossible de créer le répertoire " /var/spool/lpd/dcp9020cdw" : Aucun fichier ou dossier de ce type
J'ai cherché sur internet, je n'ai rien trouvé, hormis une personne qui avait exactement le même soucis que moi... qui n'a jamais été résolu.. Encouragent :'(
Non, il n'a pas été créer :/
Il est existe un chemin /var/spool/lpd/ mais pas dcp9020cdw, et l'option pour créer le dossier manuellement est grisée...
"As tu vérifié cette piste ? (architecture i386 du driver)
https://debian-facile.org/viewtopic.php?id=19836%26%2334%3B
J'ai tenté les deux:
dpkg --add-architecture i386
-> aucun message, je suppose que c'est ok ?

apt install lib32z1 lib32ncurses5
-> Tout est ok
Ensuite, j'ai relancé le driver installation tool. Et.. ça ne marche toujours pas !!
Je commence à sérieusement en avoir raz le bol !
Toujours le même message: mkdir: impossible de créer le répertoire " /var/spool/lpd/dcp9020cdw" : Aucun fichier ou dossier de ce type
J'ai remarqué que j'avais aussi le message: "Aucune version du paquet ia32-libs n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source
Cependant les paquets suivants le remplacent :
lib32z1 lib32ncurses5"
et ce malgré le fait d'avoir fait "
apt install lib32z1 lib32ncurses5 " et que cela ait abouti...
Je commence à me demander si ce ne sont pas les drivers de Brother qui sont obsolètes ?...
"Date de publication 17/05/2013"
Cela pourrait-il venir de là ?

Edit: Après des HEURES et des HEURES de galères !
Je suis FINALEMENT tombé sur ce script: https://doc.ubuntu-fr.org/utilisateurs/demonipuch/script_brother
et il a fonctionné... AMEN
cela venait bien du script de Brother
Merci pour votre aide !
Il faudra sans doute installer ce paquet pour que le scanner fonctionne en "user" :
https://support.brother.com/g/b/downloadlist.aspx?c=fr&lang=fr&prod=dcp9020cdw_eu&os=128&flang=English#SelectLanguageType-600_0_1
scanner setting file (le dernier de la liste).
Sinon, il ne fonctionne qu'en root.
Commenter la réponse de Irianeth