Menu

Formule excel SI,ET,OU [Résolu]

Messages postés
27
Date d'inscription
mercredi 23 septembre 2009
Statut
Membre
Dernière intervention
7 mai 2019
- - Dernière réponse : nathan027
Messages postés
27
Date d'inscription
mercredi 23 septembre 2009
Statut
Membre
Dernière intervention
7 mai 2019
- 21 févr. 2019 à 15:36
Bonjour

J'aimerai faire une formule

SI (A-B>0 et A-C>0)=vrai OU SI (A-B>0 et A-C<0)=faut SINON = peut-etre

(pour le moment j'en suis là : =SI(ET(B9-F9>0;B9-D9>0);1;"") , mais il me faut une autre condition pour mes calcul merci.

J'espère être assez clair

Merci bcp pour votre futur aide.
Afficher la suite 

6 réponses

Meilleure réponse
Messages postés
1933
Date d'inscription
mercredi 27 juillet 2005
Statut
Membre
Dernière intervention
22 juin 2019
746
1
Merci
Bonjour,

tu peux l'écrire comme ça :
=SI(ET(A1>B1;A1>C1);1;SI(OU(ET(A1>B1;A1<C1);ET(A1<B1;A1>C1));2;3))

ça fournit 3 pour A=B=C

cdlt

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 46480 internautes nous ont dit merci ce mois-ci

Commenter la réponse de JvDo
Messages postés
252
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
7 avril 2019
22
0
Merci
Bonjour,

les conditions renvoyées sont soient fausses soient vraies !

pour le "peut-être", quelle(s) condition(s) demandes-tu ?
nathan027
Messages postés
27
Date d'inscription
mercredi 23 septembre 2009
Statut
Membre
Dernière intervention
7 mai 2019
-
bonjour

J'ai mis des mots au hasard pour expliqué ce que je voulais. En réalité j'ai trois valeurs je veux que quand la premiere valeur est supérieur aux deux autres que ca affiche "1", ou quand elle est supérieur à une et inférieur à l'autre ca affiche "2" et que quand elle est inférieur aux deux autres ca affiche "3".

En espérant encore une fois etre assez clair.
Commenter la réponse de Yoyo01000
Messages postés
1904
Date d'inscription
lundi 3 mai 2010
Statut
Membre
Dernière intervention
29 avril 2019
120
0
Merci
Bonjour,

Que se passe-t-il si A=B ou A=C ?

A+
nathan027
Messages postés
27
Date d'inscription
mercredi 23 septembre 2009
Statut
Membre
Dernière intervention
7 mai 2019
-
ce n'est pas possible dans mon cas de figure
Commenter la réponse de Zoul67
Messages postés
1933
Date d'inscription
mercredi 27 juillet 2005
Statut
Membre
Dernière intervention
22 juin 2019
746
0
Merci
Bonjour,

tu peux essayer =3-(A-B>0)-(A-C>0)
si A=B=C, tu obtiendras 3.
sinon tu mets des >= au lieu des >.

cordialement
Commenter la réponse de JvDo
Messages postés
252
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
7 avril 2019
22
0
Merci
avec ceci, ça devrait être bon :


==SI(ET(A1>B1;A1>C1);"1";"")&SI(ET(A1>B1;A1<C1);"2";"")&SI(ET(A1<B1;A1>C1);"2";"")&SI(ET(A1<B1;A1<C1);"3";"")

j'ai pris en compte le fait qu'il n'y aura jamais de valeurs égales.
Commenter la réponse de Yoyo01000
Messages postés
27
Date d'inscription
mercredi 23 septembre 2009
Statut
Membre
Dernière intervention
7 mai 2019
0
Merci
Voilà ce que j'ai fait et qui fonctionne

=SI(ET(B9>=D9;B9>=F9);1;SI(OU(ET(B9<D9;B9>=F9);ET(B9>=D9;B9<F9));0;-1))

Merci à tous pour votre aide.
Commenter la réponse de nathan027