Menu

Extraction dans tableau double-entrée [Résolu]

Messages postés
11
Date d'inscription
vendredi 1 février 2019
Dernière intervention
13 février 2019
-
Bonjour à tous,

A partir d'un tableau à double-entrée, je souhaite extraire un sous-tableau afin de faire des calculs dessus (Dans le cas du fichier en pièce jointe des produits sur les coefficients en colonne). Lorsque je sélectionne une ou plusieurs options à droite de la feuille, je voudrais qu'Excel me génère un sous-tableau ou seuls les lignes correspondantes aux options sélectionnées apparaissent.
Quand il n y'a rien de sélectionné dans une option, celle-ci ne doit pas apparaître dans les lignes du sous-tableau
J'ai trouvé une solution avec des RECHERCHEV mais la mise en place est assez lourde d'autant que le tableau final sera beaucoup plus grand que celui en exemple. Je pensais plutôt utiliser un tableau croisé dynamique mais j'en ai jamais utilisé et le schéma des TCD semble différent de ce que j'ai mis en place.

Merci d'avance

Configuration: Windows / Internet Explorer 11.0
Afficher la suite 

Votre réponse

9 réponses

Meilleure réponse
Messages postés
2266
Date d'inscription
samedi 19 avril 2008
Dernière intervention
15 février 2019
280
1
Merci
Re
Oui, c'est astucieux.Ça part du meme principe.
Pour ta colonne
=SI($B$23=0;1;RECHERCHEV($B$23;Diameter;2;FAUX))
tu remplaces le 2 par colonne(b:b) ou colonnes($a:b)

=SI($B$23=0;1;RECHERCHEV($B$23;Diameter;colonne(b:b);FAUX))



Crdlmt

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 57030 internautes nous ont dit merci ce mois-ci

Commenter la réponse de DjiDji59430
Messages postés
2266
Date d'inscription
samedi 19 avril 2008
Dernière intervention
15 février 2019
280
0
Merci
Bonjour,

" Dans le cas du fichier en pièce jointe "

Où ?
Crdlmt
Loiwi
Messages postés
11
Date d'inscription
vendredi 1 février 2019
Dernière intervention
13 février 2019
-
Je n'ai pas réussi à insérer le fichier, c'est à partir de l'onglet "insérer une image"?
Commenter la réponse de DjiDji59430
Messages postés
2266
Date d'inscription
samedi 19 avril 2008
Dernière intervention
15 février 2019
280
0
Merci
Tu vas sur https://www.cjoint.com/ tu upload ton fichier et tu reviens mettre le lien
Crdlmt
Commenter la réponse de DjiDji59430
Messages postés
11
Date d'inscription
vendredi 1 février 2019
Dernière intervention
13 février 2019
Commenter la réponse de Loiwi
Messages postés
2266
Date d'inscription
samedi 19 avril 2008
Dernière intervention
15 février 2019
280
0
Merci
Re

Un essai
https://www.cjoint.com/c/IBbk2W1H5QW
Crdlmt
Commenter la réponse de DjiDji59430
Messages postés
11
Date d'inscription
vendredi 1 février 2019
Dernière intervention
13 février 2019
0
Merci
Merci pour la proposition, mais je ne peux pas mettre en place les simplifications proposées, j'ai modifié les noms des options car ce sont des informations confidentielles. De plus, le diamètre peut avoir un impact sur le choix de la couleur puisque le rouge n'est pas possible pour les diamètres 10 à 30
Commenter la réponse de Loiwi
Messages postés
2266
Date d'inscription
samedi 19 avril 2008
Dernière intervention
15 février 2019
280
0
Merci
Re
Ce nest pas "Extraction dans tableau double-entrée" mais Extraction dans tableau triple-entrée

https://www.cjoint.com/c/IBbn2Qd3Q4W

A vérifier ....
Commenter la réponse de DjiDji59430
Messages postés
11
Date d'inscription
vendredi 1 février 2019
Dernière intervention
13 février 2019
0
Merci
Ce sera même un tableau à vingt entrées une fois qu'il sera complet. La formule fonctionne mais elle deviendra ingérable quand il y'aura vingt entrées. Ci-joint une proposition utilisant des recherchev qui fonctionne bien aussi mais étant fainéant, je voulais savoir si il était possible d'écrire la formule dans la première case et de tirer celle-ci pour n'incrémenter que le numéro de la colonne.

https://www.cjoint.com/c/IBekU7DcmPR
Commenter la réponse de Loiwi
Messages postés
11
Date d'inscription
vendredi 1 février 2019
Dernière intervention
13 février 2019
0
Merci
Cela fonctionne parfaitement, merci!
Commenter la réponse de Loiwi