Menu

Ma page css marche 1/2 ! [Résolu]

Messages postés
4
Date d'inscription
vendredi 21 septembre 2018
Dernière intervention
3 décembre 2018
- - Dernière réponse : [Dal]
Messages postés
4804
Date d'inscription
mercredi 15 septembre 2004
Statut
Contributeur
Dernière intervention
13 décembre 2018
- 4 déc. 2018 à 14:01
Bonjour,

je veux créer un forum, j'ai donc crée une page .php et une page css le problème est que ma page css fonctionne mais le lendemain elle ne fonctionne plus je suis donc obliger de la changer de dossier pour que cela remarche.

Je suis sur que cela ne vient pas de mon code car si je change ne serait ce que la couleur du texte ça ne fonctionne pas mais si je change de dossier ça remarche (je n'ai pas envie de changer de dossier chaque jour).
Afficher la suite 

Votre réponse

2 réponses

Messages postés
4
Date d'inscription
vendredi 21 septembre 2018
Dernière intervention
3 décembre 2018
0
Merci
J'ai changer la page css de dossier et ça remarche ce qui montre bien qu'il doit y avoir un problème avec mes dossier où je ne sait pas quoi
Commenter la réponse de NeilSauvage2003
Messages postés
4804
Date d'inscription
mercredi 15 septembre 2004
Statut
Contributeur
Dernière intervention
13 décembre 2018
0
Merci
Salut NeilSauvage2003,

"ça fonctionne", "ça ne fonctionne plus", "ça remarche", ne nous renseignent pas utilement sur :

- ce qui arrive et que tu penses être anormal
- ce que qui devrait arriver selon toi et pourquoi tu penses que le fait que cela ne se produise pas est un problème

mets toi à la place d'un lecteur qui n'est pas dans ta tête.

Sinon, bien sûr, on pourrait jouer aux devinettes, et se dire que ce que tu constates (et que tu ne décris pas) est que si tu fais une modification de ton fichier css sur le serveur, cette modification n'est pas visible sur la page qui s'affiche sur le navigateur qui continue de s'afficher en utilisant une ancienne version du fichier .css et qu'elle ne devient visible, dans tes essais, que si du changes le fichier css de répertoire, auquel cas ton problème serait probablement seulement dû à la mise en cache du fichier .css, en qu'en lisant dans une boule de cristal, le problème que tu cherches à résoudre pendant ton développement trouve différentes solutions comme expliquées là :

https://css-tricks.com/strategies-for-cache-busting-css/
https://stackoverflow.com/questions/9560447/preventing-caching-of-css-files

Dal
Commenter la réponse de [Dal]