Menu

Installation drivers scanner. [Résolu]

Messages postés
21
Date d'inscription
jeudi 1 novembre 2018
Dernière intervention
2 novembre 2018
- 1 nov. 2018 à 18:08 - Dernière réponse :
Messages postés
35984
Date d'inscription
dimanche 7 novembre 2010
Statut
Contributeur
Dernière intervention
20 novembre 2018
- 2 nov. 2018 à 13:17
Bonjour,

Je suis nouveau donc désolé si ma question a (peut-être) déjà été posée.

Voici mon petit souci:

Mon pc est sous Linux Mint 19.

Comme je suis traducteur, j'ai investi dans une imprimante, modèle Canon Pixma MG5750.
Ce modèle fait imprimante + photocopieur + scanner.

Les drivers (lanceurs) pour imprimante étaient déjà inclus dans Linux Mint 19, mais pour le scanner, il semblerait que la Canon réalise le scan (on entend le bruit typique d'un scanning) mais une fois terminé je ne sais pas où trouver le fichier soit-disant scanné sur mon pc.

Pensant que c'était un problème de drivers, je suis allé les chercher sur le site https://www.canon-europe.com/support/consumer_products/products/fax__multifunctionals/inkjet/pixma_mg_series/pixma_mg5750.aspx?type=drivers&language=EN&os=LINUX

Or je ne parviens pas à les installer. Les deux sont sous le format deb.tar.gz, donc je les "extrais ici" pour les avoir en en dossiers deb.

Dans ces dossiers j'ai deux dossiers ("packages" et "resources") et un fichier appelé "install.sh".

Quand je glisse le fichier "install.sh dans mon terminal, on me demande le mot de passe :

petrus@petrus-MS-7846:~$ '/home/petrus/Bureau/DRIVERS IMPRIMANTE/scangearmp2-3.20-1-deb/install.sh'
/home/petrus/Bureau/DRIVERS IMPRIMANTE/scangearmp2-3.20-1-deb/install.sh: line 327: [: /home/petrus/Bureau: binary operator expected
[sudo] password for petrus:

Et là je ne peux rien taper, pourtant je connais bien mon mot de passe pour le saisir à chaque démarrage administrateur.

Est-ce que quelqu'un pourrait m'aider?

Merci d'avance!
Afficher la suite 

Votre réponse

5 réponses

Messages postés
22630
Date d'inscription
vendredi 28 décembre 2001
Statut
Modérateur
Dernière intervention
18 novembre 2018
Modifié par teutates le 1/11/2018 à 19:18
0
Merci
Bonjour,

En fait, tu te trompe de syntaxe en oubliant la commande qui va te demander le mot de passe administrateur (root) préalable. Tu utilises Linux Mint, donc c'est la même commande que pou Ubuntu, soit sudo.

En résumé, tu dois saisir :
sudo /home/petrus/Bureau/DRIVERS IMPRIMANTE/scangearmp2-3.20-1-deb/install.sh
Comme il est possible que cette saisie ne fonctionne pas, essaie alors avec :
sudo sh /home/petrus/Bureau/DRIVERS IMPRIMANTE/scangearmp2-3.20-1-deb/install.sh
Tu adapteras selon la situation ;-)

C'est après que le mot de passe te sera demandé dans la console (le terminal) puis que la suite de l'opération seta lancè automatiquement (sous réserve du bon mot de passe.)

Commenter la réponse de teutates
Messages postés
13969
Date d'inscription
dimanche 16 décembre 2007
Dernière intervention
21 novembre 2018
1 nov. 2018 à 18:27
0
Merci
bonjour
je ne connais pas bien linux, mais je l'ai déjà pratiqué, il me semble que rien ne s'affiche quand on saisi le mot de passe dans le terminal, mais quand on appuie sur entrée, si le mdp est bon, ça continue
Messages postés
22630
Date d'inscription
vendredi 28 décembre 2001
Statut
Modérateur
Dernière intervention
18 novembre 2018
- 1 nov. 2018 à 19:20
Oui mais il avait oublier de saisir la commande sudo préalable et incontournable pour Ubuntu et toutes ses dérivées quand on fait des manipulations de niveau administrateur (root).
Commenter la réponse de Redbart
0
Merci
Bonjour,
Si le scanner fait du bruit et semble scanner la page, c'est que le pilote est installé. L'image doit s'afficher dans simple-scan. La sauvegarde se fait plus tard.
Essaie de lancer simple-scan en root à partir du terminal :
sudo simple-scan

Si ça fonctionne, c'est un simple problème de droits.
Commenter la réponse de jns55
Messages postés
21
Date d'inscription
jeudi 1 novembre 2018
Dernière intervention
2 novembre 2018
2 nov. 2018 à 07:12
0
Merci
Bonjour,
Merci pour vos réponses. J'ai essayé tous vos conseils et je tombe toujours sur :
[sudo] password for petrus:
et là je ne peux rien taper.
Si c'est un problème de droits dois-je "déclarer" mon imprimante/scanner à Canon?
A bientôt
Messages postés
21
Date d'inscription
jeudi 1 novembre 2018
Dernière intervention
2 novembre 2018
- 2 nov. 2018 à 10:05
Voici ce que j'obtiens :
petrus@petrus-MS-7846:~$ whereis simple-scan
simple-scan: /usr/bin/simple-scan /usr/share/simple-scan /usr/share/man/man1/simple-scan.1.gz
Messages postés
35984
Date d'inscription
dimanche 7 novembre 2010
Statut
Contributeur
Dernière intervention
20 novembre 2018
>
Messages postés
21
Date d'inscription
jeudi 1 novembre 2018
Dernière intervention
2 novembre 2018
- 2 nov. 2018 à 10:09
Donc il est bien installé et malgré ça lorsque tu tapes
sudo simple-scan
et que tu entres le mot de passe, tu reçois "command not found", c'est ça ?
Messages postés
21
Date d'inscription
jeudi 1 novembre 2018
Dernière intervention
2 novembre 2018
- 2 nov. 2018 à 10:11
oui c'est ça
Messages postés
35984
Date d'inscription
dimanche 7 novembre 2010
Statut
Contributeur
Dernière intervention
20 novembre 2018
>
Messages postés
21
Date d'inscription
jeudi 1 novembre 2018
Dernière intervention
2 novembre 2018
- 2 nov. 2018 à 10:24
Si tu tapes
simple-scan
sans le sudo devant, le logiciel s'ouvre ?
Dans Mint simple-scan est installé par défaut... Tu ferais pas une faute de frappe par hasard ?
Essaie avec xsane :
sudo apt-get install xsane
sudo xsane
Commenter la réponse de Skubadubb
Messages postés
21
Date d'inscription
jeudi 1 novembre 2018
Dernière intervention
2 novembre 2018
2 nov. 2018 à 10:13
0
Merci
Note : il se peut que le fichier scanné soit déjà sur le pc, mais je ne sais pas où!
(J'ai fouillé dans mes documents, mes images, mes téléchargements etc... )
Messages postés
35984
Date d'inscription
dimanche 7 novembre 2010
Statut
Contributeur
Dernière intervention
20 novembre 2018
>
Messages postés
21
Date d'inscription
jeudi 1 novembre 2018
Dernière intervention
2 novembre 2018
- 2 nov. 2018 à 12:06
Les dépendances se sont installées, donc faut juste relancer
sudo ./install.sh
Messages postés
21
Date d'inscription
jeudi 1 novembre 2018
Dernière intervention
2 novembre 2018
- 2 nov. 2018 à 13:01
petrus@petrus-MS-7846:~/Bureau/DRIVERS IMPRIMANTE/scangearmp2-3.20-1-deb$ sudo ./install.sh
[sudo] password for petrus:
==================================================

ScanGear MP
Version 3.20
Copyright CANON INC. 2007-2015

==================================================
Commande exécutée = sudo dpkg -iG ./packages/scangearmp2_3.20-1_amd64.deb
Sélection du paquet scangearmp2 précédemment désélectionné.
(Lecture de la base de données... 265448 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../scangearmp2_3.20-1_amd64.deb ...
Dépaquetage de scangearmp2 (3.20-1) ...
Paramétrage de scangearmp2 (3.20-1) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.27-3ubuntu1) ...
L'installation est terminée.
petrus@petrus-MS-7846:~/Bureau/DRIVERS IMPRIMANTE/scangearmp2-3.20-1-deb$
Messages postés
21
Date d'inscription
jeudi 1 novembre 2018
Dernière intervention
2 novembre 2018
- 2 nov. 2018 à 13:03
Installation terminée!
Il me reste à tester, mais déjà je te remercie énormément sipe31!!
Tu m'as permis d'écrire une langue que je ne maîtrise pas encore, alors si un jour tu as besoin d'un coup de main pour une traduction en anglais, néerlandais ou allemand, n'hésite pas à me demander!
Messages postés
21
Date d'inscription
jeudi 1 novembre 2018
Dernière intervention
2 novembre 2018
- 2 nov. 2018 à 13:04
Oups!
Zipe31, pardon!
Messages postés
35984
Date d'inscription
dimanche 7 novembre 2010
Statut
Contributeur
Dernière intervention
20 novembre 2018
>
Messages postés
21
Date d'inscription
jeudi 1 novembre 2018
Dernière intervention
2 novembre 2018
- 2 nov. 2018 à 13:17
Pas de soucis ;-))
Commenter la réponse de Skubadubb