Menu

Classement de SOMMEPROD par ordre décroissant

Ereudet 23 Messages postés vendredi 18 mai 2018Date d'inscription 13 septembre 2018 Dernière intervention - 11 sept. 2018 à 00:44 - Dernière réponse : Ereudet 23 Messages postés vendredi 18 mai 2018Date d'inscription 13 septembre 2018 Dernière intervention
- 13 sept. 2018 à 00:43
Bonjour,

Dans le excel ci-dessous, j'ai 3 équipes qui ont joué des matchs entre elles, quand un match est gagné, ça vaut 1 point, quand il est perdu, ça vaut 0 point (en orange dans le excel ci-dessous). Toutes les équipes se rencontrent une fois, on a donc soit 1 point pour chacune des équipes, soit 2 pour l'une, 1 pour l'autre, et 0 pour la dernière.

Ensuite, j'ai également le nombre de buts marqués (en jaune).

Je voudrais ensuite réussir à classer automatiquement ces équipes de la meilleure à la moins bonne (cellules en rouge à compléter). Pour cela, il faut d'abord comparer les victoires ou défaites. Si on est dans le cas, 2-1-0, le classement est fait rapidement, si on est dans le cas 1-1-1, alors il faut regarder le nombre de but pour faire le classement.

Je pense partir sur des SOMMEPROD :

=SOMMEPROD((C3:C14="EQUIPE 1")*(E3:E14)) pour les parties gagnées et =SOMMEPROD((C3:C14="EQUIPE 1")*(D3:D14)) pour les buts. Ces formules me permettront de calculer le nombre de parties gagnées et de buts marqués, mais comment faire pour classer les résultats des sommeprod par ordre décroissant. J'ai essayé en ajoutant une fonction SI, mais la formule était très longue et je pense qu'on peut faire plus simple.

Avez-vous SVP une idée pour que les cellules G8 à G10 se remplissent automatiquement ? Merci :) :

https://www.cjoint.com/c/HIkwRloDI6p



Afficher la suite 

Votre réponse

5 réponses

DjiDji59430 2065 Messages postés samedi 19 avril 2008Date d'inscription 20 septembre 2018 Dernière intervention - 11 sept. 2018 à 11:38
0
Merci
Bonjour,

Ah ! Toute ma jeunesse sur un Stella au bistrot, les cals dans les paumes des mains, le stock de pieces de 20 centimes de francs posé a cote du cendrier !!
Un essai :

https://www.cjoint.com/c/HIljJp61mJZ


Crdlmt
Ereudet 23 Messages postés vendredi 18 mai 2018Date d'inscription 13 septembre 2018 Dernière intervention - 11 sept. 2018 à 19:20
Yes, moi je viens de me racheter un baby, pour ma rappeler mes soirées lycée ! Un bonzini B60 comme je les aime ! Du coup c'est grosse compet à la maison :) Merci pour ton aide, mais ce n'est pas exactement ce que je cherchais, en fait j'aurais souhaité que les cellules G8 à G10 dans mon fichier se remplissent automatiquement, sans changer la forme, pour faire le classement de la poule, c'était juste une étape de mon fichier. Puis finalement à force de chercher j'ai trouvé la solution, voici le fichier finalisé :)

https://www.cjoint.com/c/HIlrs3UCO6p
Ereudet 23 Messages postés vendredi 18 mai 2018Date d'inscription 13 septembre 2018 Dernière intervention - 11 sept. 2018 à 20:41
Par contre, pour les classements des poules, j'ai mis des formules à rallonge, c'est du bricolage, ça fonctionne bien, mais je pense qu'on peut faire plus simple si vous avez une idée !
Commenter la réponse de DjiDji59430
DjiDji59430 2065 Messages postés samedi 19 avril 2008Date d'inscription 20 septembre 2018 Dernière intervention - 12 sept. 2018 à 19:54
0
Merci
Re

https://www.cjoint.com/c/HImr0Pc8K2Z

En général, on ne fait pas de calcul dans la présentation.
Du coup, j'ai fait des tableaux en feuille1 qui sont plus faciles a manipuler et avec des formules plus simple !


Crdlmt
Ereudet 23 Messages postés vendredi 18 mai 2018Date d'inscription 13 septembre 2018 Dernière intervention - 13 sept. 2018 à 00:43
Ah yes, effectivement c'est plus simple ! Merci bcp ! :)
Commenter la réponse de DjiDji59430