Menu

Date et solde d'un tableau financier [Résolu]

Gustav - 8 févr. 2018 à 20:32 - Dernière réponse :  Gustav
- 8 févr. 2018 à 21:43
Bonsoir à tous et merci d'avance pour votre réponse précieuse.
Voilà mon problème :
J'ai sur une page excel (Feuil1). Quatre colonnes.
Une colonne A réservée à la date
Une colonne B réservée aux débits
Une colonne C réservée aux crédits
Une colonne D réservée aux soldes
Je voudrais que dans une autre page (Feuil2) apparaissent automatiquement tous les 10 du mois et tous les 20 du mois le solde des comptes ne sachant pas à l'avance sur quelles lignes apparaissent ces deux dates et donc ces deux soldes.
J'attends un génie d'excel pour me donner une réponse. Merci à lui d'avance.
Gustav
Afficher la suite 

Votre réponse

7 réponses

Vaucluse 22016 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 23 mai 2018 Dernière intervention - Modifié par Vaucluse le 8/02/2018 à 20:58
0
Utile
Bonjour

si vous parlez du mois en cours (ce n'est pas précisé)

pour un champ de ligne 2 à ligne 1000 en feuil 1 à limiter au plus court pour réduire le poids de la formule


pour le 10

=SOMMEPROD((Feuil1!$A$2:$A$1000>0)*(Feuil1!$A$2:$A$1000<=DATE(ANNEE(AUJOURDHUI());MOIS(AUJOURDHUI());10))*(Feuil1!$B$2:$B$1000-Feuil1!$C$2:$C$1000))

pour le 20 idem en remplaçant 10 par 20

si vos comptes ne portent que sur cette année, vous pouvez remplacer ANNEE(AUJOURDHUI()) par 2018

et si vous inscrivez dans une cellule par exemple A2 la formule:

=DATE(ANNEE(AUJOURDHUI());MOIS(AUJOURDHUI());10)
il suffira de placer en B2:

=SOMME.SI(Feuil1!A:A;"<="&A2;B:B)-SOMME.SI(Feuil1!A:A;"<="&A2;C:C)

ou pour aller chercher en D le solde

=INDEX(D:D;EQUIV(A2;Feuil1!A:A;0)+NB.SI(Feuil1!A:A;A2)-1)


crdlmnt



t






Merci pour ta réponse rapide.
D'abord il s'agit d'un tableau annuel qui se remplit au fur et à mesure des mois qui s'écoulent, donc pas forcement pour le mois en cours.
Ensuite la formule ne marche pas; Excel me dit qu'elle est trop longue.
Désolé pour toi.
Si tu as une autre idée, merci à toi
Gustav
Vaucluse 22016 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 23 mai 2018 Dernière intervention - 8 févr. 2018 à 21:08
Non pas d'autre idée, vu qu'elles fonctionnent toutes ici

ci joint un fichier avec en bleu la formule "trop longue" directement copiée/collée du message

Par ailleurs, si vous faites dans une feuille un tableau avec en A les dates où vous voulez afficher les soldes, vous pourrez placer une de ces formules en B pour avoir le solde à chaque date
Non?

et si vous voulez n'afficher un résultat que si la date du jour est atteinte en A:
=SI(A2<=AUJOURDHUI();.....formule.....;"")

https://mon-partage.fr/f/ITPFj1H5/

crdlmnt
En fait la formule marche mais elle ne respecte pas le 10 et le 20 de chaque mois.
Elle prend en compte le 11, le 13 du mois , chose qu'elle ne devrait pas faire!
Merci
Gustav
Merci ça marche
Tu es un génie!
Gustav
Commenter la réponse de Vaucluse
via55 9304 Messages postés mercredi 16 janvier 2013Date d'inscription 22 mai 2018 Dernière intervention - Modifié par via55 le 8/02/2018 à 21:09
0
Utile
Bonsoir à vous deux

Gustav la formule de Vaucluse parfaitement conçue est bien valable pour une année entière et s'adapte au mois actuel pour trouver les soldes correspondant à ce mois et elle n'est pas trop longue ! Qu'as tu entré ?


Un grand merci à toi pour la réponse rapide.
Il faudrait que la date et le solde apparaissent sur la même feuille 2 résumé de l'année
Merci
Gustav
Commenter la réponse de via55