Menu

Calcul date et heure avec condition

mohvega 6 Messages postés jeudi 8 février 2018Date d'inscription 10 février 2018 Dernière intervention - 8 févr. 2018 à 21:32 - Dernière réponse : mohvega 6 Messages postés jeudi 8 février 2018Date d'inscription 10 février 2018 Dernière intervention
- 10 févr. 2018 à 14:29
Bonjour,

Je veux calculer le nombre de jours qu'un employé a fait pendant une mission afin de rembourser les frais non pris en charge par l'entreprise. J'ai déjà la formule qui permet de décompter TOUT.

REPAS: =2*(($H3-$F3)-1)+SI($G3<=Début_repas_midi;2;SI($G3<=Début_repas_soir;1;SI($G3>=Fin_repas_soir 0)))+SI($I3>=Fin_repas_soir;2;SI($I3>=Fin_repas_midi;1;0))

HEBERGEMENT: =SI($H3<=Fin_nuitée;$H3-$F3+1;$H3-$F3)


mais je n'arrive pas à la modifier dans ce sens là:

- Décompter uniquement UN repas par jour de mission sans hébergement.
- Décompter uniquement DEUX repas par jour de mission sans hébergement.
- Décompter uniquement les repas sans hébergement.
- Décompter uniquement l'hébergement sans les repas.

Je suis débutant sur Excel, et je n'arrive pas à modifier la formule selon les Quatre critères ci-dessus.
Afficher la suite 

Votre réponse

10 réponses

via55 9302 Messages postés mercredi 16 janvier 2013Date d'inscription 19 mai 2018 Dernière intervention - 9 févr. 2018 à 00:31
0
Utile
Bonjour mohvega

Au lieu de joindre une image qui ne sert à rien pour t'aider, d'autant plus que tu as des plages nommées dans ta formule, postes un exemple de ton fichier sur cjoint.com, fais créer un lien que tu copies et reviens coller ici

Cdlmnt
Via
mohvega 6 Messages postés jeudi 8 février 2018Date d'inscription 10 février 2018 Dernière intervention - 9 févr. 2018 à 08:47
Bonjour Via,

Merci pour ta réponse. Je suis nouveau sur le forum et je savais pas de cette possibilité.

Voilà donc mon fichier. Merci d'avance.

https://www.cjoint.com/c/HBjhSp4inni
Commenter la réponse de via55
via55 9302 Messages postés mercredi 16 janvier 2013Date d'inscription 19 mai 2018 Dernière intervention - 9 févr. 2018 à 09:19
0
Utile
Bonjour movhega

Ok, je pars au boulot, je regarde ça cet après midi en rentrant
mohvega 6 Messages postés jeudi 8 février 2018Date d'inscription 10 février 2018 Dernière intervention - 9 févr. 2018 à 10:01
Via,

Juste pour t'informer que le problème d'hébergement est réglé, j'ai ajouter la formule si(ou comme suit:

=SI(OU($E4="1R/J";$E4="2R/J";$E4="R/SEUL");0;SI($H4<=Fin_nuitée;$H4-$F4+1;$H4-$F4))

Reste le probléme des repas.

Voilà le nouveau fichier:

https://www.cjoint.com/c/HBjjawXNNQp

Merci
Commenter la réponse de via55
via55 9302 Messages postés mercredi 16 janvier 2013Date d'inscription 19 mai 2018 Dernière intervention - 9 févr. 2018 à 17:36
0
Utile
Re,

Peut être ainsi alors :
https://www.cjoint.com/c/HBjqKlD4YDB

Cdlmnt
mohvega 6 Messages postés jeudi 8 février 2018Date d'inscription 10 février 2018 Dernière intervention - 9 févr. 2018 à 22:37
Re,

Merci beaucoup Via55, c exactement ce que je veux...

Reste un petit détail pour "1R/J" et "2R/J". j'ai pris un exemple d'une mission pour une même journée (cellule en jaune) mais avec date de retour à 10:00 (4 heures de mission). il donné UN repas pour "1R/J" et DEUX repas pour "2R/J", alors qu'on réalité et selon le paramétrage les deux résultats sont faux.

Maintenant je veux 1 repas quand la date de retour est supérieure ou égale à 11:00 et 2 repas quand elle est supérieure ou égale à 18:00 (selon paramétres).

ci-joint le fichier

https://www.cjoint.com/c/HBjvJFcluDp

Merci d'avance
Commenter la réponse de via55
via55 9302 Messages postés mercredi 16 janvier 2013Date d'inscription 19 mai 2018 Dernière intervention - 10 févr. 2018 à 00:10
0
Utile
Re,

1) Je ne comprends pas alors la différence qu'il y a entre 2R/J et R/seul ? ils doivent retourner le même résultat si on tient compte des paramètres pour 2R/J ?

2)Est ce que la formule fonctionne correctement dans tous les cas de mission de plus d'un jour ?
En ce cas il y aurait lieu d'y ajouter simplement une formule pour le cas d'une mission d'une journée

En attendant tes précisions je prépare un tableau découpant la formule selon les jours pour y voir plus clair

"L'imagination est plus importante que le savoir."    A. Einstein
mohvega 6 Messages postés jeudi 8 février 2018Date d'inscription 10 février 2018 Dernière intervention - 10 févr. 2018 à 08:28
Re,

Oui via, la formule fonctionne parfaitemet dans tous les cas de mission de plus d'un jour.

Y a pas de différence entre 2R/J et R/SEUL si on parle de résultat.

R/SEUL sert seulement à m'informer que l'employé en mission est toujours en bénéficie d'un hébergement pris en charge par l'entreprise. (l'entreprise rembourse seulement les repas)

Mais 2R/J veut dire que l'employé ne bénéficie pas de l'hébergement pris en charge (ex. il rentre chez lui tard la nuit) et il est en mission toute la journée et ce toujours (ex. de 06:00 à 21:00).

Merci
via55 9302 Messages postés mercredi 16 janvier 2013Date d'inscription 19 mai 2018 Dernière intervention - 10 févr. 2018 à 14:03
Re,

C'est bien ce que j'avais cru comprendre

Voilà le tableau pour voir si les résultats sont corrects,
si c'est le cas tu auras le choix où de bâtir une longue formule à partir des formules partielles où de conserver le tableau en le masquant si nécessaire
https://www.cjoint.com/c/HBknaoobzcB

Cdlmnt
mohvega 6 Messages postés jeudi 8 février 2018Date d'inscription 10 février 2018 Dernière intervention - 10 févr. 2018 à 14:29
Re,

J'apprécie bcp ton effort via55.

Je viens de recevoir une réponse à partir d'un autre forum d'excel. Elle plus simple je pense.

Pour information, je te joint le fichier avec cette solution, et avec les mêmes dates que tu as mis dans le fichier en réponse.

https://www.cjoint.com/c/HBknDcW8n4h

J'aime savoir ton avis sur cette solution.

Merci encore
Cordialement
Commenter la réponse de via55