Exclusion des cellules vides dans formule NB.SI.ENS [Résolu/Fermé]

Signaler
-
 remy -
Bonjour,

Dans une plage de données G11:G1000 je dispose uniquement des 3 données RF, RF, et AZ pour exemple dans les 3 premières lignes
Je rentre la formule ci dessous pour obtenir les valeurs différentes de RF en excluant les cellules vides
=NB.SI.ENS($G$11:$G$1000;"<>RF";$G$11:$G$1000;"<>""")
Et j'obtiens en retour 988 :( alors que j'attendrais 1 comme résultat dans cet exemple.

Quelqu'un pourrait il me dire où est l'erreur svp ?

Merci d'avance !



2 réponses

Messages postés
2567
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
24 février 2020
310
Bonjour,

essaye avec

=NB.SI.ENS($G$11:$G$1000;"<>RF";$G$11:$G$1000;"<>")

Elle sont vraiment vides, tes cellules (pas le resultat d'une formule
?)

Un morceau, ou bien le fichier expliciterait mieux ta demande !!

Cdlmnt
3
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 86490 internautes nous ont dit merci ce mois-ci

Hello DjiDji
Parfait, ça fonctionne !
C'est quand même parfois tordu, en clair il faut lui dire "différent de RF" et "différent tout court" pour que ça marche :)

Merci et bonne fin de week end