Menu

Besoin d'aide avec la fonction SI [Résolu/Fermé]

Yan - 16 mai 2017 à 02:52 - Dernière réponse : Raymond PENTIER 46116 Messages postés lundi 13 août 2007Date d'inscriptionContributeurStatut 22 juin 2018 Dernière intervention
- 17 mai 2017 à 01:17
Bonjour, voici ma situation: j'essais de faire un tableau de mesures finies et brutes pour des planches de bois et je souhaite que lorsque j'inscrit mm dans une case (pour millimètre) que cela me fasse une multiplication suivi d'une addition d'une certaine cellule vers une autre pour que mes mesures deviennent en pouce.

Si ma cellule I8 est égal à ''mm'' ma cellule H8 fera (* 25,4 + 1) sinon ma cellule H8 fera seulement (+1)

Voici la formule que j'ai essayé et qui ne marche pas: =SI(I8=''mm'';H8*25,4+1;H8+1)

Merci d'avance à celui ou ceux qui pourront m'aider.

Yan.
Afficher la suite 

12 réponses

Raymond PENTIER 46116 Messages postés lundi 13 août 2007Date d'inscriptionContributeurStatut 22 juin 2018 Dernière intervention - 16 mai 2017 à 03:28
0
Merci
Bonjour.

C'est curieux : Ta formule devrait marcher !
Yan > Raymond PENTIER 46116 Messages postés lundi 13 août 2007Date d'inscriptionContributeurStatut 22 juin 2018 Dernière intervention - 16 mai 2017 à 03:57
ma cellule de départ est en N8 je ne comprend pas pourquoi il semble avoir un problème avec le ''mm''
Raymond PENTIER 46116 Messages postés lundi 13 août 2007Date d'inscriptionContributeurStatut 22 juin 2018 Dernière intervention > Yan - 16 mai 2017 à 04:02
Moi non plus ... Alors il serait temps de nous envoyer ton fichier, pour qu'on vérifie tes données et tes formules.
 1) Tu vas dans http://cjoint.com/ 
2) Tu cliques sur [Parcourir] pour sélectionner ton fichier (15 Mo maxi)
3) Tu défiles vers le bas pour cliquer sur le bouton bleu [Créer le lien Cjoint]
4) Au bout de quelques secondes la deuxième page s'affiche, avec le lien en gras ; tu fais un clic-droit dessus et tu choisis "Copier le lien"
5) Tu reviens dans ta discussion sur CCM, et dans ton message tu fais "Coller".
=>Voir la fiche http://www.commentcamarche.net/faq/29493-utiliser-cjoint
Yan > Raymond PENTIER 46116 Messages postés lundi 13 août 2007Date d'inscriptionContributeurStatut 22 juin 2018 Dernière intervention - 16 mai 2017 à 04:11
http://www.cjoint.com/c/GEqcjVOG5qZ
La formule ce trouve dans l'onglet liste de débitage au case mentionné au début de la conversation et je me suis tromper a une endroit ce n'est pas une multiplication que je veux faire mais une division pour que mes mm devienne des po
pour le moment je n'est pas mis les '' '' au mm car quand je l'est met la formule me fais une erreur
Vaucluse 22239 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 22 juin 2018 Dernière intervention - Modifié par Vaucluse le 16/05/2017 à 08:01
0
Merci
Bonjour

votre mm en I8 étant un texte, oui, il faut le placer entre guillemets dans la formule en N8

=SI(I8="mm";H8/25,4+1;H8+1)

chez moi, elle fonctionne avec cette modif
Par contre elle est écrite dans votre modèle avec / division au lieu de *multiplication dans votre message initial

en aparté, je pense que la cellule O8 mériterait une formule du genre: =I8

crdlmnt

La qualité de la réponse dépend surtout de la clarté de la question, merci!
Raymond PENTIER 46116 Messages postés lundi 13 août 2007Date d'inscriptionContributeurStatut 22 juin 2018 Dernière intervention - 16 mai 2017 à 15:50
Non, ami Vaucluse : la colonne O donne toujours des mesures en pouces !
Cordiales salutations.
Raymond PENTIER 46116 Messages postés lundi 13 août 2007Date d'inscriptionContributeurStatut 22 juin 2018 Dernière intervention - 16 mai 2017 à 15:50
0
Merci
Je confirme :
Avec "mm" la formule marche parfaitement et affiche 3,36 en N8 ...
0
Merci
Bonjour messieurs,

Je crois que je viens de trouver le problème. Pour faire mes guillemets je faisais 2 fois l'apostrophe et non un ''vrai guillemet'' donc en copiant la formule écrite par Vaucluse ça marche.

Mille fois merci à vous deux.
Raymond PENTIER 46116 Messages postés lundi 13 août 2007Date d'inscriptionContributeurStatut 22 juin 2018 Dernière intervention - 17 mai 2017 à 01:17
Alors ça ! Je n'aurais imaginé une telle chose !