Menu

Recherche formule [Résolu/Fermé]

Messages postés
84
Date d'inscription
lundi 27 février 2017
Statut
Membre
Dernière intervention
23 mai 2019
- - Dernière réponse : Coco-8
Messages postés
84
Date d'inscription
lundi 27 février 2017
Statut
Membre
Dernière intervention
23 mai 2019
- 26 avril 2017 à 09:05
Bonjour,
Voici un tableau de production pour 3 types de produits : A, B et C sur une journée. 1 ligne correspond à 1 étape de production.
J'aimerais trouver une formule sur excel me permettant d'obtenir la quantité moyenne par jour pour chaque type de produit.
La fonction MOYENNE.SI(<>0) ne me donne pas un résultat juste car un produit peut passer par 1, 2 ou 3 étapes. Dans mon exemple, pour le produit A le résultat correct est 25 alors que la fonction MOYENNE.SI(<>0) me donne le résultat 12 ((10+10+10+15+15)/5). Le résultat que je souhaite obtenir serai 10+15 soit 25 (car les trois 10 correspondent au même produit)



Si quelqu'un fort(e) en Excel et en Mathématiques pourrait me donner la solution, je lui serais très reconnaissant :)
Afficher la suite 

3 réponses

Meilleure réponse
Messages postés
126
Date d'inscription
jeudi 9 décembre 2010
Statut
Membre
Dernière intervention
21 février 2019
13
1
Merci
Bonjour,

À ce que je vois, il ne s'agit pas de chercher une moyenne, mais une somme conditionnée.
Sans fichier, pas facile d'identifier les plage des cellules concernées, toutefois si l'on suppose que les valeurs se trouvent pour la plage Étape 1 de "A4 à A18" et que celle quantité A "D4 à D18".

Alors cette formule devrait faire l'affaire dans la cellule "D21".
=SOMMEPROD(($A$4:$A$18="x")*($D$4:$D$18))

Faire la même chose pour les autres cellules.

Cordialement.

Dire « Merci » 1

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 42991 internautes nous ont dit merci ce mois-ci

Coco-8
Messages postés
84
Date d'inscription
lundi 27 février 2017
Statut
Membre
Dernière intervention
23 mai 2019
1 -
Bonjour,
Je reviens vers vous car après avoir testé votre formule je me suis rendu compte que lorsque la colonne de l'étape 1 n'était pas cochée, le résultat devenait faux. Or dans certains cas, les produits peuvent ne passer que par les étapes 2 et/ou 3 donc j'aimerais savoir s'il était possible de modifier votre formule pour la rendre juste dans tous les cas.
J'ai essayé d'ajouter fonction OU mais celle-ci ne fonctionne pas
Merci de votre aide.
Messages postés
16907
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
18 juin 2019
3493
1
Merci
Bonjour,

en supposant que tes valeurs sont en colonne D entre D2 et D100
en formule matricielle
=SOMME(1/NB.SI(D2:D100;D2:D100)*D2:D100)

et pour faire la moyenne toujours en matricielle
=SOMME(1/NB.SI(D2:D100;D2:D100)*D2:D100)/NB.SI(D2:D100;">0")

A+
Mike-31

Pas savoir n'est pas un échec, l'échec est le refus d'apprendre.

Dire « Merci » 1

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 42991 internautes nous ont dit merci ce mois-ci

Messages postés
84
Date d'inscription
lundi 27 février 2017
Statut
Membre
Dernière intervention
23 mai 2019
1
0
Merci
Bonjour mdo et Mike,
Merci pour vos réponses, grâce à vous j'ai ce qu'il me faut :)