Compter des cellules contenant du texte avec des formules [Résolu/Fermé]

Signaler
Messages postés
7
Date d'inscription
lundi 8 août 2016
Statut
Membre
Dernière intervention
11 août 2016
-
Raymond PENTIER
Messages postés
50978
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
19 février 2020
-
Bonjour,

Je souhaiterais compter le nombre de cellules contenant du texte sur une colonne.

Cependant la formule NBVAL ne fonctionne pas. Je pense que c'est peut être dû au fait que mes cellules contiennent des formules.

Avez-vous une solution à mon problème ? J'ai fais tous les forums sans aucun résultat :(

Merci par avance !

4 réponses

Messages postés
11761
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
18 février 2020
1 665
Bonjour

Pui c'est du aux formules, essaie :
=NB.SI(ta plage de cellules ;"*")

Cdlmnt
Via
Tal92
Messages postés
7
Date d'inscription
lundi 8 août 2016
Statut
Membre
Dernière intervention
11 août 2016

ça ne marche pas :/
via55
Messages postés
11761
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
18 février 2020
1 665 > Tal92
Messages postés
7
Date d'inscription
lundi 8 août 2016
Statut
Membre
Dernière intervention
11 août 2016

Impossible de t'aider davantage sans connaitre la structure de ton fichier,
Postes un exemple de ton fichier (allégé si nécessaire) sur cjoint.com, fais créer un lien, copies le et reviens le coller ici dans ton prochain message
Tal92
Messages postés
7
Date d'inscription
lundi 8 août 2016
Statut
Membre
Dernière intervention
11 août 2016

via55
Messages postés
11761
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
18 février 2020
1 665 > Tal92
Messages postés
7
Date d'inscription
lundi 8 août 2016
Statut
Membre
Dernière intervention
11 août 2016

Re,

Alors en ce cas :
=NB.SI(I2:I6;">a")

Cdlmnt
Via
Tal92
Messages postés
7
Date d'inscription
lundi 8 août 2016
Statut
Membre
Dernière intervention
11 août 2016

ça marcheeeee !!!!! Merci bcp !! :) :)
Messages postés
50978
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
19 février 2020
12 128
=NBVAL(A1:A100)-NB.VIDE(A1:A100)
Tal92
Messages postés
7
Date d'inscription
lundi 8 août 2016
Statut
Membre
Dernière intervention
11 août 2016

merci mais cela ne marche pas car il y a des formules dans les cellules.
Raymond PENTIER
Messages postés
50978
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
19 février 2020
12 128 > Tal92
Messages postés
7
Date d'inscription
lundi 8 août 2016
Statut
Membre
Dernière intervention
11 août 2016

Essaie d'abord, avant d'être aussi affirmatif !
Dis-toi bien que j'ai pris le soin de revérifier ma formule avant de te la proposer ...
C'est toi qui as commis une erreur en mettant le caractère espace " " au lieu du caractère vide "" !
=SI(G2=0;" ";CHOISIR(MOIS(G2);"janvier";... est inexact
=SI(G2=0;"";CHOISIR(MOIS(G2);"janvier";... est correct.
Messages postés
655
Date d'inscription
dimanche 15 novembre 2015
Statut
Membre
Dernière intervention
19 février 2020
79
Bonjour,

=NB.SI(A$1:A$100;"<>"&"")

Slts
Tal92
Messages postés
7
Date d'inscription
lundi 8 août 2016
Statut
Membre
Dernière intervention
11 août 2016

J'ai testé mais ça ne fonctionne pas non plus : /
Messages postés
655
Date d'inscription
dimanche 15 novembre 2015
Statut
Membre
Dernière intervention
19 février 2020
79
Bonjour,

Voilà la raison pour joindre toujours un fichier lors de la demande,
c'est toujours plus facile de comprendre le sens du problème avec un fichier joint et cela évite beaucoup d’essais qui sont pas fonctionnels

Slts