Menu

Excel : Supprimer données d'une colonne présentes dans une autre [Résolu/Fermé]

- - Dernière réponse :  Gasp227 - 21 sept. 2015 à 15:13
Bonjour,

J'aimerais savoir si vous pouvez m'aider sur excel, voici mon problème :

Dans un tableau, j'ai deux colonnes : la Colonne B "liste complète" où figurent, ligne par ligne, 1000 adresses mail, et la colonne C "adresse invalides" où figurent, ligne par ligne, environ 100 adresses qui figurent toutes une fois dans la colonne B. Ceux-sont en quelques sortes un extrait de la colonne B.

J'aimerais supprimer dans la colonne B toutes les adresses de la colonne C, car elles ne sont plus valides.

Savez vous s'il existe une formule rapide pour le faire, plutôt que de rechercher et supprimer chaque valeur séparément ?

Merci d'avance pour vos réponses !
Gaspard
Afficher la suite 

2 réponses

Meilleure réponse
Messages postés
23958
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
18 mai 2019
5788
3
Merci
Bonjour
pour éviter de passer en VBA:
en colonne ou ailleurs:
commencez en D2 et sur toute la hauteur

=SI(NB.SI($C:$C;B2);"";B2)

vous aurez en D une liste des adresses à garder

copiez la, colonne D

collage spécial "valeur" sur B (ou ailleurs et même éventuellement sur D)

ensuite "trier" ou "supprimer les doublons pour compacter la liste "à trous" obtenue

crdlmnt

Dire « Merci » 3

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 38803 internautes nous ont dit merci ce mois-ci

0
Merci
Super merci beaucoup !