Formule ... [Fermé]

Signaler
-
Freedomsoul
Messages postés
514
Date d'inscription
lundi 9 mai 2011
Statut
Membre
Dernière intervention
17 avril 2013
-
Bonjour,



Voilà je voudrais la formule qui dirait dans ma cellule que si cellule M12= FIXE OU VARIABLE alors ma cellule = 52 et que sinon ma cellule = 36

5 réponses

Personne pour me répondre ?????
Messages postés
514
Date d'inscription
lundi 9 mai 2011
Statut
Membre
Dernière intervention
17 avril 2013
86
Bin ça n'est pas clair ...


FIXE OU VARIABLE ?

ça veux dire quoi ?
Alors j'ai une cellule avec un menu déroulant dans lequel on peut choisir : FIXE, VARIABLE, PERISCOLAIRE, VARIABLE PERISCOLAIRE

Je voudrais que si on choisit FIXE ou VARIABLE dans le menu déroulant, une autre cellule affiche 52 ou 36 quand on choisit FIXE ou VARIABLE
Messages postés
514
Date d'inscription
lundi 9 mai 2011
Statut
Membre
Dernière intervention
17 avril 2013
86
AH ! d'accord "FIXE" ou "VARIABLE" :)

Donc, c'est pas bien compliqué :

Il suffit d'ajouter une condition dans la cellule ou tu veux mettre 52 ou 36 :

Si on prend la cellule A1 comme réfèrence (qui va contenir "FIXE" ou "VARIABLE" :
il suffit d'ajouter cette formule dans la cellule B1

=SI(A1="FIXE";52;SI(A1="VARIABLE";36;""))
Merci mais c'est pas tout à fait cela ... Je veux que ma cellule affiche 52 quand si A1 ="FIXE" ou "VARIABLE" sinon elle doit afficher 36
Freedomsoul
Messages postés
514
Date d'inscription
lundi 9 mai 2011
Statut
Membre
Dernière intervention
17 avril 2013
86
Ah, dans ce cas

=SI(OU(A1="FIXE";A1="VARIABLE");52;36)
Lili03100
Messages postés
32
Date d'inscription
lundi 21 mai 2012
Statut
Membre
Dernière intervention
23 décembre 2019

Merci cela fonctionne !! Je voudrais maintenant mettre dans une autre cellule la condition suivante : si B1 = "MOINS 65 ANS" alors ma cellule = 14,95%, si B1 = "moins de 65 ans Alsace-Moselle" alors ma cellule = 16,45% , si B1 = "PLUS DE 65 ANS" alors ma cellule = 12,55% et si B1 = "PLUS DE 65 ANS ALSACE-MOSELLE" ma cellule = 14,05%
Plus personne pour me répondre ??? svp c'est urgent je dois remettre le fichier demain ...
helppppppppppppppppppppp
Messages postés
514
Date d'inscription
lundi 9 mai 2011
Statut
Membre
Dernière intervention
17 avril 2013
86
C'est le même principe !
OK donc si j'ai bien compris je dois mettre =SI(OU(B1="MOINS DE 65 ANS";B1="MOINS DE 65 ANS ALSACE-MOSELLE;B1="PLUS DE 65 ANS";B1="PLUS DE 65 ANS ALSACE-MOSELLE");14;95%;16,65%;12,55%;14,05%) ????
Freedomsoul
Messages postés
514
Date d'inscription
lundi 9 mai 2011
Statut
Membre
Dernière intervention
17 avril 2013
86
Pas tout à fait

La syntaxe du SI est:

SI(CONDITION;SICONDITIONVRAI;SICONDITIONFAUX)

La syntaxe du OU est :

OU(CONDITION1;CONDITION2;CONDITION3;....)

Ici, tu as 4 conditions, donc tu imbriques

SI(CONDITION1;VALEUR; SINONCONDITION2;VALEURSIVRAI; SINONCONDTION3;VALEURSIVRAI; ....)

Toi, tu veux :
si B1 = "MOINS 65 ANS" alors ma cellule = 14,95%, si B1 = "moins de 65 ans Alsace-Moselle" alors ma cellule = 16,45% , si B1 = "PLUS DE 65 ANS" alors ma cellule = 12,55% et si B1 = "PLUS DE 65 ANS ALSACE-MOSELLE" ma cellule = 14,05%

Donc :

=SI(B1="MOINS 65 ANS";14,95;SI(B1="MOINS DE 65 ANS ALSACE-MOSELLE";16,65;SI(B1="PLUS DE 65 ANS";12,55;SI(B1="PLUS DE 65 ANS";12,55;SI(B1="PLUS DE 65 ANS ALSACE-MOSELLE";14,05;""))))

Au niveau du %, il faut modifier le format des cellules, sinon, ça va te calculer la valeur et non l'afficher.

Clique droit > Format Cellule > Onglet "Nombre" : "Pourcentage"


Ce que tu fais toi c'est :
(et il manque une quote)
=SI(OU(B1="MOINS DE 65 ANS";B1="MOINS DE 65 ANS ALSACE-MOSELLE";B1="PLUS DE 65 ANS";B1="PLUS DE 65 ANS ALSACE-MOSELLE");14;95%;16,65%;12,55%;14,05%)

ce que tu as fait la c'est " SI(B1 = X ou B1 = Y ou B1 = Z) ALORS 14,95% SINON 16,65%"
---
Merci tu es un champion !!!
Freedomsoul
Messages postés
514
Date d'inscription
lundi 9 mai 2011
Statut
Membre
Dernière intervention
17 avril 2013
86
Que tu comprennes bien le fonctionnement, c'est ça qui est important !