Menu

Egal une des valeurs d'une plage [Résolu/Fermé]

- - Dernière réponse :  Deejay - 11 avril 2019 à 11:35
Bonjour,

J'aimerais savoir si vous connaissez une formule du type "si la cellule est égale à l'une des valeurs de cette plage".

Exemple
A1 B1
A2
A3
.
.
.
A30

Je voudrais donc une formule qui permette de dire que si B1 est égal à l'une des valeurs de la plage A1;A30 alors le test est positif.

MERCI D'AVANCE !!
Afficher la suite 

6 réponses

Meilleure réponse
Messages postés
16868
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
21 février 2019
5089
11
Merci
Re,

Justement j'ai bien compris entre A1 et A30 tu as des valeurs, peu importe texte ou numérique, en B1 tu saisis une valeur et si cette valeur est présente dans la liste tu affiches "test est positif" sinon rien ou on ajoute une légende si tu veux

C'est bien la formule
=SI(NB.SI($A$1:$A$30;B1)>0;"test est positif";"")

si tu veux un exemple fais signe

Dire « Merci » 11

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 42084 internautes nous ont dit merci ce mois-ci

Messages postés
16868
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
21 février 2019
5089
1
Merci
Salut,

Regarde si c'est ce que tu cherches

=SI(NB.SI($A$1:$A$30;B1)>0;"test est positif";"")
Messages postés
316
Date d'inscription
mercredi 13 janvier 2010
Statut
Membre
Dernière intervention
5 janvier 2019
19
1
Merci
Bonjour

A essayer

=SI(ESTNA(RECHERCHEV(B1;A1:A3;1;FAUX));"Faux";"Vrai")

Iama
Iama
Messages postés
316
Date d'inscription
mercredi 13 janvier 2010
Statut
Membre
Dernière intervention
5 janvier 2019
19 -
Re
Formule à mettre dans un autre cellule (ex ColonneC)

Iama
0
Merci
Re,

Merci mais ça fonctionne pas.
En fait les cellules A1 jusqu'à A30 ont toutes une valeur propre (jamais 2X la même).
Et moi j'aimerais donner une valeur à B1 et vérifier si elle est égale à l'une de celles de la plage A1;A30.

Le tout sans avoir à taper une formule à rallonge style =SI(OU(B1=A1;B1=A2...) etc
Messages postés
16868
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
21 février 2019
5089
0
Merci
Re,

Voir l'exemple ci joint

http://cjoint.com/?0chnKVzNZdl
0
Merci
Super !
Ca marche !!!!!

Merci à tous les deux !