Menu

Excel-comparer une cellule avec un ensemble [Résolu/Fermé]

Messages postés
8
Date d'inscription
lundi 8 novembre 2010
Statut
Membre
Dernière intervention
10 novembre 2010
- - Dernière réponse : Flambi.wan
Messages postés
8
Date d'inscription
lundi 8 novembre 2010
Statut
Membre
Dernière intervention
10 novembre 2010
- 10 nov. 2010 à 08:43
Bonjour,
J'ai défini un ensemble en nommant une plage de texte
Je souhaiterais comparer une cellule (texte) avec chaque élément de mon ensemble, et afficher 1 si le contenu de ma cellule est dans la liste, sinon afficher 2. Quelqu'un saurait faire ça SVP?


Afficher la suite 

4 réponses

0
Merci
Bonjour

Pour cerner un peu mieux le problème :
La plage de texte comprend plusieurs colonnes ?
Le texte à rechercher peut-il apparaître plusieurs fois dans la zone de recherche ?
Messages postés
8
Date d'inscription
lundi 8 novembre 2010
Statut
Membre
Dernière intervention
10 novembre 2010
7
0
Merci
Merci du temps que vous m'accordez
La plage de texte est sur une seule colonne
Le texte à rechercher ne peut apparaître qu'une seule fois dans la zone de recherche
Messages postés
15834
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
24 mai 2019
2726
0
Merci
bonjour

la liste dans A1:A200
la valeur en B1
le résultat en C1
=SI(NB.SI(A1:A200;C1)=0;2;1)
si le mot cherché est mêlé avec d'autre mots dans la cellule
=SI(NB.SI(A1:A200;"* "&C1&" *")=0;2;1)
par ex on cherche "pas" dans "papoux papas à poux pas papas" renvoie 1 mais "papoux papas à poux papas" renvoie 2
Messages postés
8
Date d'inscription
lundi 8 novembre 2010
Statut
Membre
Dernière intervention
10 novembre 2010
7
0
Merci
Merci beaucoup de votre aide très appréciable. Je ne parvenais pas à trouver la solution avec le bouquin. Encore merci