Menu

Excel: Copie automatique contenu de cellules [Résolu/Fermé]

- - Dernière réponse :  Isabellemars - 8 juin 2018 à 17:47
Bonjour, j'aurais besoin de vos lumières pour savoir si ce que je cherche à faire est possible.

Dans un document excel, je fais en sorte que le contenu de certaines cellules soit rapporté automatiquement dans d'autres cellules (commande "=cellule que je veux copier", ex : "=B5"). Cependant, lorsque la cellule est vide, le chiffre 0 apparaît dans la nouvelle cellule. Peut-on éviter ça ? J'aimerais que lorsque la cellule d'origine est vide, la cellule cible apparaisse vide aussi, afin que la copie soit vraiment identique.

Suis-je claire dans mon questionnement ? Suis-je au bon endroit pour poser la question ? Si non, merci de m'indiquer, je suis une néophyte en ce qui concerne les blogues...

Merci infiniment.
Afficher la suite 

3 réponses

Meilleure réponse
Messages postés
12245
Date d'inscription
jeudi 15 mai 2008
Statut
Contributeur
Dernière intervention
30 novembre 2018
2781
6
Merci
Bonjour,
Avec la fonction SI : Si la cellule est vide alors la cellule de destination aussi:
=SI(B5="";"";B5)

Dire « Merci » 6

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 52350 internautes nous ont dit merci ce mois-ci

2
Merci
Bonjour,

Une astuce toute simple qui rejoint un peu celle de pijaku c'est de mettre ceci:

=SI(cellule à copier <>"";cellule à copier;"")

Si c'est la cellule A1 qu'il faut copier au cas où celle-ci est complétée, cela donne:

=SI(A1<>"";A1;"")

Cela évite en effet d'avoir des "0" qui s'affichent...

Bonne journée
0
Merci
Bonjour,

je viens de lire votre sujet qui m'aide à résoudre (en prtie) un petit soucis que j'ai avec Excel.

Admettons que l'on se trouve dans la configuration de Pijaku :

=SI(B5="";"";B5)


mais en apportans quelques modifs :

--> la formule est écrite dans la Feuille2, et les valeurs de cellules dans la feuille1.
Cela donne donc, dans la case Feuille2A1 :

=SI(Feuille1B5="";"";Feuille1B5)

Ma question est la suivante :

S'il y a quelque chose dans la cellule Feuille1B5, j'aimerai que cela me copie cette cellule, mais également celle d'à côté (par exemple Feuille1B6) dans une autre cellule choisie (par exemple Feuille2Q7)

Est ce que j'ai été assez simple ou cela vous aiderait d'avoir un petit exemple Excel?
pijaku
Messages postés
12245
Date d'inscription
jeudi 15 mai 2008
Statut
Contributeur
Dernière intervention
30 novembre 2018
2781 -
Salut Raclette,

En Feuille2Q7 écrire la formule :
=SI(Feuille1B5="";"";Feuille1B6)