Menu

Problème entre recherchev & format cellules [Fermé]

Pep56 11 Messages postés vendredi 20 mars 2009Date d'inscription 26 avril 2010 Dernière intervention - 15 mai 2009 à 14:33 - Dernière réponse : MoiExcel 7 Messages postés mardi 1 mars 2016Date d'inscription 4 mars 2016 Dernière intervention
- 4 mars 2016 à 10:12
Bonjour,

J'ai un problème avec la recherchev d'Excel, sur un tableau de 9000 lignes. Je dois effectuer une recherche pour compléter 2 colonnes (la recherche est basée sur la feuille 2), à partir d'un nombre. Le problème est que le résultat de cette recherche est le message d'erreur : #N/A.
En fait ma formule est bonne, le souci c'est que je suis obligé d'aller sur chaque cellule de la feuille 2, de rentrer dans la cellule et de taper entrée pour que la réponse apparaisse sur la feuille 1...vous comprenez que sur 9000 lignes cela est compliqué. Le format des cellules est "standard", j'ai essayé en passant tout en nombre ou en texte, mais rien n'y fait...

Merci de votre aide...
Afficher la suite 

11 réponses

eriiic 21599 Messages postés mardi 11 septembre 2007Date d'inscriptionContributeurStatut 21 mai 2018 Dernière intervention - 15 mai 2009 à 17:26
+15
Utile
Bonjour,

si ta colonne de recherche est le résultat d'une formule sélectionne la colonne et fais 'remplacer' = par =
Si c'est des nombres tente avec 'remplacer' 0 par 0, 1 par 1 jusqu'à être sûr que toutes les cellules aient au moins 1 de ces chiffres et aient été traitées.
Ca devrait forcer excel à ré-évaluer ces cellules.
eric
Cette réponse vous a-t-elle aidé ?  
Un GRAND merci ! Tu m'as aidé à trouver une solution à un problème sur lequel je galère depuis plus de 12h ! Merci
MoiExcel 7 Messages postés mardi 1 mars 2016Date d'inscription 4 mars 2016 Dernière intervention - 4 mars 2016 à 10:12
bonjour,

Tu me sauves la vie 7 ans après, merci :)
michel_m 15287 Messages postés lundi 12 septembre 2005Date d'inscriptionContributeurStatut 21 mai 2018 Dernière intervention - 15 mai 2009 à 15:48
+3
Utile
bin, si tu vois pas bien à quoi ce aidera... moi, je me demande ce que je fais sur ce post
ciao
+2
Utile
merci eric j'ai essayée de remplacer le 0 par 0 et 1 par 1 et ça fonctionne !
michel_m 15287 Messages postés lundi 12 septembre 2005Date d'inscriptionContributeurStatut 21 mai 2018 Dernière intervention - 15 mai 2009 à 14:41
+1
Utile
et si tu nous écrivais ta formule
et dans quelle colonne de quelle feuille tu veux le résultat
9000 lignes.... ==> VBA
Pep56 11 Messages postés vendredi 20 mars 2009Date d'inscription 26 avril 2010 Dernière intervention - 15 mai 2009 à 15:59
+1
Utile
eh bien bonne journée à toi ! le problème n'est pas sur la recherchev, je sais en faire, le problème est que le format des cellules est mauvais et qu'il faut rentrer dans chaque cellule, faire entree pour que ça marche... à bon entendeur...
+1
Utile
merci beaucoup Eric, ça a résolu mon problème. C'est étrange tout de même, cela doit être dû à un souci de format à la base nan ?
+1
Utile
Quelqu'un a la solution?
Perso c'est un problème de format et j'ai 1000 ligne à faire entrée donc si quelqu'un sait merci de répondre.

laetitia
Pep56 11 Messages postés vendredi 20 mars 2009Date d'inscription 26 avril 2010 Dernière intervention - 15 mai 2009 à 15:25
0
Utile
ma formule c'est "=RECHERCHEV(D2;Structure!$A$2:$N$1113;3;FAUX)" mais je vois pas bien en quoi ça aidera... Cette formule est sur la feuille 1 colonne B.
michel_m 15287 Messages postés lundi 12 septembre 2005Date d'inscriptionContributeurStatut 21 mai 2018 Dernière intervention - 15 mai 2009 à 16:15
0
Utile
...SALUT!
--