Signaler

"Impossible d'atteindre l'enregistrement spécifié"

Posez votre question Mélie - Dernière réponse le 14 nov. 2017 à 17:29 par yg_be
Bonjour,

Je sollicite votre aide car je rencontre un soucis dans Access auquel je n'arrive pas à remédier.

Mon problème est le suivant :
J'ai créé un formulaire auquel j'ai ajouté le bouton "nouvel enregistrement". Mais quand j'utilise celui-ci en mode formulaire, une fenêtre apparaît avec le message "impossible d'atteindre l'enregistrement spécifié". Je me suis rendue compte que c'est lorsque je lie mes tables d'une certaine manière que ce message apparaît. En effet, dans mes relations, deux relations de 1 à plusieurs partent d'un même attribut. Lorsque ces deux relations liées à un même attribut sont présentes, le message d'erreur apparaît lorsque j'utilise le bouton nouvel enregistrement. Je n'ai pas enlevé ces relations car elles montrent au mieux ce que je souhaite exprimer.

Connaîtriez-vous une solution pour que je puisse ajouter de nouveaux enregistrements, en gardant mes relations telles quelles, sans que je ne tombe à nouveau sur ce message ?

Merci d'avance et bonne journée :)


Utile
+0
plus moins
bonjour
peux tu mettre ta base compressée sur le site dans un lien comme cjoint ou smast pour mieux comprendre ton probleme.
Donnez votre avis
Utile
+0
plus moins
bonsoir, se pourrait-il que le formulaire soit construit sur une requête liant plusieurs tables? si oui, il est probable que la requête ne soit pas modifiable, tout simplement.
il suffit peut-être de modifier la définition de la requête, mais j'en doute.
Donnez votre avis
Utile
+0
plus moins
Bonjour,
Merci pour vos réponses :)

Je voulais mettre en évidence dans mon schéma, qu'un pédiatre peut traiter plusieurs enfants (patients) et qu'un enfant (patient) peut être traité par plusieurs pédiatres. Je voulais également montrer qu'un pédiatre peut travailler dans plusieurs hôpitaux et qu'un hôpital peut regrouper plusieurs pédiatres. J'ai donc deux relations plusieurs à plusieurs. Je les ai schématisées comme suit :

ENFANT table intermédiaire PEDIATRE
N°patient (relation 1 à pls) N°patient (relation 1 à pls) N°pédiatre
Nom N°pédiatre Nom

table intermédiaire HOPITAL
(relation de 1 à pls) N° pédiatre (relation 1 à pls)N°
N° hôpital NOM

Lorsque je crée un formulaire sur ce schéma avec tous les champs existants, les données s'affichent correctement. Cependant, lorsque je créée un bouton "nouvel enregistrement" et que je clique dessus en mode formulaire, le message "impossible d'atteindre l'enregistrement spécifié" apparaît.

Merci d'avance et bonne journée :)
Donnez votre avis
Utile
+0
plus moins
Je remets mon schéma ici, car tout s'est décalé dans la publication précédente:

table ENFANT
N°patient
Nom

(relation 1 à plusieurs)

table intermédiaire
N°patient
N°pédiatre

(relation 1 à plusieurs)

table PEDIATRE
N°pédiatre
Nom

(relation 1 à plusieurs)

table intermédiaire
N°pédiatre
N°hôpital

(relation 1 à plusieurs)
N° hôpital
Nom
yg_be 3778Messages postés lundi 9 juin 2008Date d'inscription ContributeurStatut 15 novembre 2017 Dernière intervention - 14 nov. 2017 à 17:29
je te suggère de prévoir des formulaires différents pour modifier le contenu de chacune des tables.
Répondre
Donnez votre avis
Utile
+0
plus moins
bonjour
on ne va reprendre toute ta base et refaire les relation.
METS TON TRAVAIL SUR LE SITE DANS UN LIEN
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !