Signaler

Somme d'items d'une colonne en fonction d'un critère d'une autre [Résolu]

Posez votre question HugoBR - Dernière réponse le 13 sept. 2017 à 19:16 par Vaucluse
Bonjour à tous,

Après recherche, je ne trouve pas de solutions précises à mon souci (je dois forcément m'y prendre mal, le probleme est simple).

Je vous explique mon problème :
Colonne A : nom des clients
Colonne B : heures passées par client

Donc j'ai :
A1 Client1 B1 1.5
A2 Client2 B2 2.5
A3 Client2 B3 1.5
A4 Client3 B4 2
A5 Client1 B5 1
A6 Client3 B6 3
etc...
Existe-t-il une formule qui me permettrait de faire apparaitre dans un tableau la somme des heures passées pour chaque client différent ?
Mon idée est la suivante, mais je ne sais pas comment la traduire en "langage excel" :
Si dans colonne A = Client1 alors regarder dans colonne B correspondante le nombre d'heures, faire cela pour toute la colonne A et afficher la somme de toutes ces heures.

Si quelqu'un peut me donner un coup de main c'est cool ! Merci d'avance !
Utile
+0
plus moins
Bonjour

avec le nom du client en C1

=SOMME.SI(A:A;C1;B:B)

à tirer sur la hauteur de la liste de client établie en C

si le total dépasse 24 h il faut formater les cellules résultat en:
format de cellule / personnalisé
et type:
[hh]:mm:ss
avec le HH entre crochets

crdlmnt





Donnez votre avis
Utile
+0
plus moins
Bonjour,

Utiles la fonction somme.si(plage;critere;plage somme)

=somme.si(a:a="client 1";b:b) ou

=somme.si(a1:a6="client 1";b1:b6)

Cdlmnt
Vaucluse 20343Messages postés lundi 23 juillet 2007Date d'inscription ContributeurStatut 22 septembre 2017 Dernière intervention - 13 sept. 2017 à 18:24
Salut djidji
petite coquille, le code SOMME.SI ne fonctionne pas avec le signe =
crdlmnt
Répondre
DjiDji59430 1653Messages postés samedi 19 avril 2008Date d'inscription 17 septembre 2017 Dernière intervention - 13 sept. 2017 à 18:48
Bonjour Vaucluse

hé oui ! , l"age, la fatigue, et surtout l'habitude du SI...

merci
Répondre
Donnez votre avis
Utile
+0
plus moins
Bonjour HugoBR

Essayer ceci


=SOMME.SI(A1:A6;E1;B1:B6)

E1 = nom du client
Donnez votre avis
Utile
+0
plus moins
Bonjour à tous et merci de vos réponses.
En suivant vos indications avec SOMME.SI, avec la colonne de liste des clients en plage; le nom du client en critère; la colonne des heures par client en [somme_plage], le résultat qui m'est renvoyé est toujours zéro.

Où ai-je pêché ? Dois je faire une manip précise ?

Merci d'avance à tous !
HugoBR- 13 sept. 2017 à 19:14
Pardon, je viens de trouver mon erreur.
Il convenait de mettre mon critère en guillemets, tout simplement.

Merci à tous
Répondre
Vaucluse 20343Messages postés lundi 23 juillet 2007Date d'inscription ContributeurStatut 22 septembre 2017 Dernière intervention - 13 sept. 2017 à 19:16
si vous avez écrit la, formule correctement, et si bien sur les critères existent ainsi que les montants, elle devrait fonctionner!
pouvez vous la coller ici qu'on voit à quoi elle ressemble?
et avez vous bien formaté la cellule résultat comme proposé?
si problème déposez un modèle de vos données (en bidonnant les infos confidentielles, sur:
http://mon-partage.fr
et revenez ici coller le lien créé sur le site
à vous lire
Répondre
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !