Formule complexe [Résolu]

Nikywil 12 Messages postés mercredi 12 avril 2017Date d'inscription 27 mai 2017 Dernière intervention - 14 avril 2017 à 20:54 - Dernière réponse : Nikywil 12 Messages postés mercredi 12 avril 2017Date d'inscription 27 mai 2017 Dernière intervention
- 17 avril 2017 à 17:38
Bonjour à tous, J'ai besoin de votre aide svp. Je dois intégrer cette formule sur excel mais je n'y arrive vraiment pas. Je souhaite que la cellule A1 :
 soit égal à 1 si le contenu est entre 0 et 4,
 soit égal à 2 si le contenu est entre 5 et 10,
 soit égal à 3 si le contenu est entre 11 et 15
 soit égal à 4 si le contenu est entre 16 et 20.
Merci beaucoupe pour votre aide bien précieuse car je suis bien embêtée.
Afficher la suite 

11 réponses

Répondre au sujet
madmyke 35680 Messages postés lundi 21 janvier 2008Date d'inscriptionModérateurStatut 13 décembre 2017 Dernière intervention - 14 avril 2017 à 21:22
0
Utile
1
Bonjour

Merci de consulter la charte de ce forum concernant les devoirs.

bav
Nikywil 12 Messages postés mercredi 12 avril 2017Date d'inscription 27 mai 2017 Dernière intervention - 15 avril 2017 à 20:26
Bonjour,
Il ne s'agit pas d'un devoir, je suis une salariée donc ma démarche est professionnelle.
Merci
Commenter la réponse de madmyke
ccm81 8204 Messages postés lundi 18 octobre 2010Date d'inscription 12 décembre 2017 Dernière intervention - 15 avril 2017 à 10:57
0
Utile
4
Bonjour

Formule à compléter (attention au nombre de parenthèses fermées à la fin)
=SI(A2<5;1;SI(A2<11;2; ...... ))

Cdlmnt
Nikywil 12 Messages postés mercredi 12 avril 2017Date d'inscription 27 mai 2017 Dernière intervention - 15 avril 2017 à 20:27
Bonjour,
Merci beaucoup pour ta réponse, mais lorsque je tape la formule ci-dessous, dans la cellule dans laquelle doit apparaître 1 ou 2 ...., apparaît "FAUX". Donc je suis toujours coincée.
=SI(A4<5;1;SI(A4<11;2;SI(A4<16;3;SI(A4<21;4))))
ccm81 8204 Messages postés lundi 18 octobre 2010Date d'inscription 12 décembre 2017 Dernière intervention > Nikywil 12 Messages postés mercredi 12 avril 2017Date d'inscription 27 mai 2017 Dernière intervention - 15 avril 2017 à 21:43
Ta formule marche bien
1. As tu des valeurs numériques en A4 ?
2. Le cas A4 >= 21, n'est pas traité, pour le traiter, il faut compléter
=SI(A4<5;1;SI(A4<11;2;SI(A4<16;3;SI(A4<21;4;"A4>=21"))))

3. Tu peux aussi utiliser la formule proposée par gbinforme que je salue au passage.

Cdlmnt
Nikywil 12 Messages postés mercredi 12 avril 2017Date d'inscription 27 mai 2017 Dernière intervention > ccm81 8204 Messages postés lundi 18 octobre 2010Date d'inscription 12 décembre 2017 Dernière intervention - 17 avril 2017 à 17:36
Bonjour,
Ca fonctionne. Merci beaucoup pour ta précieuse contribution.
A bientôt
Raymond PENTIER 44530 Messages postés lundi 13 août 2007Date d'inscriptionContributeurStatut 13 décembre 2017 Dernière intervention > Nikywil 12 Messages postés mercredi 12 avril 2017Date d'inscription 27 mai 2017 Dernière intervention - 16 avril 2017 à 04:56
Ou encore =SI(A4<5;1;SI(A4<11;2;SI(A4<16;3;4)))
Commenter la réponse de ccm81
gbinforme 14416 Messages postés lundi 18 octobre 2004Date d'inscriptionContributeurStatut 13 décembre 2017 Dernière intervention - Modifié par gbinforme le 15/04/2017 à 21:28
0
Utile
1
Bonjour,

Je te propose une formule facilement modifiable pour rajouter des tranches ou valeurs différentes :
=CHOISIR(EQUIV(A1;{0;5;11;16};1);1;2;3;4)

{0;5;11;16}
les seuils inférieurs
1;2;3;4
les valeurs résultat correspondantes
 Toujours zen
La perfection est atteinte, non pas lorsqu'il n'y a plus rien à ajouter, mais lorsqu'il n'y a plus rien à retirer.  Antoine de Saint-Exupéry
Nikywil 12 Messages postés mercredi 12 avril 2017Date d'inscription 27 mai 2017 Dernière intervention - 17 avril 2017 à 17:37
Bonjour,
Je te remercie pour ton aide. Ca marche et je suis soulagée.
Merci encore
Commenter la réponse de gbinforme
michel_m 14941 Messages postés lundi 12 septembre 2005Date d'inscriptionContributeurStatut 13 décembre 2017 Dernière intervention - 16 avril 2017 à 09:23
0
Utile
1
Bonjour tt le monde

encore une autre possibilité en tenant compte de l'état de A1
=SI(ET(A1<>"";A1>=0;A1<=20);EQUIV(A1;{0;5;11;16};1);"")
Nikywil 12 Messages postés mercredi 12 avril 2017Date d'inscription 27 mai 2017 Dernière intervention - 17 avril 2017 à 17:38
Bonjour,
Merci beaucoup pour ton aide, c'est magique quand ça fonctionne. Merci encore.
Commenter la réponse de michel_m