Signaler

Conversion de texte csv en nombre

Posez votre question depadou_2000 11Messages postés mercredi 17 février 2016Date d'inscription 14 février 2017 Dernière intervention - Dernière réponse le 20 oct. 2016 à 13:37 par tontong
Excel 2016,

Je prends une copie de mon état de compte fournie par ma banque et je désire faire des calculs.

Voici ce que je reçois à titre d'exemple :
300,00 $
1 182,29 $

Le 300,00 $ est interprété comme un nombre sans un seul problème.
Le 1 182,29 $ est interprété comme du texte.

J'ai utilisé la fonction :
{ =VALEURNOMBRE() }
mais ça ne fonctionne pas.

Si je retire manuellement l'espace qui sépare les milliers comme : 1182,29 $, Excel l'interprète comme un nombre.

Comment puis-je retirer cet espace des milliers ?
J'ai essayé la fonction :
{ =SUPPRESPACE() }
mais ça ne fonctionne pas non plus.

Que faire ?


Afficher la suite 
Utile
+0
plus moins
Bonjour,

Une bidouille :
Tu selectionnes ta colonne de chiffres, puis remplacer

espace $
par
rien

Crdmt
depadou_2000 11Messages postés mercredi 17 février 2016Date d'inscription 14 février 2017 Dernière intervention - 19 oct. 2016 à 19:42
J'ai essayé mais ça ne fonctionne pas.

Il y a surement un format caché dans le transfert de la Banque.

Je voulais joindre mon exemple mais c'est illégal dans ce forum. Que puis-je faire?
Répondre
DjiDji59430 1497Messages postés samedi 19 avril 2008Date d'inscription 25 avril 2017 Dernière intervention - 20 oct. 2016 à 00:26
J'ai pris tes 2 exemples que j'ai collés dans un fichier, et la manip proposée fonctionne
Non, tu peux joindre ton fichier, anonymisé ou pas
Tu vas sur

1) Tu vas dans http://cjoint.com/
2) Tu cliques sur [Parcourir] pour sélectionner ton fichier
3) Tu descends en bas de la page pour cliquer sur [Créer le lien Cjoint]
4) Au bout de quelques secondes s'affiche le lien en bleu souligné ; tu le sélectionnes et tu fais "Copier"
5) Tu reviens dans la discussion, et, dans ton message de réponse, tu fais : "Coller".

Cordialement.
Répondre
Donnez votre avis
Utile
+0
plus moins
Bonjour,

Peut-être que ton espace n'en est pas un.
C'est peut-être un code ascii 160 .
Un fichier exemple aurait permis de te répondre précisément.

Cordialement
Donnez votre avis
Utile
+0
plus moins
Bonjour,
À tester:
Mettre les cellules au format Standard.
Éliminer les" $": Ctrl+H >> dans la zone Rechercher " $" obtenu avec un Copier/coller depuis la barre de formule. Dans la zone Remplacer par: ne rien mettre >> clic sur remplacer ou remplacer tout (si les cellules sont bien sélectionnées)
Éliminer les séparateurs de milliers: dans la zone Rechercher " l'espace " obtenu avec un Copier/coller depuis la barre de formule. Dans la zone Remplacer par: ne rien mettre >> clic sur remplacer ou remplacer tout (si les cellules sont bien sélectionnées).
Le copier/coller évite les recherches pour savoir si l'espace est un Car(160) ou un Car(32). Si on est sûr du code 160 on peut aussi taper Alt+0160 dans la zone Rechercher.
Il reste à mettre la colonne au format monétaire Français ( Canada) pour avoir $ à droite.
Des simplifications sont certainement possibles avec le fichier réel.
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !