Signaler

Fonction si et fonction nbval [Résolu]

Posez votre question ec163 136Messages postés jeudi 22 août 2013Date d'inscription 15 septembre 2016 Dernière intervention - Dernière réponse le 15 sept. 2016 à 15:01
Bonjour,
je souhaiterais savoir comment ne pas tenir compte dans la fonction NBVAL des cellules contenant la formule Si(feuil1="";"";"quelquechose). Pour dire ça autrement je fais un report des infos de la colonne A de la feuille 1 sur la colonne A de la feuille 2, si dans la colonne A de la feuille 1 des cellules ne sont pas renseignées en feuille 2 il n'y aura rien ce qui est exact,
Le souci c'est que je dois faire le total de tout ce qui apparaît dans la colonne et la fonction NBVAL comptabilise aussi les cellules vides puisqu'il y a la formule SI. Bref connaissez vous un moyen de contourner ce problème, par avance mercide vos réponses.
ec163
Afficher la suite 
Utile
+0
moins plus
Bonjour

pour champ de A1à A100:

=SOMMEPROD((A1:A100<>"")*1)

crdlmnt
Ajouter un commentaire
Utile
+0
moins plus
Bonjour le fil,

Si tu veux compter le nombre de cellules renseignées tu as la formule de l'ami Vaucluse que je salue, mais pour faire le total des sommes de la colonne tu as
=SOMME(A2:A100)
ou encore
=SOMME.SI(A2:A100;"<>""")
ou
=SOMME.SI.ENS(A2:A100;A2:A100;"<>""")
Ajouter un commentaire

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !