Liste excel avec nom en double/triple [Fermé]

louis - 17 mai 2012 à 04:29 - Dernière réponse : Dr Zero 1050 Messages postés samedi 29 mai 2010Date d'inscription 3 décembre 2017 Dernière intervention
- 21 mai 2012 à 21:01
Bonjour,

Voici mon probleme.

J'ai une (tres grosse) liste avec plusieurs colonnes (ce qui suis est juste un exemple): noms de clients (Mr A, B, C, D,..), produits (voiture, tasse, sac, chaussure, date d'achat, adresse e-mail.....
Ce que je sohaite faire c'est voir le nom d'adress e-mail que je possede pour les clients qui possedent une voiture.

Mon probleme: Il y a plusieurs fois les meme nom dans la liste (Mr Charles Apret, Mr Louis Azon, Mr Louis Azon, Mr Silvain Bertout,...), mais aussi plussieurs clients avec le meme nom de famille..... (Mr Silvain Bertout, Mr Louis Bertout,...)(et forcement aussi des clients avec des noms de famille differents mais le meme prenom...)

Comment puis-je "automatiquement" masquer/effacer les profiles en double (je suis donc obliger de me referrer a la fois au nom de famille mais aussi prenom je suppose pour evite de supprimer des clients qui on le meme nom de famille mais pas le meme prenom...)

Merci beaucoup pour votre aide


Afficher la suite 

8 réponses

Raymond PENTIER 44569 Messages postés lundi 13 août 2007Date d'inscriptionContributeurStatut 16 décembre 2017 Dernière intervention - 17 mai 2012 à 05:13
+1
Utile
Pour commencer, tu fais deux colonnes, une pour le nom et une pour le prénom.
Cette réponse vous a-t-elle aidé ?  
michel_m 14942 Messages postés lundi 12 septembre 2005Date d'inscriptionContributeurStatut 14 décembre 2017 Dernière intervention - 17 mai 2012 à 07:58
+1
Utile
Bonjour,

Il y a un défaut dans la conception de ta liste nominative (tu peux aussi avoir plusieurs clients qui ont le m^me nom et prénom): il faudrait que tu puisses attribuer un identifiant unique à chaque client (nombre de préférence)ou au moins une concaténation nom - prénom et avec un distinguo si doublon nom-prénom (2° prénom ?).
D'ailleurs, dans la vie courante, on nous demande toujours notre identifiant (sécu, impôts, banque....) c'est casse-pieds, je suis d'accord!

autrement tu auras beaucoup de problèmes pour utiliser ta base de données.
Cette réponse vous a-t-elle aidé ?  
Double SBA 301 Messages postés vendredi 26 mars 2010Date d'inscription 2 janvier 2016 Dernière intervention - 17 mai 2012 à 04:30
0
Utile
Salut

Tu vas dans "Données" et tu choisis "Supprimer les doublons"
0
Utile
Bonjour,

Oui en fait le nom et prenom sont deja separee en deux colonnes (chaque info a sa propre colonne)
Vaucluse 20874 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 16 décembre 2017 Dernière intervention - 17 mai 2012 à 08:14
0
Utile
Bonjour

le plus simple pour éliminer les doubles semble être de créer une colonne supplémentaire pour concatener nom et prénom et travailler sur cette colonne pour détecter les doublons:
colonne A les noms
colonne B les prénoms
colonne X par exemple, la formule:
=A1&B1
et dans cette colonne , une MFC pour identifier les doublons:
saisir le champ, mise en forme conditionnelle, la formule est:
=NB.SI(X:X;X1)>1
bonne chance

vous pouvez aussi numéroter les doublons en X si vous les souhaitez, si votre tableau commence en ligne 2:

en X2, complèter la formule avec:

=A1&B1&"_"&NB.SI($X$1:X1;A1&B1)
qui vous donnera derrière le underscore le nombre de valeurs identiques situées au niveau de la ligne dans la colonne X

enfin:

vous pouvez identifier directement les doublons dans les colonnes AB avec une MFC et cette formule qui va pour l'exemple de ligne 2 à ligne 100:
sélectionnez A2:B100
MFC par formule
la formule est:
=SOMMEPROD(($A$2:$A$100&$B$2:$B$10=$A2&$B2)*1)>1
mettez les signes $ aux bons endroits
formatez par exemple en rouge.
les doublons apparaîtront en rouge, format qui disparaîtra lorsqu'il n'y aura plus qu'un exemplaire de l'ensemble nom prénom.


crdmnt

0
Utile
1
Bonjour ,

merci je ne suis absolument pas une expert en Excel mais je vais faire ce que je peux.

merci
Vaucluse 20874 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 16 décembre 2017 Dernière intervention - 17 mai 2012 à 11:17
Pas de problème, Louis et n'hésitez pas à revenir si souci.
et vous verrez, plus on fait ce qu'on peut et plus on peut.
bonne route
Dr Zero 1050 Messages postés samedi 29 mai 2010Date d'inscription 3 décembre 2017 Dernière intervention - 21 mai 2012 à 21:01
0
Utile
Bonjour

Vous n'avez pas précisé la version de votre Excel.
si vous travaillez sous office 2007 alors c'est facile :
Il vous faudra 3 critères unique pour chaque client :
Nom : mais on peut avoir le m^me Nom pour plusieurs personnes
Prénom : Le problème si on peut avoir plusieurs personnes avec le m^me prénom, on peut avoir des client qui ont un m^me prénom mais aussi le même Nom rarement mais il existe.
3ème Critère : Il faut trouver un 3ème critère qui peut résoudre ces cas Exp Nom Rue, (avoir deux client qui ont le m^me Nom et le même prénom c'est dan le probable mais qu'il habitent la m^me rue, il faut vraiment manqué de chance) dans ce cas on peut prendre un 4ème critère et ainsi de suite.

Maintenant qu'on a choisi nos critère :
1/ clic dans votre tableau qui ne doit contenir ni ligne ni colonne vide.
2/ Clic sur Menu Données --> puis Supprimer Doublons
3/ Dans la fenêtre qui apparait vous avez toutes les entêtes de colonne. Alors ne laissez coché que les critères que vous avez choisis.
4/ Laissez bien coché Mon tableau à des entête si vous en avez (ce que je pense)
5/ Maintenant cliquez sur Ok et il vous dirra le nombre de lignes supprimer.

Un bon conseil : Travaillez sur une copie de votre tableau.

A+