Somme Si, 2 cases sur 3 remplissent une condition [Résolu]

Signaler
-
Messages postés
25007
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2020
-
Bonjour à tous,

Je souhaiterais faire la somme de 3 cases si 2 de ces 3 cases remplissent une condition.
Mon objectif c'est de pouvoir étendre ma formule sur un nombre important de case : par exemple, faire la somme de 50 cases si 43 de ces cases remplissent une condition.

J'ai fait un truc absolument dégueulasse et qui n'est pas du tout scalable.
Est-ce que vous connaîtriez une formule qui permet de faire ça ?


Configuration: Windows / Chrome 80.0.3987.149

6 réponses

Messages postés
1937
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
8 avril 2020
632
Bonjour
sans exemple, voir les fonctions SOMME.SI ou SOMMEPROD
Merci pour les pistes :)
J'ai donné un peu plus d'info dans un commentaire, j'ai essayé SOMME.SI mais ça ne me paraît pas idéal.
Et SOMMEPROD je ne vois pas comment l'utiliser dans ce cas là
Messages postés
25007
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2020
5 150
Bonjour
=SOMME.SI(champ des conditions;conditions;champ à sommer)
si vous voulez plus précis, déposez un modèle avec quelques explications sur les attendus ici:
http://mon-partage.fr
et revenez coller le lien créé sur le site
à vous lire
crdlmnt
Merci pour les pistes !
J'ai essayé d'apporter plus de précision dans le commentaire suivant
Oui pardon ça sera plus simple avec un exemple !
Voici mon doc :
https://docs.google.com/spreadsheets/d/1c21v7jyc4UebIZFEBDDMrvoBJJHH_OlOgWYrxvqhvy4/edit?usp=sharing

avec le lien de partage :
https://mon-partage.fr/f/dC21XQq1/

L'idée c'est d'avoir :
- dans la colonne E : la somme des 4 premières colonnes si les 4 sont remplies
- dans la colonne F : la somme des 4 premières colonnes si 3 sont remplies
- dans la colonne G : la somme des 4 premières colonnes si 2 sont remplies
- dans la colonne H : la somme des 4 premières colonnes si 1 seule est remplie

J'ai essayé avec SOMME.SI, comme vous pouvez le voir, mais c'est assez moche comme résultat --'
Messages postés
25007
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2020
5 150
Re
je ne comprend pas la colonne F ou vous faites la somme seulement de A à C . je suppose que le +100 fait partie de vos conditions
en régle générale s'il s'agit de sélectionner la colonne de cumul selon le nombre de résultat en A,B,C,D, il suffit de compter en 1° condition le nombre de résultats dans la ligne:
en E
=SI(NB.SI(A2:D2;"<>")=4;SOMME(A2:D2);"")
et la même formule avec
=3 en F
= 2 en G
=1 en H
cette option fait la somme sous condition quelquesoit la position de la valeur en A,B,C ou D
revenez avec complément d'explications si ça ne convient pas
crdlmnt
Hop j'ai fini par trouver !

J'ai fait une première colonne avec la formule NBVAL qui me dit combien de case sont remplies et ensuite j'ai pu faire une formule SI en fonction de la valeur renvoyé par NBVAL

Bonne journée !
Messages postés
25007
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2020
5 150
si ça fonctionne, OK, mais avec NB.SI vous auriez pu économiser une colonne et éviter d'empiler des conditions!
mais c'est vous qui voyez!
si vous avez terminé, merci de passer le sujet en résolu en cliquant sur le bouton vert en dessous de votre premier message
bonne route
crdlmnt