Formule pour avoir le montant restant dû [Résolu]

Signaler
-
 LinTahiti -
Bonjour,

SVP je souhaiterai composer une formule qui me calculerai le montant restant dû en fonction du critère "oui" ou "non"

En D3 j'ai le montant total de l'échéance
EN I3 j'ai le montant de l'échéance 1
En K3 j'ai composé une formule qui m'affiche "oui" ou "non"

SVP pouvez-vous m'aider

Merci d'avance et très belle journée!

7 réponses

Messages postés
17113
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
7 avril 2020
3 934
Bonjour,

Pas très clair comme demande, essaye comme cela d'après ma compréhension
=SI(K3="oui";D3-I3;"")

si le calcul doit se faire si non est en K3
=SI(K3="non";D3-I3;"")
Bonjour bonjour à tous,

Sincèrement merci merci les deux formules que vous m'avez proposé fonctionnent ceux de Mike-31 et de Raymond PENTIER
Messages postés
61
Date d'inscription
mercredi 23 avril 2008
Statut
Membre
Dernière intervention
7 avril 2020
11
Bonjour
Il faut utiliser la formule
=SOMME.SI(F1:F18;"OUI";E1:E18)
f1:f18 etant les cellules contenant les "OUI"
e1:e18 étant les cellules à additionner...
A+ François
Messages postés
51480
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
7 avril 2020
12 644
Bonjour Lin Tahiti.

Ta question est très incomplète. On peut l'interpréter comme on veut.
Ainsi, en plus des 3 hypothèses précédentes, moi j'ai cru comprendre qu'on affiche la différence si c'est OUI en K3, et on conserve le total si c'est NON :
=SI(K3="oui";D3-I3;D3)

On attend tes explications complémentaires ...
Svp comment je peux joindre mon fichier excel pour que ma demande soit plus explicite pour tout le monde
Messages postés
17113
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
7 avril 2020
3 934
Re,

Alors je passe le statut de la discussion en résolu bien qu'avec tes explications ce n'était pas évidant
Bonjour,

Euhh finalement, la formule ne fonctionne pas lorsque j'imbrique les deux formules, comme suit: =SI(K3="oui";D3-I3;"";SI(K3="non";D3-I3;""))

j'ai un message d'erreur m'informant que j'ai entré un nombre trop important d'argument pour cette fonction

Comment puis-je intégrer mon fichier excel svp? pour que la compréhension soit la meilleure possible
Messages postés
17113
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
7 avril 2020
3 934
Re,

pourquoi veux tu imbriquer les deux formules qui sont contraire et font la même chose que K3 contienne oui ou non le résultat est le même ce qui est illogique
il faut traiter oui ou non à ton choix.
si par exemple K3 contient oui et si tu attends D3-I3
il suffit d'écrire
=SI(K3="oui";D3-I3;"")
et c'est tout parce qu'automatiquement si tu écris non la formule te retourne rien

par contre si toi tu veux qu'Excel fasse D3-I3 lorsque K3 contient non alors et uniquement dans ce cas tu écris
=SI(K3="non";D3-I3;"")

donc c'est l'une ou l'autre mais pas les deux formules imbriquées
https://www.cjoint.com/c/JCswdp3Hu8T
Mike-31
Messages postés
17113
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
7 avril 2020
3 934 > LinTahiti
Re,

En E3 ta formule est incomplète, tu as la condition =SI(I:I="OUI"
puis la condition vrai ;D:D-G:G
mais après il manque la condition faux

=SI(I:I="OUI";D:D-G:G;"")

ensuite ta demande était incomplète parce que tu veux apparemment soustraire plusieurs valeurs qui répondent au critère "oui"
en E3 colle cette formule

=D3-(SI(I3="oui";G3;0)+SI(M3="oui";K3;0)+SI(Q3="oui";O3;0)+SI(U3="oui";S3;0))
Mike-31
Messages postés
17113
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
7 avril 2020
3 934 > Mike-31
Messages postés
17113
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
7 avril 2020

si c'est ce que tu attends tu as également SOMMEPROD mais reste basique

=D3-SOMMEPROD((I3="oui")*(G3)+(M3="oui")*(K3)+(Q3="oui")*(O3)+(U3="oui")*(S3))
> Mike-31
Messages postés
17113
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
7 avril 2020

Re,

Tu es le PRO des formules excel. ça fonctionne à merveille!

Merci sincèrement et désolé si ma 1er question n'a pas été claire. ;)

Encore merci, je vous souhaite du soleil bien chaud de Tahiti
Messages postés
17113
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
7 avril 2020
3 934
Re,

pour joindre ton fichier
1) Tu vas dans https://www.cjoint.com/
2) Tu cliques sur [Parcourir] pour sélectionner ton fichier (15 Mo maxi)
3) Tu défiles vers le bas pour cliquer sur le bouton bleu [Créer le lien Cjoint]
4) Au bout de quelques secondes la deuxième page s'affiche, avec le lien en gras ; tu fais un clic-droit dessus et tu choisis "Copier le lien"
5) Tu reviens dans ta discussion sur CCM, et dans ton message tu fais "Coller".
=>Voir la fiche https://www.commentcamarche.net/faq/29493-utiliser-cjoint-pour-heberger-des-fichiers

dans le même style tu as https://mon-partage.fr/