Formule a plusieur critere

Signaler
-
PapyLuc51
Messages postés
2467
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
31 mars 2020
-
Bonjour,


j'ai un fichier planning ou je calcule les weekend travaillée avec cette formule :

=(SI(JOURSEM(D6;2)=7;OU(ET(NB.SI(D7;"*");NB.SI(C7;"*"));ET(NB.SI(D7;"*");NB.SI(E7;"*"));ET(NB.SI(B7;"N");NB.SI(E7;"*")));""))

celle ci fonctionne parfaitement mais je souhaiterai l'ameliorer : a la place du critere "*" je voudrai : "J" ou "N" ou "F"
j'ai essayé avec la formule (NB.SI(D7;OU("J" ; "N" ; "F"))) ou mais sa marche pas

auriez vous une solution ?

Merci

4 réponses

Messages postés
8075
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
31 mars 2020
1 352
Bonjour,

Tes explications sont trop vagues, très insuffisantes.
Ta formule fait référence à 4 cellules, pour D6 c'est ok mais il faudrait que tu expliques clairement et en détail pour tous les cas ce que doivent contenir C7, D7 et E7 et les cas refusés.

Messages postés
2467
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
31 mars 2020
572
Bonjour,

Une proposition

=OU(NB.SI(D7;"J");NB.SI(D7;"N");NB.SI(D7;"F"))

Cordialement
j'ai fini par trouver :

=SI(JOURSEM(D6;2)=7;OU(ET(OU(NB.SI(D7;"J");NB.SI(D7;"N");NB.SI(D7;"F"));OU(NB.SI(C7;"J");NB.SI(C7;"N");NB.SI(C7;"F")));ET(OU(NB.SI(D7;"J");NB.SI(D7;"N");NB.SI(D7;"F"));OU(NB.SI(E7;"J");NB.SI(E7;"N");NB.SI(E7;"F")));ET(NB.SI(B7;"N");OU(NB.SI(E7;"J");NB.SI(E7;"N");NB.SI(E7;"F"))));""))

en faite je peux travaillé les weekend de nuit ou de jour ou en formation
je cherche a savoir le nombre de weekend travaille : soit le samedi dimanche jour ou nuit ou formation, soit le dimanche lundi jour ou nuit ou formation. ou encore si le vendredi est travaillée de nuit et le lundi jour ou nuit ou formation

papyluc51 j'en suis arriver au même résultat
merci pour vos réponses
Patrice33740
Messages postés
8075
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
31 mars 2020
1 352
Re,

Il serait plus simple d'écrire :
=SI(JOURSEM(D6;2)=7;OU(ET(OU(D7="J";D7="N";D7="F");OU(C7="J";C7="N";C7="F"));ET(OU(D7="J";D7="N";D7="F");OU(E7="J";E7="N";E7="F"));ET(B7="N";OU(E7="J";E7="N";E7="F")));"")

Qu'on peut simplifier :
=SI(JOURSEM(D6;2)=7;OU(ET(OU(D7="J";D7="N";D7="F");OU(OU(C7="J";C7="N";C7="F");OU(E7="J";E7="N";E7="F")));ET(B7="N";OU(E7="J";E7="N";E7="F")));"")
Messages postés
2467
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
31 mars 2020
572
Bonjour Yannick

Tu parles de weekend travaillé alors que ta formule ne concerne que le dimanche ; il y a un hic et Patrice33740 (salutations) avait raison dans sa première réponse.

Peux-tu envoyer une copie de ton fichier pour en voir la structure ; Copie sans données confidentielles sur laquelle tu mettras quelques exemples avec les explications détaillées. Fais créer un lien de partage sur l'un des sites ci-dessous ; lien à copier et à coller dans la réponse.

https://www.cjoint.com/

https://mon-partage.fr/

Cordialement