Analyse d’intervalles de dates [Résolu]

Signaler
-
Elodiiie08
Messages postés
3
Date d'inscription
dimanche 2 février 2020
Statut
Membre
Dernière intervention
2 février 2020
-
Bonjour,

Je me permets de solliciter de l’aide car je dois extraire de donnés Excel le nombre de personnes présentes pour chaque mois de l’année pour chaque entraîneur.

J’ai comme informations de base: la date d’arrivée et de départ de chaque personne ainsi que le nom de l’entraîneur qui lui ai affecté. L’objectif étant de connaître le nombre de personne suivie par chaque entraîneur et ce pour tous les mois de l’année.

Je ne sais pas quelle formule mettre en place sur Excel pour réaliser cela?

Je vous remercie par avance pour votre aide,

Bon dimanche.



Configuration: iPhone / Safari 13.0.4

4 réponses

Messages postés
24897
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 février 2020
5 042
Bonjour
sans vos données, c'est un peu au hasard
exemple à adapter
base de données en feuil1
  • en A2:A100: les dates
  • en B2:B100 le nom des entraîneurs
  • en C le noms des personnes (mais il 'entre à priori pas en ligne de compte)

feuille d'édition en feuile 2
de A2 à A12, les n° de mois de l'année de 1 à 12
de B1 à Bxx le nom des entraîneurs
la formule en B2
=SOMMEPROD(MOIS($A$2:;$A$100)=$A2)*(feuil1!$B$2:$B100=B$1))
à tirer sur tout le tableau, en respectant( bien les positis des signes $

vous pouvez remplacer dans cette feuille la liste en A2:A12 par les dates du 1° jour de chaque mois dans une cellule formatée en personnalisé > mmmm
(ça fait plus joli)
la formule devient alors:
=SOMMEPROD(MOIS($A$2:;$A$100)=MOIS($A2))*(feuil!$B$2:$B100=B$1))
csi problème avec ça, déposez un modèle de vos données ici:
http://mon-partage.fr
et revenez coller le lien créé sur le site
crdlmnt


Messages postés
3
Date d'inscription
dimanche 2 février 2020
Statut
Membre
Dernière intervention
2 février 2020

Je vous remercie pour votre réponse.

J’ai une petite question car les dates pour chaque personne sont par exemple:
Entrée: 01/02/2019
Sortie: 20/04/2019
Je dois donc savoir pour chaque entraîneur combien ils ont eu de personnes à gérer sur tous les mois de l’année (individuellement) sachant que pour chaque personne j’ai sa date d’inscription et sa date de fin de stage.
Messages postés
24897
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 février 2020
5 042
Alors déposez un modèle en bidouillant les données si confidentielles ici, sans ça, difficile de vous aider
http://mon-partage.fr
et revenez coller le lien créé sur le site
à vous lire
crdlmnt
Elodiiie08
Messages postés
3
Date d'inscription
dimanche 2 février 2020
Statut
Membre
Dernière intervention
2 février 2020

https://mon-partage.fr/f/0YAHdGHh/

La liste n’est pas exhaustive, c’est un exemple mais le format est celui indiqué.
Pour information, il y a un peu moins de dix entraîneurs et 2 types de sports.

J’ai besoin de savoir le nombre de personne par entraîneur pour chaque mois de l’année et si je peux distinguer ce nombre pour chaque sport c’est encore mieux.
Messages postés
11781
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
21 février 2020
1 670
Bonjour Elodie
Coucou Vaucluse

Je ne peux pas lire ton fichier qui n'est pas un fichier Excel
Un exemple sur Excel, à adapter à ton fichier
https://mon-partage.fr/f/MKr5oAHm/

Cdlmnt
Via
Elodiiie08
Messages postés
3
Date d'inscription
dimanche 2 février 2020
Statut
Membre
Dernière intervention
2 février 2020

Je vous remercie beaucoup pour votre aide précieuse.

Bonne soirée à vous.