Somme prod si [Résolu]

Signaler
-
Mike-31
Messages postés
17011
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
27 janvier 2020
-
Bonjour à tous,

Je suis actuellement bloqué sur une formule Excel.

J'ai une formule qui marche très bien qui est:
=SOMMEPROD((Feuil1!$D$2:$D$15000=C3)*(Feuil1!$N$2:$N$15000))

Cette formule calcule dans la Feuil1 la somme des valeurs de la colonne N si les valeurs dans la colonne D = C3 (C3 = une date donnée).

Colonne D: format Date
Colonne N: valeur en nombre

Je voudrais une deuxième formule qui calcule cette même somme mais si seulement la valeur de la cellule d'à côté (Colonne E) est non vide.

Avez-vous des idées?

Je vous remercie;

2 réponses

Messages postés
17011
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
27 janvier 2020
3 772
Bonjour,

comme cela
=SOMMEPROD(($D$2:$D$15000=C3)*($E$2:$E$15000<>"")*($N$2:$N$15000))

si ta formule est dans le même onglet tu peux supprimer Feuil1!

A+
Mike-31

Je suis responsable de ce que je dis, pas de ce que tu comprends...
Bonjour Mike et merci beaucoup ça fonctionne parfaitement :)

Encore merciii
Messages postés
17011
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
27 janvier 2020
3 772
Re,

tu peux également utiliser cette formule SOMME.SI.ENS moins gourmande en ressource que SOMMEPROD

=SOMME.SI.ENS($N$2:$N$15000;$D$2:$D$15000;C3;$E$2:$E$15000;"<>")