Fonction SI avec mois

Signaler
Messages postés
4
Date d'inscription
samedi 4 janvier 2020
Statut
Membre
Dernière intervention
4 janvier 2020
-
JulianD72
Messages postés
4
Date d'inscription
samedi 4 janvier 2020
Statut
Membre
Dernière intervention
4 janvier 2020
-
Bonjour à tous,

Je rencontre actuellement un problème Excel qui au-delà d'être un problème excel me semble être un problème de logique.

Voilà le PB quelque peu simplifié :

Je souhaite appliquer une formule SI très simple afin d'obtenir VRAI ou FAUX selon un test logique faisant référence à des mois.

En clair, SI(Mois B6 < Mois C3;VRAI;FAUX) et ainsi de suite pour les 12 mois de l'année (De B6 à B17).
La cellule B6 étant le mois de Janvier, B7 Février, B8 Mars.
Ces cellules sont au format personnalisé mmmm donc 01/01/1900 ; 01/02/1900...
La cellule C3 étant mon mois de référence tiré d'une autre cellule (C1) et faisant dans ce cas référence à Mars. La formule de C3 dit donc = MOIS(C1)
La cellule C1 indique le 01/03/2020

J'ai essayé deux types de formule :

Les 1ères sans la fonction MOIS et qui disent ceci :
=SI(B6<C3;VRAI;FAUX) -> VRAI
=SI(B7<C3;VRAI;FAUX) -> FAUX
=SI(B8<C3;VRAI;FAUX) -> FAUX

Cela ne fonctionne donc pas car la deuxième formule devrait dire VRAI puisque B7 = Février et que C3 = Mars et que Février, selon toute logique, est inférieur à Mars (comme Janvier).

Les 2ndes avec la fonction MOIS et qui disent ceci :
=SI(MOIS(B6)<C3;VRAI;FAUX) -> VRAI
=SI(MOIS(B7)<C3;VRAI;FAUX) -> FAUX
=SI(MOIS(B8)<C3;VRAI;FAUX) - FAUX

Qui ne fonctionnent pas non plus (même pb que les premières).

Quelqu'un aurait-ils des pistes de réflexion/une aide à m'apporter ?

Bien à vous,

Julian

3 réponses

Messages postés
658
Date d'inscription
lundi 22 septembre 2008
Statut
Membre
Dernière intervention
24 janvier 2020
106
JulianD72
Messages postés
4
Date d'inscription
samedi 4 janvier 2020
Statut
Membre
Dernière intervention
4 janvier 2020

WOW.
J'ai envie de vous dire merci beaucoup parce que cela marche mais pas de mon côté malheureusement.
Vous trouverez mon fichier sur Excel-pratique, j'ai pu le joindre et dedans les mêmes combinaisons que vous, pour autant cela ne marche pas pour Février...
JulianD72
Messages postés
4
Date d'inscription
samedi 4 janvier 2020
Statut
Membre
Dernière intervention
4 janvier 2020

Je viens de trouver, en réalité, j'ai fait une faute de frappe dans mes cellules. G6 faisait ref à Mars au lieu de Fev normalement d'où le FAUX.
Après avoir refait le test ça fonctionne !
Merci pour votre temps et vos réponse en tout cas.
Bien à vous,
Julian
Messages postés
658
Date d'inscription
lundi 22 septembre 2008
Statut
Membre
Dernière intervention
24 janvier 2020
106
Bonjour,

Pour ceux-ci, normal
Les 1ères sans la fonction MOIS et qui disent ceci :
=SI(B6<C3;VRAI;FAUX) -> VRAI
=SI(B7<C3;VRAI;FAUX) -> FAUX
=SI(B8<C3;VRAI;FAUX) -> FAUX


Pour les secondes
=SI(MOIS(B6)<C3;VRAI;FAUX) -> VRAI
=SI(MOIS(B7)<C3;VRAI;FAUX) -> FAUX ==> ICI C'est VRAI
=SI(MOIS(B8)<C3;VRAI;FAUX) - FAUX

Mais je pense que tu as tiré la formule vers le bas, sans figer la cellule C3 donc C3 devient C4 etc...

=SI(MOIS(B6)<$C$3;VRAI;FAUX)

A tirer vers le bas
Messages postés
4
Date d'inscription
samedi 4 janvier 2020
Statut
Membre
Dernière intervention
4 janvier 2020

Bonjour,

Pour répondre, j'ai bien figé mes cellules, j'ai même fait un fichier simplifié qui reprend le pb mais je ne peux pas le mettre en pj ici.
En tout cas, c'est bien C3 partout, j'ai enlevé les $ pour que ce soit plus lisible pour vous.

Bien à vous,

Julian