Erreur formule excel [Résolu]

Messages postés
13
Date d'inscription
dimanche 29 septembre 2019
Statut
Membre
Dernière intervention
4 octobre 2019
- - Dernière réponse : Eljojob
Messages postés
13
Date d'inscription
dimanche 29 septembre 2019
Statut
Membre
Dernière intervention
4 octobre 2019
- 4 oct. 2019 à 14:39
Bonjour,

Je fonctionne avec un fichier excel avec plusieurs onglets. Dans l'onglet boîte, j'inscris à la colonne C un code de 3 chiffres ou 3 lettres. La description de ce code doit s'inscrire automatiquement dans la colonne D de l'onglet boîte.

La description qui doit se faire automatiquement se retrouve dans l'onglet statistiques. Voici la formule que j'utilise. Elle fonctionne pour une partie des codes seulement. Devrais-je utiliser une autre formule. Voici ce que j'utilise actuellement:

=SI(C3="";"";RECHERCHE($C3;Statistiques!$A$8:$A$30;Statistiques!$B$8:$B$30))

Merci.
Afficher la suite 

3 réponses

Messages postés
11201
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
15 octobre 2019
1455
0
Merci
Bonjour

Ce serait plutôt une formule de RECHERCHEV qu'il faudrait utiliser style =RECHERCHEV($C3;Statistiques!$A$8:$B$30;2;0)

Impossible de t'aider plus sans avoir un exemple de ton fichier
Poste cet exemple sur mon-partage.fr, copie le lien créé et reviens le coller ici

Cdlmnt
Via
Eljojob
Messages postés
13
Date d'inscription
dimanche 29 septembre 2019
Statut
Membre
Dernière intervention
4 octobre 2019
-
Bonjour,

Voici le lien de mon fichier. J'ai surligneur en jaune les codes dont les descriptions ne fonctionnent pas.
Eljojob
Messages postés
13
Date d'inscription
dimanche 29 septembre 2019
Statut
Membre
Dernière intervention
4 octobre 2019
-
Commenter la réponse de via55
Messages postés
2131
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
15 octobre 2019
429
0
Merci
Bonsoir,

Si la description du code se trouve, comme je l'entrevoie, dans la colonne B du feuillet "statistiques" on peut utiliser la RECHERCHEV

=SIERREUR(RECHERCHEV($C3;Statistiques!$A$8:$B$30;2;0);"")

Cordialement
PapyLuc51
Messages postés
2131
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
15 octobre 2019
429 -
J'ai vu le fichier après coup, c'est bien ce que je pensais

Cordialement
Eljojob
Messages postés
13
Date d'inscription
dimanche 29 septembre 2019
Statut
Membre
Dernière intervention
4 octobre 2019
-
La formule a fonctionné pour quelques uns....... un vrai mystère......
PapyLuc51
Messages postés
2131
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
15 octobre 2019
429 -
Bonjour,
Salutations en retour Via55

Un tout petit ajout à la formule pour éviter que D3 se remplisse si C3 l'est aussi et vu qu'il y a un code "0"

Formule installée jusqu'à C5000

=SI(C3="";"";SIERREUR(RECHERCHEV($C3;Statistiques!$A$8:$B$30;2;0);""))

https://www.cjoint.com/c/IJecNSOEtXv

Cordialement
PapyLuc51
Messages postés
2131
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
15 octobre 2019
429 -
pardon lire """ Formule installée jusqu'à D5000 ""

Cordialement
Eljojob
Messages postés
13
Date d'inscription
dimanche 29 septembre 2019
Statut
Membre
Dernière intervention
4 octobre 2019
-
Un très grand merci. Je suis très heureuse d'avoir découvert ce forum.
Commenter la réponse de PapyLuc51
Messages postés
11201
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
15 octobre 2019
1455
0
Merci
Re,

C'est ce que je disais et que confirmait PapyLuc que je salue au passage ☺, en D3 formule :
=SI(C3="";"";RECHERCHEV(C3;Statistiques!A$8:B$30;2;0))

Cdlmnt
Eljojob
Messages postés
13
Date d'inscription
dimanche 29 septembre 2019
Statut
Membre
Dernière intervention
4 octobre 2019
-
Merci !
Commenter la réponse de via55