Création d’une formule particulière [Résolu]

Messages postés
7
Date d'inscription
samedi 24 août 2019
Statut
Membre
Dernière intervention
27 août 2019
- - Dernière réponse : Rescue01
Messages postés
7
Date d'inscription
samedi 24 août 2019
Statut
Membre
Dernière intervention
27 août 2019
- 27 août 2019 à 17:12
Bonjour,

J’ai un tableau avec des colonnes d’heure de début de travail et de fin de travail que je complète régulièrement. Je veux créer une colonne qui cette fois ci pourra contenir une formule qui établira que entre mes heures de début et fin si constate que je travaille durant les heures suivantes: 07:00 , 12:00 et 17:00. Une annotation ira s’inscrire Dans la colonne Allocation sous forme petit déjeuner, déjeuner et dîner.

Si elle détecte que le 07:00 elle écrira petit déjeuner, même principe pour le 12:00 ou le 17:00 . Si elle détecte deux valeurs elle les indiquera, si elle détectent les trois, elle indiquent les trois.

Exemple: début 06:30 Fin 18:00 , une troisième colonne nommée Allocation calcule et indique que j’ai droit à petit déjeuner, déjeuner et dîner.

Si je change ma valeur pour début a 11:00 et fin 16:00 .Elle calculera et affichera le résultat Déjeuner.

Merci de votre aide précieuse
Afficher la suite 

2 réponses

Meilleure réponse
1
Merci
Bonjour,
Ma réponse à votre post (Trigo) du 24/08 à 20:14 était-elle conforme à votre demande ?

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 62878 internautes nous ont dit merci ce mois-ci

Rescue01
Messages postés
7
Date d'inscription
samedi 24 août 2019
Statut
Membre
Dernière intervention
27 août 2019
-
Merci à vous Nestor.
J'aurais voulu savoir si l'exemple que je vous ai posté répondait à la question....
Rescue01
Messages postés
7
Date d'inscription
samedi 24 août 2019
Statut
Membre
Dernière intervention
27 août 2019
-
Oui je crois que je vous ai répondu il y a quelques heures.
Bonne journée!
Commenter la réponse de nestor
Messages postés
26937
Date d'inscription
mercredi 2 mai 2007
Statut
Modérateur
Dernière intervention
15 octobre 2019
5553
0
Merci
Bonjour,

A1/B1 debut/fin, voir :
=SI(ET(A1<="07:00"+0;B1>="07:00"+0);"Petit-Déjeuner ";"")&SI(ET(A1<="12:00"+0;B1>="12:00"+0);"Déjeuner ";"")&SI(ET(A1<="17:00"+0;B1>="17:00"+0);"Diner ";"") 


Rescue01
Messages postés
7
Date d'inscription
samedi 24 août 2019
Statut
Membre
Dernière intervention
27 août 2019
-
Merci Jee pee
Commenter la réponse de jee pee