Menu

[Excel] Recherche dans une liste de mot associé à une valeur [Résolu]

Messages postés
1
Date d'inscription
mercredi 3 juillet 2019
Statut
Membre
Dernière intervention
3 juillet 2019
-
Bonjour,

Je vous présente mon problème avec un exemple:
Imaginons que je veuille calculer la pluviométrie dans les villes de France.

Je me retrouverai alors avec :
- Une colonne A pour le nom des Villes
- Une colonne B pour le taux de pluie.

Mon problème est le suivant : Comment faire pour que lorsque je note dans une 3e colonne C le nom d'une ville j'obtienne aussi sa valeur associé à son taux de pluie qui s'afficherai alors dans une colonne D ?

J'attend vos réponses avec impatiente

merci d'avance
Afficher la suite 

2 réponses

Messages postés
49338
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
16 juillet 2019
10251
0
Merci
Salut.

C'est le B-A-BA d'Excel : utilisation de la fonction RECHERCHEV ...

https://www.commentcamarche.net/faq/24720-fonction-recherchev-sur-excel

C'est bien, la retraite ! Surtout aux Antilles ... 
Raymond (INSA, AFPA)
Commenter la réponse de Raymond PENTIER
Messages postés
1985
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
10 juillet 2019
382
0
Merci
Bonjour,

C'est la formule RECHERCHEV() qu'il faut

Pour une zone de recherche A2:B100 par exemple - le nome de la ville en C2 - donc en D2

=SIERREUR(RECHERCHEV($C$2,$A$2:$B$100;2;0);"")

Le SIERREUR est là pour laisser la case D2 vide si la ville inscrite en C2 n'est pas dans la liste de la colonne A ou si dans la colonne B le résultat d'une ville est absent.

Cordialement
Commenter la réponse de PapyLuc51