Formule de controle

- - Dernière réponse : Vaucluse
Messages postés
24281
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
15 août 2019
- 4 juil. 2019 à 14:28
Bonjour,


Je me permets de vous sollicite car je bloque sur un variable de contrôle.
J'ai un fichier avec plusieurs onglet
onglet A : le nombre de jours d'ancienneté par salarié sous forme de tableau à double entrée
Onglet B calendrier qui permet de suivre tout les jours pris par les salariés avec une zone de contrôle.

Exemple: le nombre de Congés payées est dépassé le mot épuisé apparait en rouge
pour les jours d'ancienneté acquis, je cherche une formule qui afficherait un message en fonction du nombre affiché
ex:
Onglet B
=> le salarié A => 4 jours d'ancienneté
=> le salarié B => 1 jours d'ancienneté
Onglet A le calendrier affiché est celui du salarié B avec un solde de Jour d'ancienneté différent.

l'idée c'est que dés que je change de salarié, il y a un contrôle en fonction du nombre de jour acquis par le salarié

j ene sais pas si mon explication est claire :-/

Merci d'avance

Configuration: Windows / Edge 18.17763
Afficher la suite 

5 réponses

Messages postés
10952
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
16 août 2019
1367
0
Merci
Bonjour

Pas complétement limpide
Si tu veux une aide efficace il faut fournir ton fichier (avec des noms bidons si nécessaire) en le postant sur mon-partage.fr, faire créer un lien, le copier et revenir le coller ici en donnant 2 exemples de salariés avec des ancienneté différente et les résultats attendus dans chacun des cas

Cdlmnt
Via
golda1805
Messages postés
2
Date d'inscription
vendredi 28 juin 2019
Statut
Membre
Dernière intervention
28 juin 2019
-
plusieurs onglets sont lies a ces deux fichiers ça risque d'être compliqué :-(
golda1805
Messages postés
2
Date d'inscription
vendredi 28 juin 2019
Statut
Membre
Dernière intervention
28 juin 2019
-
on va essayé de faire comme ça.
j'ai mis cette formule de contrôle dans une cellule de l'onglet A :
=+SI(AO20='Liste des salariés'!C5;"SOLDE";SI(AO20>'Liste des salariés'!C5;"DEPASSE";""))
Le souci c'est que ça ne fonction que pour le salarié de la ligne 5 de l'onglet B
( les noms des salariés sont en colonne B et le nombre de jours acquis en C)
le but est que si je change de salarié dans l'onglet A, la formule de contrôle s'adapte au salarié.

:) c'est mieux?
Commenter la réponse de via55
Messages postés
10952
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
16 août 2019
1367
0
Merci
Si le nom du salarié est en B il doit être possible de retrouver sa ligne dans Liste des salariés grâce à une RECHERCHEV
Impossible de donner la bonne solution sans avoir une version même simplifiée de ton fichier avec la feuille de calcul et la feuille Liste des salariés au moins (si les autres ne servent pas dans le calcul des congés elle sont sans intér^t)
Commenter la réponse de via55
Messages postés
24281
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
15 août 2019
4714
0
Merci
Bonjour
on va essayez avec RECHERCHEV sans garanties

onglet A, le nom du salarié en A1 à adapter:

=SI(RECHERCHEV(A1;'Liste des salariés'!B:C;2;0)=AO20;"SOLDE";SI(RECHERCHEV(A1;'Liste des salariés'!B:C;2;0)>AO20;"DEPASSE";"EN COURS"))

crdlmnt
Commenter la réponse de Vaucluse
0
Merci
Bonjour,

Désolé pour ma réponse tardive.
Malheureusement ça ne marche pas. Le message reste sur solde.

Merci pour votre aide je vais essayer de trouver un autre moyen

????????
Commenter la réponse de GOLDANGOKANG
Messages postés
24281
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
15 août 2019
4714
0
Merci
si vous ne dites pas ce qui ne fonctionne pas, ou si vous ne mettez pas de données à disposition que l'on voit ce qu''il se passe, on ne pourra pas vous aider
bonne chance
crdlmnt
Commenter la réponse de Vaucluse