Pb avec la fonction SI

Messages postés
1
Date d'inscription
lundi 3 juin 2019
Statut
Membre
Dernière intervention
3 juin 2019
- - Dernière réponse : Mike-31
Messages postés
16951
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
13 octobre 2019
- 3 juin 2019 à 22:20
Bonsoir,
voici mon problème, j'aimerai récupérer les 6 premiers caractères d'une cellule à condition que ce soient des chiffres.
J'ai essayé la fonction SI Gauche mais les chiffres sont toujours différents donc je ne peux pas les identifier dans ma fonction
En clair, je voudrai écrire "si les 6 premiers caractères sont des chiffres alors copie, sinon met 0" ou "si les 6 premiers caractères sont des lettres (qui sont toujours différentes) alors met 0, sinon copie"
Je ne connais pas la syntaxe pour spécifier que la chaîne de caractère est numérique ou non, ou du texte ou pas.
Merci de votre aide
Afficher la suite 

2 réponses

Messages postés
1491
Date d'inscription
lundi 13 juillet 2009
Statut
Membre
Dernière intervention
24 juillet 2019
375
0
Merci
Salut,

Essai quelque chose comme ça :
=SI(ESTNUM(GAUCHE("A1";6))=VRAI;GAUCHE("A1";6);0)

J'ai pas excel sous la main pour vérifier l'exactitude de la formule mais dans l'idée c'est comme ça que je l'imagine.

Commenter la réponse de ozone_
Messages postés
16951
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
13 octobre 2019
3628
0
Merci
Bonsoir,

regarde comme cela

=SI(ESTNUM(GAUCHE(A1;6)*1);GAUCHE(A1;6)*1;0)
Commenter la réponse de Mike-31