Résultat suivant 2 conditions [Résolu]

Messages postés
36
Date d'inscription
lundi 22 avril 2019
Statut
Membre
Dernière intervention
10 juin 2019
- - Dernière réponse : ccm81
Messages postés
9059
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
18 août 2019
- 23 avril 2019 à 10:58
Bonjour,
Je souhaiterai obtenir le résultat suivant le mois (P2) et l'arrondissement (Q2).
Et pour la colonne N2 à N23 y a t'il une formule pour obtenir le résultat suivant P2?
https://www.cjoint.com/c/IDwo3TNi5hP
Par avance, merci beaucoup pur votre aide.
Cordialement,
Momo
Afficher la suite 

8 réponses

Meilleure réponse
Messages postés
132
Date d'inscription
mardi 21 août 2018
Statut
Membre
Dernière intervention
19 août 2019
26
1
Merci
Alors pour le résultat en fonction du mois et de de l'arrondissement : =RECHERCHEV(Q2;A3:M23;P2+1)
Pour le résultat N2 à N23 en fonction de P2, en gros tu veux le total pour le mois/arrondissement sélectionné ?
Dans ce cas en adaptant la formule précédente : =RECHERCHEV(Q2;A3:N23;14)

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 57989 internautes nous ont dit merci ce mois-ci

SioGabx
Messages postés
132
Date d'inscription
mardi 21 août 2018
Statut
Membre
Dernière intervention
19 août 2019
26 -
PS pour te total utilise plutôt la formule en N3 que tu peux faire glisser jusqu'en N23 : =SOMME(B3:M3)
Commenter la réponse de SioGabx
Messages postés
9059
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
18 août 2019
1607
1
Merci
Bonjour à tous les deux

Pour la première question
https://www.cjoint.com/c/IDwpv5XQAcB

Pour la deuxième
Il faudra expliquer un peu plus

Cdlmnt

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 57989 internautes nous ont dit merci ce mois-ci

ccm81
Messages postés
9059
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
18 août 2019
1607 -
Et pour la question 2, peut être ceci
https://www.cjoint.com/c/IDwpC0ait8B
Cdlmnt
SioGabx
Messages postés
132
Date d'inscription
mardi 21 août 2018
Statut
Membre
Dernière intervention
19 août 2019
26 -
Je connaissait pas INDEX, ça à l'air plus propre que moi mais plus difficile x)
ccm81
Messages postés
9059
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
18 août 2019
1607 -
La combinaison INDEX-EQUIV s'utilise lorsque la colonne de recherche n'est pas la première du tableau.
Dans notre cas, j'ai dû me laisser aller, RECHERCHEV est plus simple ;-)
momo189
Messages postés
36
Date d'inscription
lundi 22 avril 2019
Statut
Membre
Dernière intervention
10 juin 2019
-
Je te remercie ccm81, serait-il possible d'obtenir le cumul dans P5 selon le mois et l'arrondissement?
Commenter la réponse de ccm81
Messages postés
49611
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
19 août 2019
10436
1
Merci
" je souhaiterai obtenir le résultat suivant le mois (P2) et l'arrondissement (Q2) "
Tu veux ça en P5 ? Et dans ton exemple ce serait pour le mois de mars (P2), mais pour quel arrondissement ? Quel résultat devrait s'afficher en P5 ?

Si tu veux les 20 résultats en colonne R:R, il faut saisir en R4 la formule
=RECHERCHEV(Q4;$A$3:$N$23;P$2+1;0) et recopier vers le bas.

Je ne sais pourquoi tu as saisi manuellement les valeurs en colonne N:N au lieu d'utiliser une formule d'addition ; d'ailleurs tes valeurs en N3:N6 sont fausses ...

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 57989 internautes nous ont dit merci ce mois-ci

momo189
Messages postés
36
Date d'inscription
lundi 22 avril 2019
Statut
Membre
Dernière intervention
10 juin 2019
-
Bonjour Raymond, je te remercie de ton aide. Pourrais-tu SVP m'expliquer le (+1;0)? ça correspond à quoi?
Merci encore...
Cordialement,
Momo
Raymond PENTIER
Messages postés
49611
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
19 août 2019
10436 -
C'est le N° de colonne.
Le mois de mars (3) est en colonne D (4) ...
Commenter la réponse de Raymond PENTIER
Messages postés
9059
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
18 août 2019
1607
1
Merci
Peux tu expliquer ce que tu entends par "cumul" ?
dans P5, je souhaiterai le cumul suivant le mois et l'arrondissement...
Le mieux est de donner un exemple avec le résultat attendu.

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 57989 internautes nous ont dit merci ce mois-ci

ccm81
Messages postés
9059
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
18 août 2019
1607 -
momo189
Messages postés
36
Date d'inscription
lundi 22 avril 2019
Statut
Membre
Dernière intervention
10 juin 2019
-
C'est tout à fait ça... un grand merci à toi et tous.
Afin que je puisse comprendre aurais tu l'amabilité d'interpréter cette formule SVP?
ccm81
Messages postés
9059
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
18 août 2019
1607 -
DECALER(Feuil1!$A$2;EQUIV(Feuil1!$Q$2;Feuil1!$A$3:$A$23);1;1;EQUIV(Feuil1!$P$2;Feuil1!$B$2:$M$2;0))
définit dynamiquement la plage
1. à partir de la cellule $A$2
2. dont la première cellule est décalée
2.1. de EQUIV(Feuil1!$Q$2;Feuil1!$A$3:$A$23) lignes < rang de $Q$2 dans la plage $A$3:$A$23>
2.2. et de 1 colonne
3. et contenant
3.1. 1 ligne
3.2. et EQUIV(Feuil1!$P$2;Feuil1!$B$2:$M$2;0) colonnes <rang de $P$2 dans la plage $B$2:$M$2>

Cdlmnt

.
momo189
Messages postés
36
Date d'inscription
lundi 22 avril 2019
Statut
Membre
Dernière intervention
10 juin 2019
-
En toute sincérité encore un grand merci pour toutes tes explications, je te souhaite une excellente soirée.
Cordialement,
Momo
ccm81
Messages postés
9059
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
18 août 2019
1607 -
De rien

Si c'est fini, peux tu mettre le sujet à résolu (en haut à droite, la roue dentée)

Bonne journée
Commenter la réponse de ccm81
Messages postés
49611
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
19 août 2019
10436
1
Merci
Si ce que tu n'as cessé, avant le post #15, d'appeler "résultat" est en réalité "cumul" ou "somme" , alors la formule en ligne 3 est tout simplement
=SOMME(B3:DECALER(B3;0;$P$2))
C'est bien, la retraite ! Surtout aux Antilles ... 
Raymond (INSA, AFPA)

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 57989 internautes nous ont dit merci ce mois-ci

Commenter la réponse de Raymond PENTIER
Messages postés
49611
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
19 août 2019
10436
0
Merci
Bonjour.

Pourrais-tu reformuler tes questions ?
Je n'arrive pas à comprendre ce que tu veux !
Commenter la réponse de Raymond PENTIER
Messages postés
36
Date d'inscription
lundi 22 avril 2019
Statut
Membre
Dernière intervention
10 juin 2019
0
Merci
Merci beaucoup, pour toutes les propositions dans P5, je souhaiterai le cumul suivant le mois et l'arrondissement...
Cordialement,
Momo189
Commenter la réponse de momo189
Messages postés
36
Date d'inscription
lundi 22 avril 2019
Statut
Membre
Dernière intervention
10 juin 2019
0
Merci
J'ai essayé la formule dans P10 =SOMME.SI(INDEX($B$3:$M$23;EQUIV($Q$2;$A$3:$A$23;0);EQUIV($P$2;$B$2:$M$2;0) celle-ci ne fonctionne pas...
Commenter la réponse de momo189