Menu

Faire une suite rapide avec une formule [Résolu]

Messages postés
11
Date d'inscription
jeudi 4 avril 2019
Statut
Membre
Dernière intervention
9 avril 2019
- - Dernière réponse : rorken
Messages postés
11
Date d'inscription
jeudi 4 avril 2019
Statut
Membre
Dernière intervention
9 avril 2019
- 5 avril 2019 à 11:09
Bonjour,
J'utilise la formule ='001'$G$2 dans un fichier excel qui me permet d'aller rechercher ce que j'ai noté dans une autre feuille du même classeur, par contre, je dois remplacer la valeur de ma feuille '001' pour chaque cellule de ma colonne. N'y aurais-t'il pas une formule pour faire une suite logique ?
Afficher la suite 

Votre réponse

2 réponses

Meilleure réponse
Messages postés
23870
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 avril 2019
5764
1
Merci
Bonjour
en principe le G ne doit pas bouger sui vous ne changez pas de colonne, mais vous ne précisez pas ce qu'il faut faire du 2

alors deux cas, qui changeront le nom de la feuille à chaque ligne

1° si le G2 est figé:
=INDIRECT(TEXTE(LIGNE(A1);"000")&"!G2"

2° cas si le 2 n'est pas figé et doit donc passer à 3,4 etc..
=INDIRECT(TEXTE(LIGNE(A1);"000")&"!G"&LIGNE(A2))


à complèter avec:

=SIERREUR(formule);"") pour éviter un affichage d'erreur si la feuille n'existe pas

crdlmnt

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 40432 internautes nous ont dit merci ce mois-ci

rorken
Messages postés
11
Date d'inscription
jeudi 4 avril 2019
Statut
Membre
Dernière intervention
9 avril 2019
-
Bonjour,

Magnifique, le 1° cas est le bon vous me retirer une belle épine du pied, un grand merci.

Cordialement
rorken
Messages postés
11
Date d'inscription
jeudi 4 avril 2019
Statut
Membre
Dernière intervention
9 avril 2019
-
Bonjour,

Pour du texte ça marche, mais j'ai un autre fichier où cela ne marche pas. C'st peut-être du à ce que se soit des chiffre non ?

Cdlmnt
Commenter la réponse de Vaucluse
Messages postés
1894
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
22 avril 2019
466
0
Merci
Bonjour

Je ne sais pas si j'ai tout compris mais peut-être enlever le $ devant le 2

='001'!$G2

Cordialement
rorken
Messages postés
11
Date d'inscription
jeudi 4 avril 2019
Statut
Membre
Dernière intervention
9 avril 2019
-
Bonjour à toi, merci mais le problème s'est que je veux faire une suite par rapport a ma feuille qui est intituler '001' car si j'enlève mon $ s'est la valeur de ma cellule qui bouge.
PapyLuc51
Messages postés
1894
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
22 avril 2019
466 > rorken
Messages postés
11
Date d'inscription
jeudi 4 avril 2019
Statut
Membre
Dernière intervention
9 avril 2019
-
Alors envoie une copie anonymisée de ton fichier en créant un lien de téléchargement sur l'un des deux sites ci-dessous - lien à copier et venir coller sur le prochain post

https://www.cjoint.com/

https://mon-partage.fr/

Cordialement
rorken
Messages postés
11
Date d'inscription
jeudi 4 avril 2019
Statut
Membre
Dernière intervention
9 avril 2019
> PapyLuc51
Messages postés
1894
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
22 avril 2019
-
Re,

Ci-joint le lien pour le fichier.

https://www.cjoint.com/c/IDensMbIddf

Cordialement
PapyLuc51
Messages postés
1894
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
22 avril 2019
466 > rorken
Messages postés
11
Date d'inscription
jeudi 4 avril 2019
Statut
Membre
Dernière intervention
9 avril 2019
-
Re,

Vaucluse (salutations) a donné la bonne formule dans son message #4

En B8

=SIERREUR(INDIRECT(TEXTE(LIGNE(A1);"000")&"!G2");"")

Cordialement
Commenter la réponse de PapyLuc51